]> git.pld-linux.org Git - packages/feathercoin.git/commitdiff
- up to 0.16.3 auto/th/feathercoin-0.16.3-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Sep 2018 18:50:35 +0000 (20:50 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Sep 2018 18:50:35 +0000 (20:50 +0200)
feathercoin-c++.patch [deleted file]
feathercoin-zxing.patch [deleted file]
feathercoin.spec
lib.patch [new file with mode: 0644]
x32.patch [deleted file]

diff --git a/feathercoin-c++.patch b/feathercoin-c++.patch
deleted file mode 100644 (file)
index 5900745..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- Feathercoin-0.9.6/src/db.cpp.orig  2017-04-16 13:38:15.712488228 +0200
-+++ Feathercoin-0.9.6/src/db.cpp       2017-04-16 13:38:19.465821520 +0200
-@@ -44,7 +44,7 @@
-     if (ret != 0)
-         LogPrintf("CDBEnv::EnvShutdown : Error %d shutting down database environment: %s\n", ret, DbEnv::strerror(ret));
-     if (!fMockDb)
--        DbEnv(0).remove(path.string().c_str(), 0);
-+        DbEnv(0u).remove(path.string().c_str(), 0);
- }
- CDBEnv::CDBEnv() : dbenv(DB_CXX_NO_EXCEPTIONS)
diff --git a/feathercoin-zxing.patch b/feathercoin-zxing.patch
deleted file mode 100644 (file)
index 69a5d5e..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- Feathercoin-0.9.6/src/qt/qimagesource.cpp.orig     2017-01-30 17:11:35.000000000 +0100
-+++ Feathercoin-0.9.6/src/qt/qimagesource.cpp  2017-04-16 22:11:31.628803262 +0200
-@@ -16,11 +16,11 @@
- ArrayRef<char> QImageLuminanceSource::getMatrix() const
- {
--    ArrayRef<char> mymatrix(width*height);
--    for (int y = 0; y < height; y++)
-+    ArrayRef<char> mymatrix(getWidth()*getHeight());
-+    for (int y = 0; y < getHeight(); y++)
-     {
--        for (int x = 0; x < width; x++) {
--            mymatrix[y*width+x] = qGray(image.pixel(x, y));
-+        for (int x = 0; x < getWidth(); x++) {
-+            mymatrix[y*getWidth()+x] = qGray(image.pixel(x, y));
-         }
-     }
-     return mymatrix;
index 4c80117d3128927e0c0b3335c3a34ce0adc495ce..a7d157a29cee023335b4c701b9ba0335d56cfc75 100644 (file)
@@ -7,16 +7,14 @@
 Summary:       Feathercoin - a peer-to-peer currency
 Summary(pl.UTF-8):     Feathercoin - waluta peer-to-peer
 Name:          feathercoin
-Version:       0.9.6
-Release:       5
+Version:       0.16.3
+Release:       1
 License:       MIT
 Group:         Applications/Networking
 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
 Source0:       https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 9ac8509ab7bc7fb39b8e9d474a1079e3
-Patch0:                %{name}-c++.patch
-Patch1:                %{name}-zxing.patch
-Patch2:                x32.patch
+# Source0-md5: eaecf6f317091f52fae0eff95ac3b7be
+Patch0:                lib.patch
 URL:           https://www.feathercoin.com/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5
@@ -34,15 +32,18 @@ BuildRequires:      boost-devel
 BuildRequires: db-cxx-devel >= 4.8
 BuildRequires: gettext-tools
 %{?with_gui:BuildRequires:     libpng-devel}
+BuildRequires: libsecp256k1-devel
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: libunivalue-devel
 BuildRequires: miniupnpc-devel >= 1.5
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: protobuf-devel
 BuildRequires: qrencode-devel
 %{?with_gui:BuildRequires:     qt5-build >= 5}
-BuildRequires: zxing-cpp-devel
 %{?with_gui:BuildRequires:     zlib-devel}
+BuildRequires: zxing-cpp-devel
 Requires:      perl-base
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -70,14 +71,10 @@ Oparty na Qt portfel Feathercoin.
 %prep
 %setup -q -n Feathercoin-%{version}
 %patch0 -p1
-%patch1 -p1
-%ifarch x32
-%patch2 -p1
-%endif
 
 %build
-install -d src/build-aux
-%{__aclocal} -I m4
+%{__libtoolize}
+%{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -86,7 +83,8 @@ install -d src/build-aux
        --enable-ccache%{!?with_ccache:=no} \
        --disable-silent-rules \
        --with-incompatible-bdb \
-       --with-gui=%{?with_gui:qt5}%{!?with_gui:no}
+       --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
+       --with-system-univalue
 
 %{__make}
 
@@ -99,26 +97,28 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,5},%{_desktopdir},%{_datadir}/kde4/services}
 sed -e 's#bitcoin#feathercoin#g;s#Bitcoin#Feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
 sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
-cp -p contrib/debian/manpages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
-cp -p contrib/debian/manpages/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc COPYING README.md doc/*.txt contrib/debian/examples/bitcoin.conf
 %attr(755,root,root) %{_bindir}/feathercoin-cli
+%attr(755,root,root) %{_bindir}/feathercoin-tx
 %attr(755,root,root) %{_bindir}/feathercoind
-%attr(755,root,root) %{_bindir}/test_bitcoin
 %{_mandir}/man1/feathercoin-cli.1*
+%{_mandir}/man1/feathercoin-tx.1*
 %{_mandir}/man1/feathercoind.1*
-%{_mandir}/man5/feathercoin.conf.5*
+%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
+%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*
 
 %files qt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/feathercoin-qt
-%attr(755,root,root) %{_bindir}/test_bitcoin-qt
 %{_datadir}/kde4/services/feathercoin-qt.protocol
 %{_desktopdir}/feathercoin-qt.desktop
 %{_mandir}/man1/feathercoin-qt.1*
diff --git a/lib.patch b/lib.patch
new file mode 100644 (file)
index 0000000..a693e01
--- /dev/null
+++ b/lib.patch
@@ -0,0 +1,53 @@
+--- Feathercoin-0.16.3/configure.ac~   2018-09-22 09:16:24.000000000 +0200
++++ Feathercoin-0.16.3/configure.ac    2018-09-25 20:30:45.640038984 +0200
+@@ -1310,9 +1310,6 @@ if test x$need_bundled_univalue = xyes;
+   AC_CONFIG_SUBDIRS([src/univalue])
+ fi
+-ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no --enable-module-recovery --disable-jni"
+-AC_CONFIG_SUBDIRS([src/secp256k1])
+-
+ AC_OUTPUT
+ dnl Taken from https://wiki.debian.org/RpathIssue
+--- Feathercoin-0.16.3/configure.ac~   2018-09-25 20:31:22.000000000 +0200
++++ Feathercoin-0.16.3/configure.ac    2018-09-25 20:34:53.278016850 +0200
+@@ -972,6 +972,7 @@ if test x$use_pkgconfig = xyes; then
+       else
+           AC_DEFINE_UNQUOTED([ENABLE_ZMQ],[0],[Define to 1 to enable ZMQ functions])
+       fi
++      PKG_CHECK_MODULES([SECP256K1], [libsecp256k1],, [AC_MSG_ERROR(libsecp256k1 not found.)])
+     ]
+   )
+ else
+--- Feathercoin-0.16.3/src/Makefile.am~        2018-09-22 09:16:24.000000000 +0200
++++ Feathercoin-0.16.3/src/Makefile.am 2018-09-25 20:40:02.844966767 +0200
+@@ -2,7 +2,7 @@
+ # Distributed under the MIT software license, see the accompanying
+ # file COPYING or http://www.opensource.org/licenses/mit-license.php.
+-DIST_SUBDIRS = secp256k1 univalue
++DIST_SUBDIRS = univalue
+ AM_LDFLAGS = $(PTHREAD_CFLAGS) $(LIBTOOL_LDFLAGS) $(HARDENED_LDFLAGS)
+ AM_CXXFLAGS = $(HARDENED_CXXFLAGS) $(ERROR_CXXFLAGS)
+@@ -20,7 +20,7 @@ endif
+ BITCOIN_INCLUDES=-I$(builddir) $(BDB_CPPFLAGS) $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS) $(CRYPTO_CFLAGS) $(SSL_CFLAGS)
+-BITCOIN_INCLUDES += -I$(srcdir)/secp256k1/include
++BITCOIN_INCLUDES += $(SECP256K1_CFLAGS)
+ BITCOIN_INCLUDES += $(UNIVALUE_CFLAGS)
+ LIBBITCOIN_SERVER=libbitcoin_server.a
+@@ -30,8 +30,8 @@ LIBBITCOIN_CLI=libbitcoin_cli.a
+ LIBBITCOIN_UTIL=libbitcoin_util.a
+ LIBBITCOIN_CRYPTO=crypto/libbitcoin_crypto.a
+ LIBBITCOINQT=qt/libbitcoinqt.a
+-LIBSECP256K1=secp256k1/libsecp256k1.la
+-
++LIBSECP256K1=$(SECP256K1_LIBS)
++
+ if ENABLE_ZMQ
+ LIBBITCOIN_ZMQ=libbitcoin_zmq.a
+ endif
diff --git a/x32.patch b/x32.patch
deleted file mode 100644 (file)
index 460eacd..0000000
--- a/x32.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Feathercoin-0.9.6/m4/ax_boost_base.m4~     2017-01-30 17:11:35.000000000 +0100
-+++ Feathercoin-0.9.6/m4/ax_boost_base.m4      2017-04-17 21:11:55.828600021 +0200
-@@ -93,7 +93,7 @@
-     ax_arch=`uname -m`
-     case $ax_arch in
-       x86_64|ppc64|s390x|sparc64|aarch64)
--        libsubdirs="lib64 lib lib64"
-+        libsubdirs="libx32"
-         ;;
-     esac
This page took 0.118278 seconds and 4 git commands to generate.