]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
boost rebuild
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.9.6
11 Release:        3
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  9ac8509ab7bc7fb39b8e9d474a1079e3
17 Patch0:         %{name}-c++.patch
18 Patch1:         %{name}-zxing.patch
19 Patch2:         x32.patch
20 URL:            https://www.feathercoin.com/
21 %if %{with gui}
22 BuildRequires:  Qt5Core-devel >= 5
23 BuildRequires:  Qt5DBus-devel >= 5
24 BuildRequires:  Qt5Gui-devel >= 5
25 BuildRequires:  Qt5Network-devel >= 5
26 BuildRequires:  Qt5PrintSupport-devel >= 5
27 BuildRequires:  Qt5Test-devel >= 5
28 BuildRequires:  Qt5Widgets-devel >= 5
29 %endif
30 BuildRequires:  autoconf >= 2.69
31 BuildRequires:  automake
32 BuildRequires:  boost-devel
33 %{?with_ccache:BuildRequires:   ccache}
34 BuildRequires:  db-cxx-devel >= 4.8
35 BuildRequires:  gettext-tools
36 %{?with_gui:BuildRequires:      libpng-devel}
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  miniupnpc-devel >= 1.5
39 BuildRequires:  openssl-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  protobuf-devel
42 BuildRequires:  qrencode-devel
43 %{?with_gui:BuildRequires:      qt5-build >= 5}
44 BuildRequires:  zxing-cpp-devel
45 %{?with_gui:BuildRequires:      zlib-devel}
46 Requires:       perl-base
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
51 central authority issues new money or tracks transactions. These tasks
52 are managed collectively by the network.
53
54 %description -l pl.UTF-8
55 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
56 centralnego urzędu, który emituje nowe pieniądze czy śledzi
57 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
58
59 %package qt
60 Summary:        Qt-based Feathercoin Wallet
61 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
62 Group:          X11/Applications
63
64 %description qt
65 Qt-based Feathercoin Wallet.
66
67 %description qt -l pl.UTF-8
68 Oparty na Qt portfel Feathercoin.
69
70 %prep
71 %setup -q -n Feathercoin-%{version}
72 %patch0 -p1
73 %patch1 -p1
74 %ifarch x32
75 %patch2 -p1
76 %endif
77
78 %build
79 install -d src/build-aux
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
85 %configure \
86         --enable-ccache%{!?with_ccache:=no} \
87         --disable-silent-rules \
88         --with-incompatible-bdb \
89         --with-gui=%{?with_gui:qt5}%{!?with_gui:no}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,5},%{_desktopdir},%{_datadir}/kde4/services}
100 sed -e 's#bitcoin#feathercoin#g;s#Bitcoin#Feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
101 sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
102 cp -p contrib/debian/manpages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
103 cp -p contrib/debian/manpages/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc COPYING README.md doc/*.txt contrib/debian/examples/bitcoin.conf
111 %attr(755,root,root) %{_bindir}/feathercoin-cli
112 %attr(755,root,root) %{_bindir}/feathercoind
113 %attr(755,root,root) %{_bindir}/test_bitcoin
114 %{_mandir}/man1/feathercoin-cli.1*
115 %{_mandir}/man1/feathercoind.1*
116 %{_mandir}/man5/feathercoin.conf.5*
117
118 %files qt
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/feathercoin-qt
121 %attr(755,root,root) %{_bindir}/test_bitcoin-qt
122 %{_datadir}/kde4/services/feathercoin-qt.protocol
123 %{_desktopdir}/feathercoin-qt.desktop
124 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.105977 seconds and 3 git commands to generate.