]> git.pld-linux.org Git - packages/fdupes.git/commitdiff
up to 1.51 auto/th/fdupes-1.51-1
authorElan Ruusamäe <glen@delfi.ee>
Mon, 7 Apr 2014 18:01:44 +0000 (21:01 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 7 Apr 2014 18:01:44 +0000 (21:01 +0300)
fdupes-make.patch
fdupes.spec

index f0643e952cdaac7a8d7310ea92ba6afff842ea4e..e3bfd0b3c25bcc0153ca33280ad2884f1a6a8e2b 100644 (file)
@@ -1,41 +1,28 @@
---- fdupes-1.40/Makefile~      2006-05-19 21:15:32.000000000 +0300
-+++ fdupes-1.40/Makefile       2006-05-19 21:15:34.000000000 +0300
-@@ -2,13 +2,13 @@
- # INSTALLDIR indicates directory where program is to be installed. 
- # Suggested values are "/usr/local/bin" or "/usr/bin".
+--- fdupes-1.51/Makefile~      2013-04-20 20:51:58.000000000 +0300
++++ fdupes-1.51/Makefile       2014-04-07 20:59:52.580658642 +0300
+@@ -56,7 +56,7 @@
+ # MAN_DIR indicates directory where the fdupes man page is to be 
+ # installed. Suggested value is "$(PREFIX)/man/man1"
  #
--INSTALLDIR = /usr/local/bin
-+INSTALLDIR = /usr/bin
+-MAN_BASE_DIR = $(PREFIX)/man
++MAN_BASE_DIR = $(PREFIX)/share/man
+ MAN_DIR = $(MAN_BASE_DIR)/man1
+ MAN_EXT = 1
  
- #
- # MANPAGEDIR indicates directory where the fdupes man page is to be 
- # installed. Suggested values are "/usr/local/man" or "/usr/man".
- #
--MANPAGEDIR = /usr/local/man
-+MANPAGEDIR = /usr/share/man
- #
- # VERSION determines the program's version number.
-@@ -30,16 +30,19 @@
- #
- #EXPERIMENTAL_RBTREE = -DEXPERIMENTAL_RBTREE
-+CFLAGS = -Wall
-+
- #####################################################################
- # no need to modify anything beyond this point                      #
- #####################################################################
+@@ -103,12 +103,12 @@
+       $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
  
- fdupes: fdupes.c md5/md5.c    
--      gcc fdupes.c md5/md5.c -Wall -o fdupes -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(EXPERIMENTAL_RBTREE)
-+      $(CC) fdupes.c md5/md5.c $(CFLAGS) -o fdupes -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(EXPERIMENTAL_RBTREE)
+ installdirs:
+-      test -d $(BIN_DIR) || $(MKDIR) $(BIN_DIR)
+-      test -d $(MAN_DIR) || $(MKDIR) $(MAN_DIR)
++      test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)
++      test -d $(DESTDIR)$(MAN_DIR) || $(MKDIR) $(DESTDIR)$(MAN_DIR)
  
- install: fdupes
--      cp fdupes $(INSTALLDIR)
--      cp fdupes.1 $(MANPAGEDIR)/man1
-+      install -d $(DESTDIR)$(INSTALLDIR) $(DESTDIR)$(MANPAGEDIR)/man1
-+      cp fdupes $(DESTDIR)$(INSTALLDIR)
-+      cp fdupes.1 $(DESTDIR)$(MANPAGEDIR)/man1
+ install: fdupes installdirs
+-      $(INSTALL_PROGRAM)      fdupes   $(BIN_DIR)/$(PROGRAM_NAME)
+-      $(INSTALL_DATA)         fdupes.1 $(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
++      $(INSTALL_PROGRAM)      fdupes   $(DESTDIR)$(BIN_DIR)/$(PROGRAM_NAME)
++      $(INSTALL_DATA)         fdupes.1 $(DESTDIR)$(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
  
- tarball: clean
-       tar --directory=.. -c -z -v -f ../fdupes-$(VERSION).tar.gz fdupes-$(VERSION)
+ clean:
+       $(RM) $(OBJECT_FILES)
index 3560172420c1c92380d1d535a0ee334fc9033e79..51310fc436a2acd39ec9196dbbdfde5a66045fa0 100644 (file)
@@ -1,14 +1,14 @@
 Summary:       Program identifying or deleting duplicate files
 Summary(pl.UTF-8):     Program identyfikujący lub usuwający duplikaty plików
 Name:          fdupes
-Version:       1.40
-Release:       2
+Version:       1.51
+Release:       1
 License:       MIT
 Group:         Applications/File
-Source0:       http://fdupes.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 11de9ab4466089b6acbb62816b30b189
+Source0:       https://fdupes.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: 47d0410c90c9e51e450933ba35a32b62
 Patch0:                %{name}-make.patch
-URL:           http://code.google.com/p/fdupes/
+URL:           https://code.google.com/p/fdupes/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -29,11 +29,13 @@ bajcie w celu weryfikacji.
 %build
 %{__make} \
        CC="%{__cc}" \
-       CFLAGS="%{rpmcflags}"
+       COMPILER_OPTIONS="%{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
+       PREFIX=%{_prefix} \
+       INSTALL="install -p" \
        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
This page took 0.059811 seconds and 4 git commands to generate.