]> git.pld-linux.org Git - packages/fcron.git/blobdiff - fcron.spec
resolve conflict with libbsd-devel
[packages/fcron.git] / fcron.spec
index 5765ed9698221bf5354fc86e2343ea9206fb552c..d25f1879e85db659e90252d4f551ca1bdf846915 100644 (file)
@@ -1,14 +1,14 @@
-# TODO:
-# - check -mail_output_only_if_there_is_output.patch. I'm not sure we need it in >= 3.0.4 version
+# TODO
+# - use libbsd-devel? (bitstring at least?)
 Summary:       A periodical command scheduler which aims at replacing Vixie Cron
 Summary(pl.UTF-8):     Serwer okresowego uruchamiania poleceń zastępujący Vixie Crona
 Name:          fcron
-Version:       3.0.4
-Release:       1
+Version:       3.1.2
+Release:       3
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://fcron.free.fr/archives/%{name}-%{version}.src.tar.gz
-# Source0-md5: 5a26a1dfd91fdc7e87401e98aef870e6
+# Source0-md5: 36bf213e15f3a480f2274f8e46cced0a
 Source1:       %{name}.init
 Source2:       cron.logrotate
 Source3:       cron.sysconfig
@@ -17,9 +17,9 @@ Source5:      %{name}.pam
 Source6:       %{name}.conf
 Source7:       %{name}tab.pam
 Source8:       %{name}.systab
-Patch0:                %{name}-mail_output_only_if_there_is_output.patch
-Patch1:                %{name}-configure.patch
-Patch2:                %{name}-Makefile.patch
+Patch0:                %{name}-sendmail.patch
+Patch1:                %{name}-Makefile.patch
+Patch2:                %{name}-accept_readable_fcron.conf.patch
 URL:           http://fcron.free.fr/
 # configure tests -x (check can be removed, just like sendmail)
 BuildRequires: /bin/vi
@@ -39,12 +39,10 @@ Requires:   /bin/run-parts
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts
 Provides:      crondaemon
-Provides:      crontabs >= 1.7
+Provides:      crontabs = 1.7
 Provides:      group(crontab)
+Obsoletes:     crondaemon
 Obsoletes:     crontabs
-Obsoletes:     mcron
-Conflicts:     hc-cron
-Conflicts:     vixie-cron
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -68,9 +66,9 @@ uruchamianie go w zależności od obciążenia systemu i dużo więcej.
 
 %prep
 %setup -q
-#%%patch0 -p1
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
+%patch2 -p0
 
 %build
 %{__aclocal}
@@ -100,7 +98,7 @@ install -d $RPM_BUILD_ROOT{/var/{log,spool/cron},%{_mandir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
-%{__make} install \
+%{__make} install-staged \
        DESTDIR=$RPM_BUILD_ROOT \
        ROOTNAME=$(id -u) \
        ROOTGROUP=$(id -g) \
@@ -124,16 +122,21 @@ install %{SOURCE8} $RPM_BUILD_ROOT/etc/cron.hourly/fcron.systab
 
 touch $RPM_BUILD_ROOT/var/log/cron
 
-cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << EOF
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
 # cron.allow   This file describes the names of the users which are
 #              allowed to use the local cron daemon
 root
 EOF
 
-cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << EOF2
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
 # cron.deny    This file describes the names of the users which are
 #              NOT allowed to use the local cron daemon
-EOF2
+EOF
+
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+
+# conflicts with libbsd-devel-0.7.0-2.x86_64
+%{__rm} $RPM_BUILD_ROOT/usr/share/man/man3/bitstring.3*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -170,7 +173,7 @@ if [ "$1" = "2" ]; then
 fi
 
 /sbin/chkconfig --add crond
-%service crond restart "cron daemon"
+%service crond restart "Cron Daemon"
 
 umask 027
 touch /var/log/cron
@@ -192,9 +195,9 @@ if [ "$1" = "0" ]; then
                chown $USER:crontab /var/spool/cron/$USER >/dev/null 2>&1
                chmod 600 /var/spool/cron/$USER >/dev/null 2>&1
        done
-       rm -f /var/spool/cron/rm\.*
+       rm -f /var/spool/cron/rm.*
        rm -f /var/spool/cron/fcrontab.sig
-       rm -f /var/spool/cron/new\.*
+       rm -f /var/spool/cron/new.*
 fi
 
 %postun
@@ -203,54 +206,14 @@ if [ "$1" = "0" ]; then
        %groupremove crontab
 fi
 
-%triggerpostun -- vixie-cron <= 3.0.1-85
-for i in `/bin/ls /var/spool/cron 2>/dev/null`
-do
-       chown ${i} /var/spool/cron/${i} 2>/dev/null || :
-done
-/bin/chmod 660 /var/log/cron
-/bin/chgrp crontab /var/log/cron
-/bin/chmod 640 /etc/cron/cron.*
-/bin/chgrp crontab /etc/cron/cron.*
-
-%triggerpostun -- vixie-cron <= 3.0.1-73
-if [ -f /etc/cron.d/cron.allow.rpmsave ]; then
-       mv -f /etc/cron.d/cron.allow.rpmsave /etc/cron/cron.allow
-fi
-if [ -f /etc/cron.d/cron.allow ]; then
-       mv -f /etc/cron.d/cron.allow /etc/cron/cron.allow
-fi
-if [ -f /etc/cron.d/cron.deny.rpmsave ]; then
-       mv -f /etc/cron.d/cron.deny.rpmsave /etc/cron/cron.deny
-fi
-if [ -f /etc/cron.d/cron.deny ]; then
-       mv -f /etc/cron.d/cron.deny /etc/cron/cron.deny
-fi
-
-%triggerpostun -- vixie-cron <= 3.0.1-70
-if [ -f /etc/cron.allow ]; then
-       mv -f /etc/cron.allow /etc/cron/cron.allow
-fi
-if [ -f /etc/cron.deny ]; then
-       mv -f /etc/cron.deny /etc/cron/cron.deny
-fi
-
 %triggerpostun -- hc-cron
+# reinstall crond init.d links, which could be different
 /sbin/chkconfig --del crond
 /sbin/chkconfig --add crond
 
-%triggerpostun -- hc-cron <= 0.14-12
-for i in `/bin/ls /var/spool/cron 2>/dev/null`; do
-       chown ${i} /var/spool/cron/${i} 2>/dev/null || :
-done
-/bin/chmod 660 /var/log/cron
-/bin/chgrp crontab /var/log/cron
-/bin/chmod 640 /etc/cron/cron.*
-/bin/chgrp crontab /etc/cron/cron.*
-
 %files
 %defattr(644,root,root,755)
-%doc doc/en/HTML doc/en/txt/{faq.txt,changes.txt,readme.txt,thanks.txt,todo.txt} 
+%doc doc/en/HTML doc/en/txt/{faq.txt,changes.txt,readme.txt,thanks.txt,todo.txt}
 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
 %attr(750,root,root) %{_sysconfdir}/cron.hourly/%{name}.systab
 %attr(640,root,crontab) %config(noreplace) /etc/cron.d/crontab
@@ -261,8 +224,9 @@ done
 %attr(644,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/fcrontab
 %attr(754,root,root) /etc/rc.d/init.d/crond
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) /etc/logrotate.d/cron
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fcron.*
-%attr(640,root,crontab) %config(noreplace) %{_sysconfdir}/fcron.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fcron.allow
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fcron.deny
+%attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fcron.conf
 %attr(755,root,root) %{_sbindir}/crond
 %attr(6111,crontab,crontab) %{_bindir}/fcrontab
 %attr(6111,crontab,crontab) %{_bindir}/crontab
@@ -270,13 +234,11 @@ done
 %attr(6111,crontab,crontab) %{_bindir}/fcrondyn
 %{_mandir}/man1/fcrondyn.1*
 %{_mandir}/man1/fcrontab.1*
-%{_mandir}/man3/bitstring.3*
 %{_mandir}/man5/fcron.conf.5*
 %{_mandir}/man5/fcrontab.5*
 %{_mandir}/man8/fcron.8*
 %lang(fr) %{_mandir}/fr/man1/fcrondyn.1*
 %lang(fr) %{_mandir}/fr/man1/fcrontab.1*
-%lang(fr) %{_mandir}/fr/man3/bitstring.3*
 %lang(fr) %{_mandir}/fr/man5/fcron.conf.5*
 %lang(fr) %{_mandir}/fr/man5/fcrontab.5*
 %lang(fr) %{_mandir}/fr/man8/fcron.8*
This page took 0.093461 seconds and 4 git commands to generate.