]> git.pld-linux.org Git - packages/fckeditor.git/blob - fckeditor.spec
- helper to find lang files
[packages/fckeditor.git] / fckeditor.spec
1 # TODO
2 # - connectors subpackages (for language deps)
3 # - subpackage for _source (or don't package at all), used only when FCKConfig.Debug is set: LoadScript( '_source/internals/fckdebug.js' ) ;
4 Summary:        The text editor for Internet
5 Summary(pl.UTF-8):      Edytor tekstowy dla Internetu
6 Name:           fckeditor
7 Version:        2.6.3
8 Release:        0.7
9 License:        LGPL v2.1
10 Group:          Applications/WWW
11 Source0:        http://dl.sourceforge.net/fckeditor/FCKeditor_%{version}.tar.gz
12 # Source0-md5:  eb926332283376614ade9610f20b27d4
13 URL:            http://www.fckeditor.net/
14 BuildRequires:  rpmbuild(macros) > 1.268
15 BuildRequires:  sed >= 4.0
16 Requires:       webserver(access)
17 Requires:       webserver(alias)
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _appdir %{_datadir}/%{name}
22
23 %description
24 This HTML text editor brings to the web many of the powerful
25 functionalities of desktop editors like MS Word. It's lightweight and
26 doesn't require any kind of installation on the client computer.
27
28 %description -l pl.UTF-8
29 Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
30 edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
31 inicjalizacji na komputerze klienckim.
32
33 %prep
34 %setup -qc
35 mv fckeditor/* .
36 rmdir fckeditor
37 mv _samples samples
38
39 # don't know if there's any interpreter for those on linux, so kill
40 rm -f *.{afp,asp,cfc,cfm,lasso}
41
42 # undos the source
43 sed -i -e 's,\r$,,' fckeditor*
44 find '(' -name '*.js' -o -name '*.css' -o -name '*.txt' -o -name '*.html' -o -name '*.php' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
45
46 # apache1/apache2 conf
47 cat > apache.conf <<'EOF'
48 Alias /%{name} %{_appdir}
49 <Directory %{_appdir}>
50         Allow from all
51 </Directory>
52 EOF
53
54 # lighttpd conf
55 cat > lighttpd.conf <<'EOF'
56 alias.url += (
57     "/%{name}" => "%{_appdir}",
58 )
59 EOF
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_appdir}
64 cp -a fckconfig.* $RPM_BUILD_ROOT%{_appdir}
65 cp -a fckeditor.* fckeditor_php4.php fckeditor_php5.php $RPM_BUILD_ROOT%{_appdir}
66 cp -a editor $RPM_BUILD_ROOT%{_appdir}
67 cp -a *.xml $RPM_BUILD_ROOT%{_appdir}
68
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %triggerin -- apache1 < 1.3.37-3, apache1-base
73 %webapp_register apache %{_webapp}
74
75 %triggerun -- apache1 < 1.3.37-3, apache1-base
76 %webapp_unregister apache %{_webapp}
77
78 %triggerin -- apache < 2.2.0, apache-base
79 %webapp_register httpd %{_webapp}
80
81 %triggerun -- apache < 2.2.0, apache-base
82 %webapp_unregister httpd %{_webapp}
83
84 %triggerin -- lighttpd
85 %webapp_register lighttpd %{_webapp}
86
87 %triggerun -- lighttpd
88 %webapp_unregister lighttpd %{_webapp}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc _*
96 %{_appdir}
97
98 %{_examplesdir}/%{name}-%{version}
This page took 0.080496 seconds and 3 git commands to generate.