]> git.pld-linux.org Git - packages/fckeditor.git/blob - fckeditor.spec
- missing fckeditor.* (lang interfaces) and *.xml files added
[packages/fckeditor.git] / fckeditor.spec
1 # TODO
2 # - connectors subpackages
3 Summary:        The text editor for Internet
4 Summary(pl.UTF-8):      Edytor tekstowy dla Internetu
5 Name:           fckeditor
6 Version:        2.6.3
7 Release:        0.2
8 License:        LGPL v2.1
9 Group:          Applications/WWW
10 Source0:        http://dl.sourceforge.net/fckeditor/FCKeditor_%{version}.tar.gz
11 # Source0-md5:  eb926332283376614ade9610f20b27d4
12 URL:            http://www.fckeditor.net/
13 BuildRequires:  rpmbuild(macros) > 1.268
14 BuildRequires:  sed >= 4.0
15 Requires:       webserver(access)
16 Requires:       webserver(alias)
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _appdir %{_datadir}/%{name}
21
22 %description
23 This HTML text editor brings to the web many of the powerful
24 functionalities of desktop editors like MS Word. It's lightweight and
25 doesn't require any kind of installation on the client computer.
26
27 %description -l pl.UTF-8
28 Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
29 edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
30 inicjalizacji na komputerze klienckim.
31
32 %prep
33 %setup -qc
34 mv fckeditor/* .
35 rmdir fckeditor
36
37 # don't know if there's any interpreter for those on linux, so kill
38 rm -f fckeditor.{afp,asp,cfc,cfm,lasso}
39
40 # undos the source
41 sed -i -e 's,\r$,,' fckeditor.*
42 find '(' -name '*.js' -o -name '*.css' -o -name '*.txt' -o -name '*.html' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
43
44 # apache1/apache2 conf
45 cat > apache.conf <<'EOF'
46 Alias /%{name} %{_appdir}
47 <Directory %{_appdir}>
48         Allow from all
49 </Directory>
50 EOF
51
52 # lighttpd conf
53 cat > lighttpd.conf <<'EOF'
54 alias.url += (
55     "/%{name}" => "%{_appdir}",
56 )
57 EOF
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_appdir}
62 cp -a fckconfig.* $RPM_BUILD_ROOT%{_appdir}
63 cp -a fckeditor.* $RPM_BUILD_ROOT%{_appdir}
64 cp -a editor $RPM_BUILD_ROOT%{_appdir}
65 cp -a *.xml $RPM_BUILD_ROOT%{_appdir}
66
67 %triggerin -- apache1 < 1.3.37-3, apache1-base
68 %webapp_register apache %{_webapp}
69
70 %triggerun -- apache1 < 1.3.37-3, apache1-base
71 %webapp_unregister apache %{_webapp}
72
73 %triggerin -- apache < 2.2.0, apache-base
74 %webapp_register httpd %{_webapp}
75
76 %triggerun -- apache < 2.2.0, apache-base
77 %webapp_unregister httpd %{_webapp}
78
79 %triggerin -- lighttpd
80 %webapp_register lighttpd %{_webapp}
81
82 %triggerun -- lighttpd
83 %webapp_unregister lighttpd %{_webapp}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc _*
91 %{_appdir}
This page took 0.055918 seconds and 3 git commands to generate.