]> git.pld-linux.org Git - packages/fckeditor.git/blame - fckeditor.spec
- typo
[packages/fckeditor.git] / fckeditor.spec
CommitLineData
11e4bb06 1# TODO
879123f0 2# - fckeditor.* provide language interfaces. package them where?
11e4bb06 3Summary: The text editor for Internet
0d5841a4 4Summary(pl.UTF-8): Edytor tekstowy dla Internetu
11e4bb06 5Name: fckeditor
62513a26 6Version: 2.6.3
2900a700 7Release: 0.16
11e4bb06
ER
8License: LGPL v2.1
9Group: Applications/WWW
10Source0: http://dl.sourceforge.net/fckeditor/FCKeditor_%{version}.tar.gz
62513a26 11# Source0-md5: eb926332283376614ade9610f20b27d4
2900a700
ER
12Source1: %{name}-find-lang.sh
13Patch0: %{name}-config-php.patch
11e4bb06 14URL: http://www.fckeditor.net/
2dbf4c9d 15BuildRequires: rpmbuild(macros) >= 1.268
11e4bb06 16BuildRequires: sed >= 4.0
4409a9c4
AG
17Requires: webserver(access)
18Requires: webserver(alias)
11e4bb06
ER
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
879123f0
ER
22%define _webapps /etc/webapps
23%define _webapp %{name}
24%define _sysconfdir %{_webapps}/%{_webapp}
25%define _appdir %{_datadir}/%{name}
26
98264908
JB
27%description
28This HTML text editor brings to the web many of the powerful
29functionalities of desktop editors like MS Word. It's lightweight and
30doesn't require any kind of installation on the client computer.
31
32%description -l pl.UTF-8
33Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
34edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
35inicjalizacji na komputerze klienckim.
36
879123f0 37%package connector-php
2900a700 38Summary: File Manager Connector for PHP
98264908 39Summary(pl.UTF-8): Interfejs zarządcy plików do PHP
879123f0
ER
40Group: Applications/WWW
41Requires: %{name} = %{version}-%{release}
42Requires: php-common >= 4:5.0.0
43
44%description connector-php
2900a700 45File Manager Connector for PHP.
879123f0 46
98264908
JB
47%description connector-php -l pl.UTF-8
48Interfejs zarządcy plików do PHP.
49
879123f0 50%package connector-perl
2900a700 51Summary: File Manager Connector for Perl
98264908 52Summary(pl.UTF-8): Interfejs zarządcy plików do Perla
879123f0
ER
53Group: Applications/WWW
54Requires: %{name} = %{version}-%{release}
55Requires: perl-base
56
57%description connector-perl
2900a700 58File Manager Connector for Perl.
879123f0 59
98264908
JB
60%description connector-perl -l pl.UTF-8
61Interfejs zarządcy plików do Perla.
62
879123f0 63%package connector-python
2900a700 64Summary: File Manager Connector for Python
98264908 65Summary(pl.UTF-8): Interfejs zarządcy plików do Pythona
879123f0
ER
66Group: Applications/WWW
67Requires: %{name} = %{version}-%{release}
68Requires: python
69
70%description connector-python
2900a700 71File Manager Connector for Python.
11e4bb06 72
98264908
JB
73%description connector-python -l pl.UTF-8
74Interfejs zarządcy plików do Pythona.
2927bf25 75
879123f0
ER
76# copied from /usr/lib/rpm/macros
77%package debuginfo
78Summary: Debug information for package %{name}
79Summary(pl.UTF-8): Informacje dla debuggera dla pakietu %{name}
80Group: Development/Debug
81AutoReqProv: 0
82
83%description debuginfo
84This package provides debug information for package %{name}. Debug
85information is useful when developing applications that use this
86package or when debugging this package.
87
88%description debuginfo -l pl.UTF-8
89Ten pakiet dostarcza informacje dla debuggera dla pakietu %{name}.
90Informacje te są przydatne przy rozwijaniu aplikacji używających tego
91pakietu oraz przy odpluskwianiu samego pakietu.
92
11e4bb06 93%prep
3d29de61
ER
94%setup -qc
95mv fckeditor/* .
96rmdir fckeditor
9a74b07e 97mv _samples samples
879123f0
ER
98mkdir samples/plugins
99mv editor/plugins/bbcode/_sample samples/plugins/bbcode
100rm -f editor/lang/_translationstatus.txt
101
102install %{SOURCE1} find-lang.sh
103
104# fck php4
105mv fckeditor_php5.php fckeditor.php
106rm fckeditor_php4.php
107
108%if %{_enable_debug_packages}
109%else
110# source used only when FCKConfig.Debug is set: LoadScript( '_source/internals/fckdebug.js' ) ;
111rm -r editor/_source
112%endif
11e4bb06
ER
113
114# don't know if there's any interpreter for those on linux, so kill
9a74b07e 115rm -f *.{afp,asp,cfc,cfm,lasso}
879123f0
ER
116rm -rf editor/filemanager/connectors/{asp,aspx,cfm,lasso}
117rm -f editor/filemanager/connectors/{test,uploadtest}.html
11e4bb06
ER
118
119# undos the source
9a74b07e
ER
120sed -i -e 's,\r$,,' fckeditor*
121find '(' -name '*.js' -o -name '*.css' -o -name '*.txt' -o -name '*.html' -o -name '*.php' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
11e4bb06 122
2900a700
ER
123%patch0 -p1
124
4409a9c4
AG
125# apache1/apache2 conf
126cat > apache.conf <<'EOF'
127Alias /%{name} %{_appdir}
128<Directory %{_appdir}>
129 Allow from all
130</Directory>
131EOF
132
133# lighttpd conf
134cat > lighttpd.conf <<'EOF'
135alias.url += (
136 "/%{name}" => "%{_appdir}",
137)
138EOF
139
11e4bb06
ER
140%install
141rm -rf $RPM_BUILD_ROOT
142install -d $RPM_BUILD_ROOT%{_appdir}
11e4bb06 143cp -a editor $RPM_BUILD_ROOT%{_appdir}
879123f0 144cp -a fckconfig.* $RPM_BUILD_ROOT%{_appdir}
4409a9c4
AG
145cp -a *.xml $RPM_BUILD_ROOT%{_appdir}
146
879123f0
ER
147# these are sample language interfaces. move to examples?
148cp -a fckeditor.{js,php,pl,py} $RPM_BUILD_ROOT%{_appdir}
149
9a74b07e
ER
150install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
151cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
152
879123f0
ER
153./find-lang.sh %{name}.lang
154
155install -d $RPM_BUILD_ROOT%{_sysconfdir}
156cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
157cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
158cp -a lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
2900a700 159mv $RPM_BUILD_ROOT{%{_appdir}/editor/filemanager/connectors/php/config.php,%{_sysconfdir}/connector.php}
879123f0 160
4409a9c4
AG
161%triggerin -- apache1 < 1.3.37-3, apache1-base
162%webapp_register apache %{_webapp}
163
164%triggerun -- apache1 < 1.3.37-3, apache1-base
165%webapp_unregister apache %{_webapp}
166
167%triggerin -- apache < 2.2.0, apache-base
168%webapp_register httpd %{_webapp}
169
170%triggerun -- apache < 2.2.0, apache-base
171%webapp_unregister httpd %{_webapp}
172
173%triggerin -- lighttpd
174%webapp_register lighttpd %{_webapp}
175
176%triggerun -- lighttpd
177%webapp_unregister lighttpd %{_webapp}
11e4bb06
ER
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
879123f0 182%files -f %{name}.lang
11e4bb06
ER
183%defattr(644,root,root,755)
184%doc _*
879123f0
ER
185%dir %attr(750,root,http) %{_sysconfdir}
186%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
187%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
188%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
189%dir %{_appdir}
190%dir %{_appdir}/editor
191%{_appdir}/editor/css
192%{_appdir}/editor/dialog
193%{_appdir}/editor/skins
194%{_appdir}/editor/js
195%{_appdir}/editor/dtd
196%{_appdir}/editor/images
197
198%dir %{_appdir}/editor/plugins
199%{_appdir}/editor/plugins/autogrow
200%{_appdir}/editor/plugins/bbcode
201%{_appdir}/editor/plugins/dragresizetable
202%{_appdir}/editor/plugins/simplecommands
203%{_appdir}/editor/plugins/tablecommands
204%dir %{_appdir}/editor/plugins/placeholder
205%{_appdir}/editor/plugins/placeholder/fck_placeholder.html
206%{_appdir}/editor/plugins/placeholder/fckplugin.js
207%{_appdir}/editor/plugins/placeholder/placeholder.gif
208
209%dir %{_appdir}/editor/filemanager
210%{_appdir}/editor/filemanager/browser
211%dir %{_appdir}/editor/filemanager/connectors
212
213%{_appdir}/editor/fckdebug.html
214%{_appdir}/editor/fckdialog.html
215%{_appdir}/editor/fckeditor.html
216%{_appdir}/editor/fckeditor.original.html
217%{_appdir}/fckconfig.js
218%{_appdir}/fckeditor.js
219
220%{_appdir}/fckpackager.xml
221%{_appdir}/fckstyles.xml
222%{_appdir}/fcktemplates.xml
9a74b07e
ER
223
224%{_examplesdir}/%{name}-%{version}
879123f0
ER
225
226%files connector-php
227%defattr(644,root,root,755)
2900a700 228%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/connector.php
879123f0
ER
229%{_appdir}/editor/filemanager/connectors/php
230# language interface actually.
231%{_appdir}/fckeditor.php
232
233%files connector-perl
234%defattr(644,root,root,755)
235%{_appdir}/editor/filemanager/connectors/perl
236# language interface actually.
237%{_appdir}/fckeditor.pl
238
239%files connector-python
240%defattr(644,root,root,755)
241%{_appdir}/editor/filemanager/connectors/py
242# language interface actually.
243%{_appdir}/fckeditor.py
244
245%if %{_enable_debug_packages}
246%files debuginfo
247%defattr(644,root,root,755)
248%{_appdir}/editor/_source
249%endif
This page took 0.068911 seconds and 4 git commands to generate.