]> git.pld-linux.org Git - packages/fckeditor.git/blame - fckeditor.spec
- alternative config via FCKEDITOR_CONFIG in php connector
[packages/fckeditor.git] / fckeditor.spec
CommitLineData
11e4bb06 1# TODO
879123f0 2# - fckeditor.* provide language interfaces. package them where?
11e4bb06 3Summary: The text editor for Internet
0d5841a4 4Summary(pl.UTF-8): Edytor tekstowy dla Internetu
11e4bb06 5Name: fckeditor
62513a26 6Version: 2.6.3
2900a700 7Release: 0.16
11e4bb06
ER
8License: LGPL v2.1
9Group: Applications/WWW
10Source0: http://dl.sourceforge.net/fckeditor/FCKeditor_%{version}.tar.gz
62513a26 11# Source0-md5: eb926332283376614ade9610f20b27d4
2900a700
ER
12Source1: %{name}-find-lang.sh
13Patch0: %{name}-config-php.patch
11e4bb06 14URL: http://www.fckeditor.net/
4409a9c4 15BuildRequires: rpmbuild(macros) > 1.268
11e4bb06 16BuildRequires: sed >= 4.0
4409a9c4
AG
17Requires: webserver(access)
18Requires: webserver(alias)
11e4bb06
ER
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
879123f0
ER
22%define _webapps /etc/webapps
23%define _webapp %{name}
24%define _sysconfdir %{_webapps}/%{_webapp}
25%define _appdir %{_datadir}/%{name}
26
27%package connector-php
2900a700 28Summary: File Manager Connector for PHP
879123f0
ER
29Group: Applications/WWW
30Requires: %{name} = %{version}-%{release}
31Requires: php-common >= 4:5.0.0
32
33%description connector-php
2900a700 34File Manager Connector for PHP.
879123f0
ER
35
36%package connector-perl
2900a700 37Summary: File Manager Connector for Perl
879123f0
ER
38Group: Applications/WWW
39Requires: %{name} = %{version}-%{release}
40Requires: perl-base
41
42%description connector-perl
2900a700 43File Manager Connector for Perl.
879123f0
ER
44
45%package connector-python
2900a700 46Summary: File Manager Connector for Python
879123f0
ER
47Group: Applications/WWW
48Requires: %{name} = %{version}-%{release}
49Requires: python
50
51%description connector-python
2900a700 52File Manager Connector for Python.
11e4bb06
ER
53
54%description
55This HTML text editor brings to the web many of the powerful
56functionalities of desktop editors like MS Word. It's lightweight and
57doesn't require any kind of installation on the client computer.
58
9d354683
JR
59%description -l pl.UTF-8
60Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
61edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
2927bf25
JB
62inicjalizacji na komputerze klienckim.
63
879123f0
ER
64# copied from /usr/lib/rpm/macros
65%package debuginfo
66Summary: Debug information for package %{name}
67Summary(pl.UTF-8): Informacje dla debuggera dla pakietu %{name}
68Group: Development/Debug
69AutoReqProv: 0
70
71%description debuginfo
72This package provides debug information for package %{name}. Debug
73information is useful when developing applications that use this
74package or when debugging this package.
75
76%description debuginfo -l pl.UTF-8
77Ten pakiet dostarcza informacje dla debuggera dla pakietu %{name}.
78Informacje te są przydatne przy rozwijaniu aplikacji używających tego
79pakietu oraz przy odpluskwianiu samego pakietu.
80
11e4bb06 81%prep
3d29de61
ER
82%setup -qc
83mv fckeditor/* .
84rmdir fckeditor
9a74b07e 85mv _samples samples
879123f0
ER
86mkdir samples/plugins
87mv editor/plugins/bbcode/_sample samples/plugins/bbcode
88rm -f editor/lang/_translationstatus.txt
89
90install %{SOURCE1} find-lang.sh
91
92# fck php4
93mv fckeditor_php5.php fckeditor.php
94rm fckeditor_php4.php
95
96%if %{_enable_debug_packages}
97%else
98# source used only when FCKConfig.Debug is set: LoadScript( '_source/internals/fckdebug.js' ) ;
99rm -r editor/_source
100%endif
11e4bb06
ER
101
102# don't know if there's any interpreter for those on linux, so kill
9a74b07e 103rm -f *.{afp,asp,cfc,cfm,lasso}
879123f0
ER
104rm -rf editor/filemanager/connectors/{asp,aspx,cfm,lasso}
105rm -f editor/filemanager/connectors/{test,uploadtest}.html
11e4bb06
ER
106
107# undos the source
9a74b07e
ER
108sed -i -e 's,\r$,,' fckeditor*
109find '(' -name '*.js' -o -name '*.css' -o -name '*.txt' -o -name '*.html' -o -name '*.php' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
11e4bb06 110
2900a700
ER
111%patch0 -p1
112
4409a9c4
AG
113# apache1/apache2 conf
114cat > apache.conf <<'EOF'
115Alias /%{name} %{_appdir}
116<Directory %{_appdir}>
117 Allow from all
118</Directory>
119EOF
120
121# lighttpd conf
122cat > lighttpd.conf <<'EOF'
123alias.url += (
124 "/%{name}" => "%{_appdir}",
125)
126EOF
127
11e4bb06
ER
128%install
129rm -rf $RPM_BUILD_ROOT
130install -d $RPM_BUILD_ROOT%{_appdir}
11e4bb06 131cp -a editor $RPM_BUILD_ROOT%{_appdir}
879123f0 132cp -a fckconfig.* $RPM_BUILD_ROOT%{_appdir}
4409a9c4
AG
133cp -a *.xml $RPM_BUILD_ROOT%{_appdir}
134
879123f0
ER
135# these are sample language interfaces. move to examples?
136cp -a fckeditor.{js,php,pl,py} $RPM_BUILD_ROOT%{_appdir}
137
9a74b07e
ER
138install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
140
879123f0
ER
141./find-lang.sh %{name}.lang
142
143install -d $RPM_BUILD_ROOT%{_sysconfdir}
144cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
145cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
146cp -a lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
2900a700 147mv $RPM_BUILD_ROOT{%{_appdir}/editor/filemanager/connectors/php/config.php,%{_sysconfdir}/connector.php}
879123f0 148
4409a9c4
AG
149%triggerin -- apache1 < 1.3.37-3, apache1-base
150%webapp_register apache %{_webapp}
151
152%triggerun -- apache1 < 1.3.37-3, apache1-base
153%webapp_unregister apache %{_webapp}
154
155%triggerin -- apache < 2.2.0, apache-base
156%webapp_register httpd %{_webapp}
157
158%triggerun -- apache < 2.2.0, apache-base
159%webapp_unregister httpd %{_webapp}
160
161%triggerin -- lighttpd
162%webapp_register lighttpd %{_webapp}
163
164%triggerun -- lighttpd
165%webapp_unregister lighttpd %{_webapp}
11e4bb06
ER
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
879123f0 170%files -f %{name}.lang
11e4bb06
ER
171%defattr(644,root,root,755)
172%doc _*
879123f0
ER
173%dir %attr(750,root,http) %{_sysconfdir}
174%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
175%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
176%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
177%dir %{_appdir}
178%dir %{_appdir}/editor
179%{_appdir}/editor/css
180%{_appdir}/editor/dialog
181%{_appdir}/editor/skins
182%{_appdir}/editor/js
183%{_appdir}/editor/dtd
184%{_appdir}/editor/images
185
186%dir %{_appdir}/editor/plugins
187%{_appdir}/editor/plugins/autogrow
188%{_appdir}/editor/plugins/bbcode
189%{_appdir}/editor/plugins/dragresizetable
190%{_appdir}/editor/plugins/simplecommands
191%{_appdir}/editor/plugins/tablecommands
192%dir %{_appdir}/editor/plugins/placeholder
193%{_appdir}/editor/plugins/placeholder/fck_placeholder.html
194%{_appdir}/editor/plugins/placeholder/fckplugin.js
195%{_appdir}/editor/plugins/placeholder/placeholder.gif
196
197%dir %{_appdir}/editor/filemanager
198%{_appdir}/editor/filemanager/browser
199%dir %{_appdir}/editor/filemanager/connectors
200
201%{_appdir}/editor/fckdebug.html
202%{_appdir}/editor/fckdialog.html
203%{_appdir}/editor/fckeditor.html
204%{_appdir}/editor/fckeditor.original.html
205%{_appdir}/fckconfig.js
206%{_appdir}/fckeditor.js
207
208%{_appdir}/fckpackager.xml
209%{_appdir}/fckstyles.xml
210%{_appdir}/fcktemplates.xml
9a74b07e
ER
211
212%{_examplesdir}/%{name}-%{version}
879123f0
ER
213
214%files connector-php
215%defattr(644,root,root,755)
2900a700 216%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/connector.php
879123f0
ER
217%{_appdir}/editor/filemanager/connectors/php
218# language interface actually.
219%{_appdir}/fckeditor.php
220
221%files connector-perl
222%defattr(644,root,root,755)
223%{_appdir}/editor/filemanager/connectors/perl
224# language interface actually.
225%{_appdir}/fckeditor.pl
226
227%files connector-python
228%defattr(644,root,root,755)
229%{_appdir}/editor/filemanager/connectors/py
230# language interface actually.
231%{_appdir}/fckeditor.py
232
233%if %{_enable_debug_packages}
234%files debuginfo
235%defattr(644,root,root,755)
236%{_appdir}/editor/_source
237%endif
This page took 0.137328 seconds and 4 git commands to generate.