]> git.pld-linux.org Git - packages/fcgi.git/commitdiff
- updated to 2.2.2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 May 2002 17:34:17 +0000 (17:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- renamed to fastcgi-devkit.spec to fcgi.spec, added -devel and -static
  (now it uses shared library)
- no-libs patch to avoid linking with unnecessary libs

Changed files:
    fcgi-no-libs.patch -> 1.1
    fcgi.spec -> 1.1

fcgi-no-libs.patch [new file with mode: 0644]
fcgi.spec [new file with mode: 0644]

diff --git a/fcgi-no-libs.patch b/fcgi-no-libs.patch
new file mode 100644 (file)
index 0000000..7d6345c
--- /dev/null
@@ -0,0 +1,14 @@
+--- fcgi-2.2.2/configure.in.orig       Tue Nov 27 17:27:13 2001
++++ fcgi-2.2.2/configure.in    Fri May  3 17:18:31 2002
+@@ -32,11 +32,6 @@
+ AC_SUBST(LIBFCGIXX)
+ AC_SUBST(ECHO_CPP)
+-AC_CHECK_LIB([nsl],       [main]) ac_cv_lib_nsl=ac_cv_lib_nsl_main
+-AC_CHECK_LIB([resolv],    [main]) ac_cv_lib_resolv=ac_cv_lib_resolv_main
+-AC_CHECK_LIB([socket],          [main]) ac_cv_lib_socket=ac_cv_lib_socket_main
+-AC_CHECK_LIB([dnet_stub], [main]) ac_cv_lib_dnet_stub=ac_cv_lib_dnet_stub_main
+-AC_CHECK_LIB([ieee],    [main]) ac_cv_lib_ieee=ac_cv_lib_ieee_main
+ AC_SUBST(threaded)
+ AC_CHECK_LIB([pthread],         [main], 
diff --git a/fcgi.spec b/fcgi.spec
new file mode 100644 (file)
index 0000000..8d945b1
--- /dev/null
+++ b/fcgi.spec
@@ -0,0 +1,135 @@
+Summary:       FastCGI development kit - shared libraries
+Summary(pl):   Zestaw dla programistów FastCGI - biblioteki wspó³dzielone
+Name:          fcgi
+Version:       2.2.2
+Release:       1
+License:       distributable
+Group:         Libraries
+Source0:       http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
+Patch0:                %{name}-no-libs.patch
+URL:           http://www.fastcgi.com/
+BuildRequires: autoconf
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _includedir     %{_prefix}/include/fastcgi
+
+%description
+FastCGI is an open extension to CGI that provides high performance for
+all Internet applications without the penalties of Web server APIs.
+
+FastCGI is designed to be layered on top of existing Web server APIs.
+For instance, the mod_fastcgi Apache module adds FastCGI support to
+the Apache server. FastCGI can also be used, with reduced
+functionality and reduced performance, on any Web server that supports
+CGI.
+
+This FastCGI Developer's Kit is designed to make developing FastCGI
+applications easy. The kit currently supports FastCGI applications
+written in C/C++, Perl, Tcl, and Java.
+
+This package contains only shared libraries used by programs developed
+using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
+FastCGI).
+
+%description -l pl
+FastCGI to otwarte rozszerzenie CGI daj±ce wysok± wydajno¶æ dla
+wszystkich aplikacjach internetowych bez obci±¿ania API serwera WWW.
+
+FastCGI zosta³ zaprojektowany "na wierzchu" instniej±cych API
+serwerów. Na przyk³ad, modu³ Apache mod_fastcgi dodaje obs³ugê FastCGI
+do serwera Apache. FastCGI mo¿e byæ u¿ywany, ze zmniejszon±
+funkcjonalno¶ci± i wydajno¶ci±, z dowolnym serwerem obs³uguj±cym CGI.
+
+Zestaw Programisty FastCGI jest tak zaprojektowany, by uczyniæ ³atwym
+tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
+FastCGI w C/C++, Perlu, Tcl i Javie.
+
+Ten pakiet zawiera tylko biblioteki wspó³dzielone u¿ywane przez
+programy stworzone przy u¿yciu FastCGI developer's Kit oraz program
+cgi-fcgi (bramkê pomiêdzy CGI a FastCGI).
+
+%package devel
+Summary:       FastCGI development kit
+Summary(pl):   Zestaw dla programistów FastCGI
+Group:         Development/Libraries
+Requires:      %{name} = %{version}
+Obsoletes:     fastcgi-devkit
+Provides:      fastcgi-devkit = %{version}
+
+%description devel
+This package contains FastCGI Developer's Kit, which is designed to
+make developing FastCGI applications easy. The kit currently supports
+FastCGI applications written in C/C++, Perl, Tcl, and Java.
+
+%description devel -l pl
+Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
+zaprojektowany, by uczyniæ ³atwym tworzenie aplikacji FastCGI.
+Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
+Javie.
+
+%package static
+Summary:       FastCGI static library
+Summary(pl):   Statyczna biblioteka FastCGI
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+
+%description static
+FastCGI static library.
+
+%description static -l pl
+Statyczna biblioteka FastCGI.
+
+%prep
+%setup -q
+%patch -p1
+
+%build
+autoconf
+%configure \
+       --with-global \
+       --with-nodebug \
+       --with-noassert \
+       --with-notest
+
+%{__make}
+
+# avoid relinking
+cd libfcgi
+sed -e '/^relink_command.*/d' libfcgi++.la > libfcgi++.la.tmp
+mv -f libfcgi++.la.tmp libfcgi++.la
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
+
+# note *.[13] files are already formatted to plain text :(
+gzip -9nf README LICENSE.TERMS doc/*.[13]
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz doc/*.1.gz
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+
+%files devel
+%defattr(644,root,root,755)
+%doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3.gz
+%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/lib*.la
+%{_includedir}
+%{_examplesdir}/fastcgi
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
This page took 0.11019 seconds and 4 git commands to generate.