]> git.pld-linux.org Git - packages/fcgi.git/blame - fcgi.spec
- x32 rebuild
[packages/fcgi.git] / fcgi.spec
CommitLineData
34bb51d4 1Summary: FastCGI development kit - shared libraries
35aba833 2Summary(pl.UTF-8): Zestaw dla programistów FastCGI - biblioteki współdzielone
34bb51d4 3Name: fcgi
20d696aa 4Version: 2.4.0
727ddfdd 5Release: 4
34bb51d4
JB
6License: distributable
7Group: Libraries
8Source0: http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9f2540b3 9# Source0-md5: d15060a813b91383a9f3c66faf84867e
34bb51d4 10Patch0: %{name}-no-libs.patch
b08a0f50 11Patch1: %{name}-listen-backlog.patch
4e93fed1 12Patch2: %{name}-includes.patch
34bb51d4
JB
13URL: http://www.fastcgi.com/
14BuildRequires: autoconf
585bfa08
JB
15BuildRequires: automake
16BuildRequires: libtool >= 2:1.4d-3
34bb51d4
JB
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _includedir %{_prefix}/include/fastcgi
20
21%description
22FastCGI is an open extension to CGI that provides high performance for
23all Internet applications without the penalties of Web server APIs.
24
25FastCGI is designed to be layered on top of existing Web server APIs.
26For instance, the mod_fastcgi Apache module adds FastCGI support to
27the Apache server. FastCGI can also be used, with reduced
28functionality and reduced performance, on any Web server that supports
29CGI.
30
31This FastCGI Developer's Kit is designed to make developing FastCGI
32applications easy. The kit currently supports FastCGI applications
33written in C/C++, Perl, Tcl, and Java.
34
35This package contains only shared libraries used by programs developed
36using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
37FastCGI).
38
b272e604
JR
39%description -l pl.UTF-8
40FastCGI to otwarte rozszerzenie CGI dające wysoką wydajność dla
41wszystkich aplikacjach internetowych bez obciążania API serwera WWW.
34bb51d4 42
b272e604
JR
43FastCGI został zaprojektowany "na wierzchu" istniejących API serwerów.
44Na przykład, moduł Apache mod_fastcgi dodaje obsługę FastCGI do serwera
45Apache. FastCGI może być używany, ze zmniejszoną funkcjonalnością
46i wydajnością, z dowolnym serwerem obsługującym CGI.
34bb51d4 47
b272e604 48Zestaw Programisty FastCGI jest tak zaprojektowany, by uczynić łatwym
34bb51d4
JB
49tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
50FastCGI w C/C++, Perlu, Tcl i Javie.
51
b272e604
JR
52Ten pakiet zawiera tylko biblioteki współdzielone używane przez programy
53stworzone przy użyciu FastCGI developer's Kit oraz program cgi-fcgi
54(bramkę pomiędzy CGI a FastCGI).
34bb51d4
JB
55
56%package devel
57Summary: FastCGI development kit
35aba833 58Summary(pl.UTF-8): Zestaw dla programistów FastCGI
34bb51d4 59Group: Development/Libraries
dd0fce24 60Requires: %{name} = %{version}-%{release}
34bb51d4 61Obsoletes: fastcgi-devkit
34bb51d4
JB
62
63%description devel
64This package contains FastCGI Developer's Kit, which is designed to
65make developing FastCGI applications easy. The kit currently supports
66FastCGI applications written in C/C++, Perl, Tcl, and Java.
67
b272e604
JR
68%description devel -l pl.UTF-8
69Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
70zaprojektowany, by uczynić łatwym tworzenie aplikacji FastCGI.
34bb51d4
JB
71Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
72Javie.
73
74%package static
75Summary: FastCGI static library
35aba833 76Summary(pl.UTF-8): Statyczna biblioteka FastCGI
34bb51d4 77Group: Development/Libraries
dd0fce24 78Requires: %{name}-devel = %{version}-%{release}
34bb51d4
JB
79
80%description static
81FastCGI static library.
82
b272e604 83%description static -l pl.UTF-8
34bb51d4
JB
84Statyczna biblioteka FastCGI.
85
86%prep
87%setup -q
b08a0f50
ER
88%patch0 -p1
89%patch1 -p1
4e93fed1 90%patch2 -p1
34bb51d4
JB
91
92%build
585bfa08
JB
93# supplied libtool is broken (relink, C++)
94%{__libtoolize}
95%{__aclocal}
7fa55f4d 96%{__autoconf}
585bfa08 97%{__automake}
b08a0f50
ER
98
99CPPFLAGS="-DLISTEN_BACKLOG=1024"
34bb51d4
JB
100%configure \
101 --with-global \
34bb51d4 102 --with-noassert \
4e93fed1 103 --with-nodebug \
34bb51d4
JB
104 --with-notest
105
4e93fed1
JB
106# parallel build broken: library is searched before it's built
107%{__make} -j1
34bb51d4 108
34bb51d4
JB
109%install
110rm -rf $RPM_BUILD_ROOT
b08a0f50 111install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
34bb51d4
JB
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
b08a0f50 116cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
34bb51d4 117
34bb51d4
JB
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
e989b779 126%doc README LICENSE.TERMS doc/*.1
4e93fed1
JB
127%attr(755,root,root) %{_bindir}/cgi-fcgi
128%attr(755,root,root) %{_libdir}/libfcgi.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/libfcgi.so.0
130%attr(755,root,root) %{_libdir}/libfcgi++.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/libfcgi++.so.0
34bb51d4
JB
132
133%files devel
134%defattr(644,root,root,755)
e989b779 135%doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
4e93fed1
JB
136%attr(755,root,root) %{_libdir}/libfcgi.so
137%attr(755,root,root) %{_libdir}/libfcgi++.so
138%{_libdir}/libfcgi.la
139%{_libdir}/libfcgi++.la
34bb51d4 140%{_includedir}
b08a0f50 141%{_examplesdir}/%{name}-%{version}
34bb51d4
JB
142
143%files static
144%defattr(644,root,root,755)
4e93fed1
JB
145%{_libdir}/libfcgi.a
146%{_libdir}/libfcgi++.a
This page took 0.11677 seconds and 4 git commands to generate.