]> git.pld-linux.org Git - packages/fceultra.git/blobdiff - fceultra.spec
- completed dependencies, release 3 (libx264 0.164)
[packages/fceultra.git] / fceultra.spec
index 5159069ac6c64ef7b6c8a2112888db521618e311..3eff586a339bbf4d71a1bf28cd57047ad704643f 100644 (file)
@@ -1,28 +1,53 @@
 #
-# TODO: bcond for non-gtk gui (gfceux)
-# TODO: bcond for gtk3 interface instead of qt
-#
+# Conditional build:
+%bcond_with    qt6     # Qt 6 instead of Qt 5
+
 Summary:       FCE Ultra - Linux Nintendo Entertainment System emulator
 Summary(pl.UTF-8):     FCE Ultra - linuksowy emulator systemu Nintendo
 Name:          fceultra
-Version:       2.3.0
-Release:       1
+Version:       2.6.6
+Release:       3
 License:       GPL v2+
 Group:         X11/Applications/Games
-Source0:       http://downloads.sourceforge.net/fceultra/fceux-%{version}.src.tar.gz
-# Source0-md5: 1d7588d6cd74fa6a0473e529a6f823d9
-URL:           http://fceultra.sourceforge.net/
-BuildRequires: Mesa-libGLU-devel
+#Source0Download: https://fceux.com/web/download.html
+# TODO: use named tarballs
+#Source0:      https://github.com/TASEmulators/fceux/archive/v%{version}/fceux-%{version}.tar.gz
+Source0:       https://github.com/TASEmulators/fceux/archive/refs/tags/v%{version}.tar.gz
+# Source0-md5: 8e1aede624ebe26f0a936daba3b87328
+URL:           https://fceux.com/
+BuildRequires: OpenGL-devel
+BuildRequires: SDL2-devel >= 2.0
+BuildRequires: cmake >= 3.8
+# libavcodec libavformat libavutil libswresample libswscale
+BuildRequires: ffmpeg-devel
+BuildRequires: libarchive-devel
+BuildRequires: libx264-devel
+BuildRequires: libx265-devel
+BuildRequires: lua51-devel >= 5.1
+BuildRequires: minizip-devel
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.605
+# checked but not used
+#BuildRequires:        xorg-lib-libX11-devel
+#BuildRequires:        xorg-lib-libxkbcommon-devel
+BuildRequires: zlib-devel
+%if %{with qt6}
+BuildRequires: Qt6Core-devel >= 6.0
+BuildRequires: Qt6Gui-devel >= 6.0
+BuildRequires: Qt6Help-devel >= 6.0
+BuildRequires: Qt6OpenGL-devel >= 6.0
+BuildRequires: Qt6Widgets-devel >= 6.0
+BuildRequires: qt6-build >= 6.0
+Requires:      Qt6Gui-platform-xcb-glx >= 5.11
+%else
 BuildRequires: Qt5Core-devel >= 5.11
 BuildRequires: Qt5Gui-devel >= 5.11
+BuildRequires: Qt5Help-devel >= 5.11
 BuildRequires: Qt5OpenGL-devel >= 5.11
 BuildRequires: Qt5Widgets-devel >= 5.11
-BuildRequires: SDL2 >= 2.0
-BuildRequires: cmake
-BuildRequires: lua51-devel
-BuildRequires: minizip-devel
-BuildRequires: pkgconfig
+BuildRequires: qt5-build >= 5.11
 Requires:      Qt5Gui-platform-xcb-glx >= 5.11
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -38,18 +63,22 @@ FCE Ultra to wieloplatformowy emulator konsoli Famicom/NES/Pegasus.
 CFLAGS="%{rpmcflags}"
 CXXFLAGS="%{rpmcxxflags}"
 mkdir -p build
-%cmake --build=build .
+cd build
+%cmake .. \
+       -DQHELP=ON \
+       %{?with_qt6:-DQT6=ON}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+
+%{__make} -C build install \
         DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_mandir}/man6/
-%{__mv} documentation/fceux.6 $RPM_BUILD_ROOT%{_mandir}/man6/
-%{__mv} documentation/fceux-net-server.6 $RPM_BUILD_ROOT%{_mandir}/man6/
+install -d $RPM_BUILD_ROOT%{_mandir}/man6
+%{__mv} documentation/fceux.6 $RPM_BUILD_ROOT%{_mandir}/man6
+%{__mv} documentation/fceux-net-server.6 $RPM_BUILD_ROOT%{_mandir}/man6
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.096232 seconds and 4 git commands to generate.