]> git.pld-linux.org Git - packages/fceultra.git/blob - fceultra.spec
- fixed requirements
[packages/fceultra.git] / fceultra.spec
1 #
2 # TODO: bcond for non-gtk gui (gfceux)
3 # TODO: bcond for gtk3 interface instead of qt
4 #
5 Summary:        FCE Ultra - Linux Nintendo Entertainment System emulator
6 Summary(pl.UTF-8):      FCE Ultra - linuksowy emulator systemu Nintendo
7 Name:           fceultra
8 Version:        2.3.0
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://downloads.sourceforge.net/fceultra/fceux-%{version}.src.tar.gz
13 # Source0-md5:  1d7588d6cd74fa6a0473e529a6f823d9
14 URL:            http://fceultra.sourceforge.net/
15 BuildRequires:  Mesa-libGLU-devel
16 BuildRequires:  Qt5Core-devel >= 5.11
17 BuildRequires:  Qt5Gui-devel >= 5.11
18 BuildRequires:  Qt5OpenGL-devel >= 5.11
19 BuildRequires:  Qt5Widgets-devel >= 5.11
20 BuildRequires:  SDL2 >= 2.0
21 BuildRequires:  cmake
22 BuildRequires:  lua51-devel
23 BuildRequires:  minizip-devel
24 BuildRequires:  pkgconfig
25 Requires:       Qt5Gui-platform-xcb-glx >= 5.11
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FCE Ultra is a cross platform, NTSC and PAL Famicom/NES emulator.
30
31 %description -l pl.UTF-8
32 FCE Ultra to wieloplatformowy emulator konsoli Famicom/NES/Pegasus.
33
34 %prep
35 %setup -q -n fceux-%{version}
36
37 %build
38 mkdir -p build
39 %cmake --build=build \
40         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
41         .
42
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_mandir}/man6/
51 %{__mv} documentation/fceux.6 $RPM_BUILD_ROOT%{_mandir}/man6/
52 %{__mv} documentation/fceux-net-server.6 $RPM_BUILD_ROOT%{_mandir}/man6/
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README TODO-SDL changelog.txt readme.md documentation/*
60 %attr(755,root,root) %{_bindir}/fceux
61 %dir %{_datadir}/fceux
62 %dir %{_datadir}/fceux/luaScripts
63 %dir %{_datadir}/fceux/palettes
64 %dir %{_datadir}/fceux/tools
65 %{_datadir}/fceux/*.{dll,chm}
66 %{_datadir}/fceux/luaScripts/*
67 %{_datadir}/fceux/palettes/*
68 %{_datadir}/fceux/tools/*
69 %{_mandir}/man6/fceux-net-server.6*
70 %{_mandir}/man6/fceux.6*
71 %{_pixmapsdir}/fceux1.png
72 %{_desktopdir}/fceux.desktop
This page took 0.037811 seconds and 4 git commands to generate.