]> git.pld-linux.org Git - packages/fbida.git/commitdiff
- updated to 2.10 auto/th/fbida-2.10-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 9 May 2015 12:26:44 +0000 (14:26 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 9 May 2015 12:26:44 +0000 (14:26 +0200)
- updated config-noforce patch
- removed obsolete giflib patch

fbida-config-noforce.patch
fbida-giflib.patch [deleted file]
fbida.spec

index a3a1f7f60bbe285f559ad09ac73046f65f91e660..60a2e2e354d7e2156711d4580b926490ede59964 100644 (file)
@@ -1,24 +1,25 @@
---- fbida-2.08/GNUmakefile.orig        2011-06-01 09:31:59.000000000 +0200
-+++ fbida-2.08/GNUmakefile     2011-06-05 08:53:44.957075434 +0200
+--- fbida-2.10/GNUmakefile.orig        2015-05-09 10:47:54.960989289 +0200
++++ fbida-2.10/GNUmakefile     2015-05-09 11:09:58.194267091 +0200
 @@ -42,16 +42,16 @@
  HAVE_NEW_EXIF := $(call ac_header,libexif/exif-log.h)
  HAVE_GLIBC    := $(call ac_func,fopencookie)
- HAVE_STRCASESTR       := $(call ac_func,strcasestr)
+ HAVE_STRSIGNAL        := $(call ac_func,strsignal)
 -HAVE_LIBPCD   := $(call ac_lib,pcd_open,pcd)
--HAVE_LIBUNGIF := $(call ac_lib,DGifOpenFileName,ungif)
+-HAVE_LIBGIF   := $(call ac_lib,DGifOpenFileName,gif)
 -HAVE_LIBPNG   := $(call ac_lib,png_read_info,png,-lz)
 -HAVE_LIBTIFF  := $(call ac_lib,TIFFOpen,tiff)
 -HAVE_LIBWEBP  := $(call ac_lib,WebPDecodeRGBA,webp)
-+HAVE_LIBPCD   ?= $(call ac_lib,pcd_open,pcd)
-+HAVE_LIBUNGIF ?= $(call ac_lib,DGifOpenFileName,ungif)
-+HAVE_LIBPNG   ?= $(call ac_lib,png_read_info,png,-lz)
-+HAVE_LIBTIFF  ?= $(call ac_lib,TIFFOpen,tiff)
-+HAVE_LIBWEBP  ?= $(call ac_lib,WebPDecodeRGBA,webp)
- #HAVE_LIBMAGICK       := $(call ac_binary,Magick-config)
+-#HAVE_LIBMAGICK       := $(call ac_binary,Magick-config)
 -HAVE_LIBSANE  := $(call ac_lib,sane_init,sane)
 -HAVE_LIBCURL  := $(call ac_lib,curl_easy_init,curl)
 -HAVE_LIBLIRC  := $(call ac_lib,lirc_init,lirc_client)
 -HAVE_MOTIF    := $(call ac_lib,XmStringGenerate,Xm,-L/usr/X11R6/$(LIB) -lXpm -lXt -lXext -lX11)
++HAVE_LIBPCD   ?= $(call ac_lib,pcd_open,pcd)
++HAVE_LIBGIF   ?= $(call ac_lib,DGifOpenFileName,gif)
++HAVE_LIBPNG   ?= $(call ac_lib,png_read_info,png,-lz)
++HAVE_LIBTIFF  ?= $(call ac_lib,TIFFOpen,tiff)
++HAVE_LIBWEBP  ?= $(call ac_lib,WebPDecodeRGBA,webp)
++#HAVE_LIBMAGICK       ?= $(call ac_binary,Magick-config)
 +HAVE_LIBSANE  ?= $(call ac_lib,sane_init,sane)
 +HAVE_LIBCURL  ?= $(call ac_lib,curl_easy_init,curl)
 +HAVE_LIBLIRC  ?= $(call ac_lib,lirc_init,lirc_client)
diff --git a/fbida-giflib.patch b/fbida-giflib.patch
deleted file mode 100644 (file)
index 790e39b..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -Naur fbida-2.09-orig/rd/read-gif.c fbida-2.09/rd/read-gif.c
---- fbida-2.09-orig/rd/read-gif.c      2013-07-29 16:43:26.949362012 -0400
-+++ fbida-2.09/rd/read-gif.c   2013-07-29 16:43:43.669166969 -0400
-@@ -13,6 +13,13 @@
-     int w,h;
- };
-+static void
-+localPrintGifError(int ErrorCode)
-+{
-+    const char *err = GifErrorString(ErrorCode);
-+    fprintf(stderr, "\nGIF-LIB error %d: %s.\n", ErrorCode, err);
-+}
-+
- static GifRecordType
- gif_fileread(struct gif_state *h)
- {
-@@ -25,7 +33,7 @@
-       if (GIF_ERROR == DGifGetRecordType(h->gif,&RecordType)) {
-           if (debug)
-               fprintf(stderr,"gif: DGifGetRecordType failed\n");
--          PrintGifError();
-+          localPrintGifError(h->gif->Error);
-           return -1;
-       }
-       switch (RecordType) {
-@@ -42,7 +50,7 @@
-               if (rc == GIF_ERROR) {
-                   if (debug)
-                       fprintf(stderr,"gif: DGifGetExtension failed\n");
--                  PrintGifError();
-+                  localPrintGifError(h->gif->Error);
-                   return -1;
-               }
-               if (debug) {
-@@ -93,12 +101,13 @@
-     struct gif_state *h;
-     GifRecordType RecordType;
-     int i, image = 0;
--    
-+    int Error;
-+
-     h = malloc(sizeof(*h));
-     memset(h,0,sizeof(*h));
-     h->infile = fp;
--    h->gif = DGifOpenFileHandle(fileno(fp));
-+    h->gif = DGifOpenFileHandle(fileno(fp), &Error);
-     h->row = malloc(h->gif->SWidth * sizeof(GifPixelType));
-     while (0 == image) {
-@@ -108,7 +117,7 @@
-           if (GIF_ERROR == DGifGetImageDesc(h->gif)) {
-               if (debug)
-                   fprintf(stderr,"gif: DGifGetImageDesc failed\n");
--              PrintGifError();
-+              localPrintGifError(h->gif->Error);
-           }
-           if (NULL == h->gif->SColorMap &&
-               NULL == h->gif->Image.ColorMap) {
---- fbida-2.09/rd/read-gif.c~  2014-11-07 12:24:02.000000000 +0100
-+++ fbida-2.09/rd/read-gif.c   2014-11-07 12:24:58.229076247 +0100
-@@ -164,7 +164,7 @@ gif_init(FILE *fp, char *filename, unsig
-  oops:
-     if (debug)
-       fprintf(stderr,"gif: fatal error, aborting\n");
--    DGifCloseFile(h->gif);
-+    DGifCloseFile(h->gif, NULL);
-     fclose(h->infile);
-     free(h->row);
-     free(h);
-@@ -204,7 +204,7 @@ gif_done(void *data)
-     if (debug)
-       fprintf(stderr,"gif: done, cleaning up\n");
--    DGifCloseFile(h->gif);
-+    DGifCloseFile(h->gif, NULL);
-     fclose(h->infile);
-     if (h->il)
-       free(h->il);
index c22498675c351603ff9c7f23867c3029733caafc..d6bdf23eff6f3186cc2f97b2701f5e6409bd3513 100644 (file)
 Summary:       fbida - a few applications for viewing and editing images
 Summary(pl.UTF-8):     fbida - kilka aplikacji do oglądania i edycji obrazków
 Name:          fbida
-Version:       2.09
-Release:       16
+Version:       2.10
+Release:       1
 License:       GPL
 Group:         Applications/Graphics
-Source0:       http://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
-# Source0-md5: 62415c7cb28d995f9d317868de0f2830
+Source0:       https://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
+# Source0-md5: 09460b964b58c2e39b665498eca29018
 Patch0:                %{name}-config-noforce.patch
 Patch1:                %{name}-desktop.patch
 Patch2:                format-security.patch
-Patch3:                %{name}-giflib.patch
-URL:           http://www.kraxel.org/blog/linux/fbida/
+URL:           https://www.kraxel.org/blog/linux/fbida/
 BuildRequires: ImageMagick-devel
 %{?with_curl:BuildRequires:    curl-devel}
 BuildRequires: fontconfig-devel
@@ -127,7 +126,6 @@ Dostępne jest też trochę podstawowych funkcji edycyjnych.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
 CFLAGS="%{rpmcflags}" \
@@ -135,7 +133,7 @@ CFLAGS="%{rpmcflags}" \
        CC="%{__cc}" \
        verbose=yes \
        %{!?with_pcd:HAVE_LIBPCD=no} \
-       %{!?with_gif:HAVE_LIBUNGIF=no} \
+       %{!?with_gif:HAVE_LIBGIF=no} \
        %{!?with_png:HAVE_LIBPNG=no} \
        %{!?with_tiff:HAVE_LIBTIFF=no} \
        %{!?with_webp:HAVE_LIBWEBP=no} \
@@ -152,7 +150,7 @@ rm -rf $RPM_BUILD_ROOT
        prefix=%{_prefix} \
        INSTALL_BINARY=install \
        %{!?with_pcd:HAVE_LIBPCD=no} \
-       %{!?with_gif:HAVE_LIBUNGIF=no} \
+       %{!?with_gif:HAVE_LIBGIF=no} \
        %{!?with_png:HAVE_LIBPNG=no} \
        %{!?with_tiff:HAVE_LIBTIFF=no} \
        %{!?with_webp:HAVE_LIBWEBP=no} \
This page took 0.087215 seconds and 4 git commands to generate.