]> git.pld-linux.org Git - packages/fann.git/commitdiff
Update to 2.2.0 (-static subpackage and python bindings are no longer available) master
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Mon, 4 Feb 2013 22:20:16 +0000 (23:20 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Mon, 4 Feb 2013 22:20:16 +0000 (23:20 +0100)
fann-link.patch
fann-python.patch [deleted file]
fann.spec

index d45ae9049142c6c7bd59c382688b8780c4eb707a..6deae4cce63f43248115378e08cb7aeb1b4f66d2 100644 (file)
@@ -1,19 +1,34 @@
-diff -urN fann-2.0.0/src/Makefile.am fann-2.0.0.new/src/Makefile.am
---- fann-2.0.0/src/Makefile.am 2005-12-13 22:17:45.000000000 +0100
-+++ fann-2.0.0.new/src/Makefile.am     2010-11-27 17:56:01.155902638 +0100
-@@ -6,8 +6,15 @@
- AM_CFLAGS = -D_REENTRANT
- libfloatfann_la_SOURCES = floatfann.c
-+libfloatfann_la_LIBADD = -lm
-+
- libdoublefann_la_SOURCES = doublefann.c
-+libdoublefann_la_LIBADD = -lm
-+
- libfixedfann_la_SOURCES = fixedfann.c
-+libfixedfann_la_LIBADD = -lm
-+
- libfann_la_SOURCES = floatfann.c
-+libfann_la_LIBADD = -lm
- EXTRA_DIST = fann.c fann_io.c fann_train.c fann_train_data.c fann_error.c fann_cascade.c
+diff -urN FANN-2.2.0-Source/src/CMakeLists.txt FANN-2.2.0-Source.new/src/CMakeLists.txt
+--- FANN-2.2.0-Source/src/CMakeLists.txt       2012-01-24 06:31:39.000000000 +0100
++++ FANN-2.2.0-Source.new/src/CMakeLists.txt   2013-02-04 22:45:53.654911044 +0100
+@@ -11,6 +11,7 @@
+ ADD_LIBRARY(floatfann SHARED ${floatfann_LIB_SRCS})
+ SET_TARGET_PROPERTIES(floatfann PROPERTIES VERSION ${VERSION} SOVERSION 2 )
++TARGET_LINK_LIBRARIES(floatfann m)
+ INSTALL(TARGETS floatfann DESTINATION ${LIB_INSTALL_DIR} )
+@@ -23,6 +24,7 @@
+ ADD_LIBRARY(doublefann SHARED ${doublefann_LIB_SRCS})
+ SET_TARGET_PROPERTIES(doublefann PROPERTIES VERSION ${VERSION} SOVERSION 2 )
++TARGET_LINK_LIBRARIES(doublefann m)
+ INSTALL(TARGETS doublefann DESTINATION ${LIB_INSTALL_DIR} )
+@@ -35,6 +37,7 @@
+ ADD_LIBRARY(fixedfann SHARED ${fixedfann_LIB_SRCS})
+ SET_TARGET_PROPERTIES(fixedfann PROPERTIES VERSION ${VERSION} SOVERSION 2 )
++TARGET_LINK_LIBRARIES(fixedfann m)
+ INSTALL(TARGETS fixedfann DESTINATION ${LIB_INSTALL_DIR} )
+@@ -47,5 +50,6 @@
+ ADD_LIBRARY(fann SHARED ${fann_LIB_SRCS})
+ SET_TARGET_PROPERTIES(fann PROPERTIES VERSION ${VERSION} SOVERSION 2 )
++TARGET_LINK_LIBRARIES(fann m)
+ INSTALL(TARGETS fann DESTINATION ${LIB_INSTALL_DIR} )
diff --git a/fann-python.patch b/fann-python.patch
deleted file mode 100644 (file)
index 572dd1b..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN fann-2.0.0/python/pyfann/Makefile fann-2.0.0.new/python/pyfann/Makefile
---- fann-2.0.0/python/pyfann/Makefile  2005-12-03 02:22:43.000000000 +0100
-+++ fann-2.0.0.new/python/pyfann/Makefile      2010-11-27 17:49:34.672568903 +0100
-@@ -3,17 +3,17 @@
- TARGETS = _libfann.so
--PYTHON=python2.4
-+PYTHON=python2.7
- FANN_DIR="../.."
--LIBS=-L. -L/usr/local/lib -L/usr/bin -l$(PYTHON) $(FANN_DIR)/src/fann*.o
-+LIBS=-L. -L/usr/lib -l$(PYTHON) $(FANN_DIR)/src/fann*.o
- all: $(TARGETS)
-       
- _%.so: pyfann_wrap.o fann_helper.o
--      gcc $(LIBS) -shared -dll $^ -o $@
-+      gcc $(LIBS) -shared $^ -o $@
- %.o: %.c 
--      gcc -c $< -I/usr/include/$(PYTHON)/ -I$(FANN_DIR)/src/include/
-+      $(CC) $(CFLAGS) -c $< -I/usr/include/$(PYTHON)/ -I$(FANN_DIR)/src/include/
- pyfann_wrap.c: pyfann.i 
-       swig -python $<
index 45c753f4d46cbfab61d55b8fee234aca3d853432..2c7016e0c8eea3263359345252714e60e53aeab3 100644 (file)
--- a/fann.spec
+++ b/fann.spec
@@ -1,26 +1,17 @@
 Summary:       A fast artificial neural network library
 Summary(pl.UTF-8):     Szybka biblioteka do tworzenia sztucznych sieci neuronowych
 Name:          fann
-Version:       2.0.0
-Release:       2
+Version:       2.2.0
+Release:       1
 License:       LGPL
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/fann/%{name}-%{version}.tar.bz2
-# Source0-md5: 4224efa533265dcf39237667973d0e20
-Source1:       http://dl.sourceforge.net/fann/%{name}_doc_complete_1.0.pdf
+Source0:       http://downloads.sourceforge.net/fann/FANN-%{version}-Source.tar.gz
+# Source0-md5: c9d6c8da5bb70276352a1718a668562c
+Source1:       http://downloads.sourceforge.net/fann/%{name}_doc_complete_1.0.pdf
 # Source1-md5: 8117a677afc79dfaa31de39ca84d82da
-Patch0:                %{name}-python.patch
-Patch1:                %{name}-link.patch
+Patch0:                %{name}-link.patch
 URL:           http://leenissen.dk/fann/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: libtool
-BuildRequires: python
-BuildRequires: python-devel >= 1:2.7
-BuildRequires: python-modules
-BuildRequires: rpm-pythonprov
-BuildRequires: sed >= 4.0
-BuildRequires: swig-python >= 1.3.25
+BuildRequires: cmake >= 2.8
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,70 +52,24 @@ Documentation for FANN.
 %description doc -l pl.UTF-8
 Dokumentacja do FANN.
 
-%package static
-Summary:       FANN static libraries
-Summary(pl.UTF-8):     Biblioteki statyczne FANN
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-FANN static libraries.
-%description static -l pl.UTF-8
-Biblioteki statyczne FANN.
-
-%package -n python-%{name}
-Summary:       Python support for FANN
-Summary(pl.UTF-8):     Moduł języka Python dla biblioteki FANN
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python-libs
-
-%description -n python-%{name}
-Python support for FANN.
-
-%description -n python-%{name} -l pl.UTF-8
-Moduł języka Python dla biblioteki FANN.
-
 %prep
-%setup -q
+%setup -q -n FANN-%{version}-Source
 cp %{SOURCE1} .
 %patch0 -p1
-%patch1 -p1
 
 %build
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__automake}
-%configure
-%{__make} \
-       CFLAGS="%{rpmcflags} -fPIC"
-cd python
-
-CFLAGS="%{rpmcflags} -fPIC" \
+%cmake .
 %{__make}
-%py_comp .
-%py_ocomp .
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd python
-%{__make} install \
-       ROOT=$RPM_BUILD_ROOT
-
-cd ..
-install -d $RPM_BUILD_ROOT%{_examplesdir}/{python-,}%{name}-%{version}
-
-install python/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version} 
 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/pyfann/*.py
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -133,7 +78,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
+%doc README.txt datasets/*
 %attr(755,root,root) %{_libdir}/libdoublefann.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libdoublefann.so.2
 %attr(755,root,root) %{_libdir}/libfann.so.*.*.*
@@ -149,29 +94,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libfann.so
 %attr(755,root,root) %{_libdir}/libfixedfann.so
 %attr(755,root,root) %{_libdir}/libfloatfann.so
-%{_libdir}/libdoublefann.la
-%{_libdir}/libfann.la
-%{_libdir}/libfixedfann.la
-%{_libdir}/libfloatfann.la
 %{_includedir}/*.h
 %{_pkgconfigdir}/fann.pc
 %{_examplesdir}/%{name}-%{version}
 
 %files doc
 %defattr(644,root,root,755)
-%doc fann_doc_complete_1.0.pdf doc/*
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/libdoublefann.a
-%{_libdir}/libfann.a
-%{_libdir}/libfixedfann.a
-%{_libdir}/libfloatfann.a
-
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/pyfann/*.so
-%dir %{py_sitedir}/pyfann
-%{py_sitedir}/pyfann/*.py[co]
-%{py_sitedir}/pyfann-*.egg-info
-%{_examplesdir}/python-%{name}-%{version}
+%doc fann_doc_complete_1.0.pdf
This page took 0.069174 seconds and 4 git commands to generate.