]> git.pld-linux.org Git - packages/fann.git/blobdiff - fann-python.patch
- fix name _libfann library
[packages/fann.git] / fann-python.patch
index 893d5464c1ca26c56527d898a802baae16c4c7ef..3d3f55f6836598f735b1c6de1c9bd5eb9c00b9a1 100644 (file)
@@ -1,15 +1,28 @@
---- fann-1.1.0-old/python/Makefile     2004-06-06 00:33:09.817753008 +0200
-+++ fann-1.1.0/python/Makefile 2004-06-06 00:32:31.565568224 +0200
-@@ -6,10 +6,10 @@
+diff -urN fann-1.2.0/python/makefile.gnu fann-1.2.0.new/python/makefile.gnu
+--- fann-1.2.0/python/makefile.gnu     2004-10-09 13:56:57.000000000 +0200
++++ fann-1.2.0.new/python/makefile.gnu 2005-11-13 20:10:45.000000000 +0100
+@@ -1,18 +1,18 @@
+ # This makefile was written to compile a distribution of pyfann for
+ # GNU platforms (cygwin included.)
+-TARGETS = _libfann.dll
++TARGETS = _libfann.so
+-PYTHON=python2.3
+-LIBS=-L. -L/usr/local/lib -L/usr/bin -l$(PYTHON) ../src/fann*.o
++PYTHON=python2.4
++LIBS=-L. -L/usr/lib -L/usr/bin -l$(PYTHON) ../src/fann*.o
  all: $(TARGETS)
  
- _%.so: %_wrap.o
--      gcc -shared $< -lfann -o $@ 
-+      gcc -shared ${CFLAGS} $< -L../src/.libs/ -lfann -o $@ 
+-_%.dll: %_wrap.o fann_helper.o
+-      gcc $(LIBS) -shared -dll $^ -o $@
++_%.so: %_wrap.o fann_helper.o
++      gcc $(LIBS) -shared $^ -o $@
  
  %.o: %.c 
--      gcc -c -fpic $< -I/usr/include/python2.3/
-+      gcc ${CFLAGS} -c -fpic $< -I/usr/include/python2.4/ -I/usr/include/python2.3/
+-      gcc -c $< -I/usr/include/$(PYTHON)/
++      gcc -c $< -I/usr/include/$(PYTHON)/ -I../src/include/
  
  %_wrap.c: %.i 
        swig -python $<
This page took 0.10393 seconds and 4 git commands to generate.