]> git.pld-linux.org Git - packages/fam.git/commitdiff
- gcc 3.4 fix.
authorPaweł Sikora <pluto@pld-linux.org>
Tue, 17 Feb 2004 12:09:56 +0000 (12:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fam-gcc34.patch -> 1.1
    fam.spec -> 1.28

fam-gcc34.patch [new file with mode: 0644]
fam.spec

diff --git a/fam-gcc34.patch b/fam-gcc34.patch
new file mode 100644 (file)
index 0000000..2da8d09
--- /dev/null
@@ -0,0 +1,106 @@
+diff -uNr fam-2.6.10.orig/fam/DNotify.c++ fam-2.6.10/fam/DNotify.c++
+--- fam-2.6.10.orig/fam/DNotify.c++    2004-02-17 12:56:54.000000000 +0100
++++ fam-2.6.10/fam/DNotify.c++ 2004-02-17 13:00:18.321654784 +0100
+@@ -37,7 +37,7 @@
+ #include "Interest.h"
+ #include "Log.h"
+ #include "Scheduler.h"
+-#include "alloc.h"
++#include <malloc.h>
+ int DNotify::pipe_write_fd = -2;
+diff -uNr fam-2.6.10.orig/fam/IMon.c++ fam-2.6.10/fam/IMon.c++
+--- fam-2.6.10.orig/fam/IMon.c++       2003-04-15 06:21:31.000000000 +0200
++++ fam-2.6.10/fam/IMon.c++    2004-02-17 12:59:53.667402800 +0100
+@@ -42,7 +42,7 @@
+ #include "Interest.h"
+ #include "Log.h"
+ #include "Scheduler.h"
+-#include "alloc.h"
++#include <malloc.h>
+ int              IMon::imonfd = -2;
+ IMon::EventHandler IMon::ehandler = NULL;
+diff -uNr fam-2.6.10.orig/fam/SmallTable.h fam-2.6.10/fam/SmallTable.h
+--- fam-2.6.10.orig/fam/SmallTable.h   2003-04-15 06:21:43.000000000 +0200
++++ fam-2.6.10/fam/SmallTable.h        2004-02-17 12:56:54.985566568 +0100
+@@ -98,7 +98,7 @@
+ }
+ template <class Tkey, class Tvalue>
+-SmallTable<Tkey, Tvalue>::Closure
++typename SmallTable<Tkey, Tvalue>::Closure
+ SmallTable<Tkey, Tvalue>::position(const Tkey& key) const
+ {
+     unsigned l = 0, r = n;
+diff -uNr fam-2.6.10.orig/include/BTree.h fam-2.6.10/include/BTree.h
+--- fam-2.6.10.orig/include/BTree.h    2004-02-17 13:02:07.000000000 +0100
++++ fam-2.6.10/include/BTree.h 2004-02-17 12:56:54.986566416 +0100
+@@ -236,7 +236,7 @@
+ //  to the right and returns them.
+ template <class Key, class Value>
+-BTree<Key, Value>::Closure
++typename BTree<Key, Value>::Closure
+ BTree<Key, Value>::Node::remove(unsigned j)
+ {
+     Key k = key[j];
+@@ -348,7 +348,7 @@
+ }
+ template <class Key, class Value>
+-BTree<Key, Value>::Closure
++typename BTree<Key, Value>::Closure
+ BTree<Key, Value>::Node::next(const Key& pred) const
+ {
+     if (!this)
+@@ -404,7 +404,7 @@
+ //  nodes as necessary on the way back.
+ template <class Key, class Value>
+-BTree<Key, Value>::Closure
++typename BTree<Key, Value>::Closure
+ BTree<Key, Value>::insert(Node *p, const Key& key, const Value& value)
+ {
+     if (!p) return Closure(key, value, 0);
+@@ -499,7 +499,7 @@
+ //  Returns UNDER if node p is too small afterward, OK otherwise.
+ template <class Key, class Value>
+-BTree<Key, Value>::Status
++typename BTree<Key, Value>::Status
+ BTree<Key, Value>::underflow(Node *p, unsigned i)
+ {
+     assert(p);
+@@ -557,7 +557,7 @@
+ template <class Key, class Value>
+-BTree<Key, Value>::Closure
++typename BTree<Key, Value>::Closure
+ BTree<Key, Value>::remove_rightmost(Node *p)
+ {
+     int i = p->n;
+@@ -587,7 +587,7 @@
+ //  back up.
+ template <class Key, class Value>
+-BTree<Key, Value>::Status
++typename BTree<Key, Value>::Status
+ BTree<Key, Value>::remove(Node *p, const Key& key)
+ {
+     if (!p)
+diff -uNr fam-2.6.10.orig/libfam/Client.c++ fam-2.6.10/libfam/Client.c++
+--- fam-2.6.10.orig/libfam/Client.c++  2003-04-15 06:21:25.000000000 +0200
++++ fam-2.6.10/libfam/Client.c++       2004-02-17 12:56:54.987566264 +0100
+@@ -34,7 +34,8 @@
+ #include <syslog.h>
+ #include <errno.h>
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+ #include "fam.h"
+ #include "Client.h"
index 2772ae16f6052e45c8244ac88fa7dccaef48c5b0..31def2addea395dc4f771c4c7b17545f132af86c 100644 (file)
--- a/fam.spec
+++ b/fam.spec
@@ -13,6 +13,7 @@ Patch0:               %{name}-dnotify.patch
 Patch1:                %{name}-build.patch
 Patch2:                %{name}-rpcsvc.patch
 Patch3:                %{name}-cleanup.patch
+Patch4:                %{name}-gcc34.patch
 URL:           http://oss.sgi.com/projects/fam/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -101,6 +102,7 @@ Bibliotecas est
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 rm -f missing
This page took 0.073481 seconds and 4 git commands to generate.