]> git.pld-linux.org Git - packages/fakeroot.git/blobdiff - fakeroot.spec
Up to 1.26; dlsym patch obsolete (according to debian changelog for fakeroot)
[packages/fakeroot.git] / fakeroot.spec
index 8d282115e787a504f9a1d708054f58d04829b50c..59dc1fbfbd68c63ac3f42fa0b59b15cbf750f245 100644 (file)
@@ -1,66 +1,84 @@
 Summary:       Gives a fake root environment
-Summary(pl):   Umo¿liwia uzyskanie ,,podrobionego'' ¶rodowiska roota
-Summary(pt_BR):        Cria um falso ambiente de root
+Summary(pl.UTF-8):     "Podrobione" środowiska roota
+Summary(pt_BR.UTF-8):  Cria um falso ambiente de root
 Name:          fakeroot
-Version:       0.4.5
-Release:       4
-%define                debver 2.1
-License:       GPL (see COPYING)
+Version:       1.26
+Release:       1
+License:       GPL v3+
 Group:         Development/Tools
-Source0:       ftp://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}_%{version}-%{debver}.tar.gz
-Patch0:                %{name}-ac_fix.patch
-Patch1:                %{name}-amfix.patch
-BuildRequires: autoconf
+Source0:       http://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}_%{version}.orig.tar.gz
+# Source0-md5: cb1c68f2597f0a064232a841050eb6f2
+BuildRequires: acl-devel
+BuildRequires: autoconf >= 2.61
 BuildRequires: automake
-BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2
+BuildRequires: po4a
 Requires:      util-linux
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                pkglibdir               %{_libdir}/libfakeroot
+
 %description
-This package is intended to enable something like: fakeroot rpm
---rebuild i.e. to remove the need to become root for a package
-build. This is done by setting LD_PRELOAD to a "libfakeroot.so.0.0",
-that provides wrappers around chown, chmod, mknod, stat, etc.
+fakeroot runs a command in an environment were it appears to have root
+privileges for file manipulation. This is useful for allowing users to
+create archives (tar, ar, .deb etc.) with files in them with root
+permissions/ownership. Without fakeroot one would have to have root
+privileges to create the constituent files of the archives with the
+correct permissions and ownership, and then pack them up, or one would
+have to construct the archives directly, without using the archiver.
 
-If you don't understand any of this, you do not need this!
+fakeroot works by replacing the file manipulation library functions
+(chmod(), stat() etc.) by ones that simulate the effect the real
+library functions would have had, had the user really been root. These
+wrapper functions are in a shared library libfakeroot.so*, which is
+loaded through the LD_PRELOAD mechanism of the dynamic loader.
 
-%description -l pl
-Pakiet w zamierzeniu pozwala na wykonanie operacji takich jak:
-fakeroot rpm --rebuild by usun±æ potrzebê operowania z u¿ytkownika
-root w celu zbudowania pakietu. Fakeroot wykorzystuje LD_PRELOAD,
-któr± to zmienn± ustawia na "libfakeroot.so.0.0" - bibliotekê, która
-dostarcza w³asne chown, chmod, mknod, stat itp.
+%description -l pl.UTF-8
+Program fakeroot uruchamia polecenia w środowisku, gdzie wydaje im
+się, że mają uprawnienia roota przy operacjach na plikach. Jest to
+przydatne, aby umożliwić użytkownikom na tworzenie archiwów (tar, ar,
+deb) z plikami mającymi będącymi własnością roota. Bez fakeroota do
+tworzenia takich plików z właściwymi uprawnieniami potrzebne byłyby
+uprawnienia roota lub bezpośrednie tworzenie archiwów bez użycia
+normalnego archiwizera.
 
-Je¶li nie rozumiesz niczego z powy¿szych informacji to nie
-potrzebujesz tego pakietu!
+fakeroot działa poprzez podmianę funkcji bibliotecznych operujących na
+plikach (chmod(), stat() itp.) na takie, które symulują efekt
+prawdziwych funkcji gdyby były uruchamiane z uprawnieniami roota. Te
+specjalne funkcje znajdują się w bibliotece dzielonej libfakeroot.so*
+ładowanej poprzez mechanizm LD_PRELOAD.
 
-%description -l pt_BR
-Este pacote permite a construção de pacotes por usuários sem
-privilégios de root. Isso e' feito utilizando libfakeroot.so com
+%description -l pt_BR.UTF-8
+Este pacote permite a construção de pacotes por usuários sem
+privilégios de root. Isso e' feito utilizando libfakeroot.so com
 LD_PRELOAD, que prove implementacoes de getuid, chown, chmod, mknod,
 stat e outros, criando um falso ambiente de root.
 
 %prep
-%setup -q -n %{name}-%{version}
-%patch0 -p1
-%patch1 -p1
+%setup -q
 
 %build
-rm -f missing
-libtoolize --copy --force
-aclocal
-autoconf
-automake -a -c
-%configure
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --libdir=%{pkglibdir} \
+       --disable-static
+
+cd doc
+po4a -k 0 --rm-backups --variable "srcdir=../doc/" po4a/po4a.cfg
+cd ..
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf DEBUG AUTHORS COPYING README.fake BUGS debian/changelog
+%{__rm} $RPM_BUILD_ROOT%{pkglibdir}/libfakeroot.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -70,8 +88,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz debian/*.gz
-%attr(755,root,root) %{_bindir}/*
-%dir %{_libdir}/libfakeroot
-%attr(755,root,root) %{_libdir}/libfakeroot/lib*so.*
-%{_mandir}/man*/*
+%doc AUTHORS BUGS DEBUG README
+%attr(755,root,root) %{_bindir}/faked
+%attr(755,root,root) %{_bindir}/fakeroot
+%dir %{pkglibdir}
+%attr(755,root,root) %{pkglibdir}/libfakeroot*.so
+%{_mandir}/man1/faked.1*
+%{_mandir}/man1/fakeroot.1*
+%lang(de) %{_mandir}/de/man1/*
+%lang(es) %{_mandir}/es/man1/*
+%lang(fr) %{_mandir}/fr/man1/*
+%lang(nl) %{_mandir}/nl/man1/*
+%lang(pt) %{_mandir}/pt/man1/*
+%lang(sv) %{_mandir}/sv/man1/*
This page took 0.094596 seconds and 4 git commands to generate.