]> git.pld-linux.org Git - packages/fakeroot.git/blob - fakeroot.spec
Up to 1.26; dlsym patch obsolete (according to debian changelog for fakeroot)
[packages/fakeroot.git] / fakeroot.spec
1 # TODO
2 # - why the library can't be in standard %{_libdir}?
3
4 Summary:        Gives a fake root environment
5 Summary(pl.UTF-8):      "Podrobione" środowiska roota
6 Summary(pt_BR.UTF-8):   Cria um falso ambiente de root
7 Name:           fakeroot
8 Version:        1.21
9 Release:        2
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        ftp://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}_%{version}.orig.tar.gz
13 # Source0-md5:  be5c9a0e516869fca4a6758105968e5a
14 Patch0:         hide-dlsym-error.patch
15 URL:            http://fakeroot.alioth.debian.org/
16 BuildRequires:  acl-devel
17 BuildRequires:  autoconf >= 2.61
18 BuildRequires:  automake
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  po4a
21 Requires:       util-linux
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _libexecdir             %{_prefix}/%{_lib}/libfakeroot
25
26 %description
27 fakeroot runs a command in an environment were it appears to have root
28 privileges for file manipulation. This is useful for allowing users to
29 create archives (tar, ar, .deb etc.) with files in them with root
30 permissions/ownership. Without fakeroot one would have to have root
31 privileges to create the constituent files of the archives with the
32 correct permissions and ownership, and then pack them up, or one would
33 have to construct the archives directly, without using the archiver.
34
35 fakeroot works by replacing the file manipulation library functions
36 (chmod(), stat() etc.) by ones that simulate the effect the real
37 library functions would have had, had the user really been root. These
38 wrapper functions are in a shared library libfakeroot.so*, which is
39 loaded through the LD_PRELOAD mechanism of the dynamic loader.
40
41 %description -l pl.UTF-8
42 Program fakeroot uruchamia polecenia w środowisku, gdzie wydaje im
43 się, że mają uprawnienia roota przy operacjach na plikach. Jest to
44 przydatne, aby umożliwić użytkownikom na tworzenie archiwów (tar, ar,
45 deb) z plikami mającymi będącymi własnością roota. Bez fakeroota do
46 tworzenia takich plików z właściwymi uprawnieniami potrzebne byłyby
47 uprawnienia roota lub bezpośrednie tworzenie archiwów bez użycia
48 normalnego archiwizera.
49
50 fakeroot działa poprzez podmianę funkcji bibliotecznych operujących na
51 plikach (chmod(), stat() itp.) na takie, które symulują efekt
52 prawdziwych funkcji gdyby były uruchamiane z uprawnieniami roota. Te
53 specjalne funkcje znajdują się w bibliotece dzielonej libfakeroot.so*
54 ładowanej poprzez mechanizm LD_PRELOAD.
55
56 %description -l pt_BR.UTF-8
57 Este pacote permite a construção de pacotes por usuários sem
58 privilégios de root. Isso e' feito utilizando libfakeroot.so com
59 LD_PRELOAD, que prove implementacoes de getuid, chown, chmod, mknod,
60 stat e outros, criando um falso ambiente de root.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         --libdir=%{_libexecdir} \
74         --disable-static
75
76 cd doc
77 po4a -k 0 --rm-backups --variable "srcdir=../doc/" po4a/po4a.cfg
78 cd ..
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %{__rm} $RPM_BUILD_ROOT%{_libexecdir}/libfakeroot.la
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS BUGS DEBUG README
98 %attr(755,root,root) %{_bindir}/faked
99 %attr(755,root,root) %{_bindir}/fakeroot
100 %dir %{_libexecdir}
101 %attr(755,root,root) %{_libexecdir}/libfakeroot*.so
102 %{_mandir}/man1/faked.1*
103 %{_mandir}/man1/fakeroot.1*
104 %lang(de) %{_mandir}/de/man1/*
105 %lang(es) %{_mandir}/es/man1/*
106 %lang(fr) %{_mandir}/fr/man1/*
107 %lang(nl) %{_mandir}/nl/man1/*
108 %lang(pt) %{_mandir}/pt/man1/*
109 %lang(sv) %{_mandir}/sv/man1/*
This page took 0.092264 seconds and 3 git commands to generate.