]> git.pld-linux.org Git - packages/fakeroot.git/blame_incremental - fakeroot.spec
do not redefine %{_libdir}
[packages/fakeroot.git] / fakeroot.spec
... / ...
CommitLineData
1# TODO
2# - why the library can't be in standard %{_libdir}?
3
4Summary: Gives a fake root environment
5Summary(pl.UTF-8): "Podrobione" środowiska roota
6Summary(pt_BR.UTF-8): Cria um falso ambiente de root
7Name: fakeroot
8Version: 1.21
9Release: 1
10License: GPL v3+
11Group: Development/Tools
12Source0: ftp://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}_%{version}.orig.tar.gz
13# Source0-md5: be5c9a0e516869fca4a6758105968e5a
14URL: http://fakeroot.alioth.debian.org/
15BuildRequires: acl-devel
16BuildRequires: autoconf >= 2.61
17BuildRequires: automake
18BuildRequires: libtool >= 2:2.2
19BuildRequires: po4a
20Requires: util-linux
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _libexecdir %{_prefix}/%{_lib}/libfakeroot
24
25%description
26fakeroot runs a command in an environment were it appears to have root
27privileges for file manipulation. This is useful for allowing users to
28create archives (tar, ar, .deb etc.) with files in them with root
29permissions/ownership. Without fakeroot one would have to have root
30privileges to create the constituent files of the archives with the
31correct permissions and ownership, and then pack them up, or one would
32have to construct the archives directly, without using the archiver.
33
34fakeroot works by replacing the file manipulation library functions
35(chmod(), stat() etc.) by ones that simulate the effect the real
36library functions would have had, had the user really been root. These
37wrapper functions are in a shared library libfakeroot.so*, which is
38loaded through the LD_PRELOAD mechanism of the dynamic loader.
39
40%description -l pl.UTF-8
41Program fakeroot uruchamia polecenia w środowisku, gdzie wydaje im
42się, że mają uprawnienia roota przy operacjach na plikach. Jest to
43przydatne, aby umożliwić użytkownikom na tworzenie archiwów (tar, ar,
44deb) z plikami mającymi będącymi własnością roota. Bez fakeroota do
45tworzenia takich plików z właściwymi uprawnieniami potrzebne byłyby
46uprawnienia roota lub bezpośrednie tworzenie archiwów bez użycia
47normalnego archiwizera.
48
49fakeroot działa poprzez podmianę funkcji bibliotecznych operujących na
50plikach (chmod(), stat() itp.) na takie, które symulują efekt
51prawdziwych funkcji gdyby były uruchamiane z uprawnieniami roota. Te
52specjalne funkcje znajdują się w bibliotece dzielonej libfakeroot.so*
53ładowanej poprzez mechanizm LD_PRELOAD.
54
55%description -l pt_BR.UTF-8
56Este pacote permite a construção de pacotes por usuários sem
57privilégios de root. Isso e' feito utilizando libfakeroot.so com
58LD_PRELOAD, que prove implementacoes de getuid, chown, chmod, mknod,
59stat e outros, criando um falso ambiente de root.
60
61%prep
62%setup -q
63
64%build
65%{__libtoolize}
66%{__aclocal}
67%{__autoconf}
68%{__autoheader}
69%{__automake}
70%configure \
71 --libdir=%{_libexecdir} \
72 --disable-static
73
74cd doc
75po4a -k 0 --rm-backups --variable "srcdir=../doc/" po4a/po4a.cfg
76cd ..
77
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85%{__rm} $RPM_BUILD_ROOT%{_libexecdir}/libfakeroot.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS BUGS DEBUG README
96%attr(755,root,root) %{_bindir}/faked
97%attr(755,root,root) %{_bindir}/fakeroot
98%dir %{_libexecdir}
99%attr(755,root,root) %{_libexecdir}/libfakeroot*.so
100%{_mandir}/man1/faked.1*
101%{_mandir}/man1/fakeroot.1*
102%lang(de) %{_mandir}/de/man1/*
103%lang(es) %{_mandir}/es/man1/*
104%lang(fr) %{_mandir}/fr/man1/*
105%lang(nl) %{_mandir}/nl/man1/*
106%lang(pt) %{_mandir}/pt/man1/*
107%lang(sv) %{_mandir}/sv/man1/*
This page took 0.091673 seconds and 4 git commands to generate.