]> git.pld-linux.org Git - packages/fail.git/blob - fail.spec
- release 2 (by relup.sh)
[packages/fail.git] / fail.spec
1 # TODO:
2 # - register gnome thumbnailer in more package-friendly way (not multiple gconftool runs)
3 # - webapp config for -html5? (optional, may be used also locally)
4 #
5 # Conditional build:
6 %bcond_without  html5   # HTML5 viewer
7 %bcond_without  magick  # ImageMagick coder
8 #
9 Summary:        FAIL - First Atari Image Library
10 Summary(pl.UTF-8):      FAIL (First Atari Image Library) - biblioteka do obrazów w formatach Atari
11 Name:           fail
12 Version:        2.0.1
13 Release:        2
14 License:        GPL v2+
15 Group:          Applications/Graphics
16 Source0:        http://downloads.sourceforge.net/fail/%{name}-%{version}.tar.gz
17 # Source0-md5:  b9362106f9a23a1f99ff7bece94d9aa7
18 URL:            http://fail.sourceforge.net/
19 %{?with_magick:BuildRequires:   ImageMagick-devel >= 1:6.8}
20 %{?with_html5:BuildRequires:    asciidoc}
21 %{?with_html5:BuildRequires:    cito}
22 BuildRequires:  libpng-devel
23 BuildRequires:  libxslt-progs
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %if %{with magick}
28 %define         im_coders_dir   %{_libdir}/%(MagickCore-config --version | sed -e 's,^\\([.0-9]\\+\\) \\+\\(Q[0-9]\\+\\)\\( \\+\\(HDRI\\)\\)\\?.*,ImageMagick-\\1/modules-\\2\\4,')/coders
29 %endif
30
31 %description
32 FAIL is a viewer of pictures in native formats of Atari 8-bit, Atari
33 ST, Atari Falcon and Atari Portfolio computers.
34
35 %description -l pl.UTF-8
36 FAIL to narzędzia do przeglądania obrazów w natywnych formatach
37 komputerów Atari 8-bitowych, Atari ST, Atari Falcon oraz Atari
38 Portfolio.
39
40 %package gnome
41 Summary:        FAIL support for viewing Atari files in GNOME
42 Summary(pl.UTF-8):      Wsparcie FAIL do oglądania plików z Atari w GNOME
43 Group:          X11/Applications/Graphics
44 Requires:       %{name} = %{version}-%{release}
45
46 %description gnome
47 FAIL support for viewing Atari files in GNOME.
48
49 %description gnome -l pl.UTF-8
50 Wsparcie FAIL do oglądania plików z Atari w GNOME.
51
52 %package html5
53 Summary:        HTML5 FAIL viewer for Atari files
54 Summary(pl.UTF-8):      Przeglądarka FAIL do plików z Atari w HTML5
55 Group:          Applications/WWW
56
57 %description html5
58 HTML5 FAIL viewer for Atari files.
59
60 %description html5 -l pl.UTF-8
61 Przeglądarka FAIL do plików z Atari w HTML5.
62
63 %package -n ImageMagick-coder-fail
64 Summary:        FAIL coder for ImageMagick
65 Summary(pl.UTF-8):      Koder FAIL dla ImageMagicka
66 Group:          Libraries
67 %requires_ge_to ImageMagick ImageMagick-devel
68
69 %description -n ImageMagick-coder-fail
70 FAIL coder for ImageMagick to read Atari formats.
71
72 %description -n ImageMagick-coder-fail -l pl.UTF-8
73 Koder FAIL dla ImageMagicka, czytający formaty Atari.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__make} all fail-mime.xml \
80         CC="%{__cc}" \
81         CFLAGS="%{rpmcflags} -Wall" \
82 %if %{with magick}
83         MAGICK_INCLUDE_PATH=/usr/include/ImageMagick-6/private \
84         CAN_INSTALL_MAGICK=1
85 %endif
86
87 %if %{with html5}
88 %{__make} -C html5
89 %endif
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install-fail2png \
95         PREFIX=$RPM_BUILD_ROOT%{_prefix}
96
97 # install-thumbnailer is ugly; for now, install only this one
98 install -D fail-mime.xml $RPM_BUILD_ROOT%{_datadir}/mime/packages/fail-mime.xml
99
100 %if %{with magick}
101 install -D fail.so $RPM_BUILD_ROOT%{im_coders_dir}/fail.so
102 echo "dlname='fail.so'" >$RPM_BUILD_ROOT%{im_coders_dir}/fail.la
103 %endif
104
105 %if %{with html5}
106 install -d $RPM_BUILD_ROOT%{_datadir}/fail-html5
107 cp -p html5/*.{js,html} $RPM_BUILD_ROOT%{_datadir}/fail-html5
108 %endif
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README.html
116 %attr(755,root,root) %{_bindir}/fail2png
117
118 %files gnome
119 %defattr(644,root,root,755)
120 %{_datadir}/mime/packages/fail-mime.xml
121 # TODO: gconf files?
122
123 %if %{with html5}
124 %files html5
125 %defattr(644,root,root,755)
126 %{_datadir}/fail-html5
127 %endif
128
129 %if %{with magick}
130 %files -n ImageMagick-coder-fail
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{im_coders_dir}/fail.so
133 %{im_coders_dir}/fail.la
134 %endif
This page took 0.079961 seconds and 3 git commands to generate.