]> git.pld-linux.org Git - packages/faad2.git/commitdiff
- updated for 2.6.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 4 Nov 2007 12:08:17 +0000 (12:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    faad2-make.patch -> 1.3
    faad2-mpeg4ip.patch -> 1.4
    faad2-soname.patch -> 1.2

faad2-make.patch
faad2-mpeg4ip.patch
faad2-soname.patch

index cc5a7489f2cca406d222d0a41dc1e2dcfa5c7e7b..fbd3cb351eecf1e4055b12111da6af17def3c40a 100644 (file)
@@ -1,54 +1,23 @@
 --- faad2/libfaad/Makefile.am.orig     2004-11-08 09:06:09.000000000 +0100
-+++ faad2/libfaad/Makefile.am  2006-08-23 23:39:14.753322500 +0200
-@@ -3,7 +3,7 @@
- include_HEADERS = $(top_srcdir)/include/faad.h \\r
-                   $(top_srcdir)/include/neaacdec.h\r
\r
--libfaad_la_LDFLAGS = -lm\r
-+libfaad_la_LIBADD = -lm\r
\r
- libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \\r
- drm_dec.c error.c filtbank.c \\r
---- faad2/plugins/Makefile.am.orig     2006-08-07 20:47:45.000000000 +0200
-+++ faad2/plugins/Makefile.am  2006-08-24 00:00:04.739441750 +0200
-@@ -8,10 +8,6 @@
- if HAVE_XMMS\r
- SUBDIRS = xmms\r
- else\r
--if HAVE_BMP\r
--SUBDIRS = bmp\r
--else\r
- SUBDIRS =\r
--endif #HAVE_BMP\r
- endif #HAVE_XMMS\r
- endif #HAVE_MPEG4IP_PLUG\r
---- faad2/plugins/xmms/src/Makefile.am.orig    2006-08-07 20:47:45.000000000 +0200
-+++ faad2/plugins/xmms/src/Makefile.am 2006-08-24 00:01:12.775693750 +0200
-@@ -1,13 +1,13 @@
- if HAVE_BMP\r
--libdir=$(shell pkg-config --variable=input-plugin-dir bmp)\r
-+plugindir=$(shell pkg-config --variable=input-plugin-dir bmp)\r
- local_CFLAGS=$(shell pkg-config --cflags bmp)\r
- local_LDFLAGS=$(shell pkg-config --libs bmp)\r
- else\r
- local_CFLAGS=`$(XMMS_CONFIG) --cflags` -Wall\r
- local_LDFLAGS=`$(XMMS_CONFIG) --libs`\r
--libdir = `$(XMMS_CONFIG) --input-plugin-dir`\r
-+plugindir = `$(XMMS_CONFIG) --input-plugin-dir`\r
- endif #HAVE_BMP\r
--lib_LTLIBRARIES = libmp4.la\r
-+plugin_LTLIBRARIES = libmp4.la\r
\r
- libmp4_la_CFLAGS = $(local_CFLAGS) -Wall \\r
-        -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4ff\r
---- faad2/configure.in.orig    2006-08-13 16:13:31.000000000 +0200
-+++ faad2/configure.in 2006-08-24 00:04:16.259160750 +0200
-@@ -118,6 +118,8 @@
-   AC_DEFINE([HAVE_BMP], 1, [User wants beep media player plugin built])\r
-   AM_CONDITIONAL([HAVE_XMMS], true)\r
-   AM_CONDITIONAL([HAVE_BMP], true)\r
-+else\r
-+  AM_CONDITIONAL([HAVE_BMP], false)\r
- fi\r
\r
- if test x$WITHDRM = xyes; then\r
++++ faad2/libfaad/Makefile.am  2007-11-04 11:44:26.132686561 +0100
+@@ -3,7 +3,7 @@ lib_LTLIBRARIES = libfaad.la
+ include_HEADERS = $(top_srcdir)/include/faad.h \
+                   $(top_srcdir)/include/neaacdec.h
+-libfaad_la_LDFLAGS = -lm
++libfaad_la_LIBADD = -lm
+ libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
+ drm_dec.c error.c filtbank.c \
+--- faad2/plugins/xmms/src/Makefile.am.orig    2006-09-25 21:52:53.000000000 +0200
++++ faad2/plugins/xmms/src/Makefile.am 2007-11-04 11:45:59.870028348 +0100
+@@ -1,7 +1,7 @@
+ local_CFLAGS=`$(XMMS_CONFIG) --cflags` -Wall
+ local_LDFLAGS=`$(XMMS_CONFIG) --libs`
+-libdir = `$(XMMS_CONFIG) --input-plugin-dir`
+-lib_LTLIBRARIES = libmp4.la
++plugindir = `$(XMMS_CONFIG) --input-plugin-dir`
++plugin_LTLIBRARIES = libmp4.la
+ libmp4_la_CFLAGS = $(local_CFLAGS) -Wall \
+        -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4ff
index cd97ce40bf5d759807c32c12e9e5710269c5512c..507588c80ad25a06128e4ba37afe71824bfd92c6 100644 (file)
 --- faad2/plugins/mpeg4ip/faad2.cpp.orig       2004-08-20 10:30:53.000000000 +0200
 +++ faad2/plugins/mpeg4ip/faad2.cpp    2006-08-24 08:27:51.399489000 +0200
 @@ -35,7 +35,7 @@
- /*\r
-  * Create CAACodec class\r
-  */\r
--static codec_data_t *aac_codec_create (const char *compressor,\r
-+static codec_data_t *aac_codec_create (const char *stream_type, const char *compressor,\r
-                        int type,\r
-                        int profile,\r
-                        format_list_t *media_fmt,\r
+ /*
+  * Create CAACodec class
+  */
+-static codec_data_t *aac_codec_create (const char *compressor,
++static codec_data_t *aac_codec_create (const char *stream_type, const char *compressor,
+                        int type,
+                        int profile,
+                        format_list_t *media_fmt,
 @@ -148,7 +148,7 @@
-  * Decode task call for FAAC\r
-  */\r
- static int aac_decode (codec_data_t *ptr,\r
--               uint64_t ts,\r
-+               frame_timestamp_t *ts,\r
-                int from_rtp,\r
-                int *sync_frame,\r
-                uint8_t *buffer,\r
+  * Decode task call for FAAC
+  */
+ static int aac_decode (codec_data_t *ptr,
+-               uint64_t ts,
++               frame_timestamp_t *ts,
+                int from_rtp,
+                int *sync_frame,
+                uint8_t *buffer,
 @@ -163,15 +163,15 @@
-   if (aac->m_record_sync_time) {\r
-     aac->m_current_frame = 0;\r
-     aac->m_record_sync_time = 0;\r
--    aac->m_current_time = ts;\r
--    aac->m_last_rtp_ts = ts;\r
-+    aac->m_current_time = ts->msec_timestamp;\r
-+    aac->m_last_rtp_ts = ts->msec_timestamp;\r
-   } else {\r
--    if (aac->m_last_rtp_ts == ts) {\r
-+    if (aac->m_last_rtp_ts == ts->msec_timestamp) {\r
-       aac->m_current_time += aac->m_msec_per_frame;\r
-       aac->m_current_frame++;\r
-     } else {\r
--      aac->m_last_rtp_ts = ts;\r
--      aac->m_current_time = ts;\r
-+      aac->m_last_rtp_ts = ts->msec_timestamp;\r
-+      aac->m_current_time = ts->msec_timestamp;\r
-       aac->m_current_frame = 0;\r
-     }\r
\r
+   if (aac->m_record_sync_time) {
+     aac->m_current_frame = 0;
+     aac->m_record_sync_time = 0;
+-    aac->m_current_time = ts;
+-    aac->m_last_rtp_ts = ts;
++    aac->m_current_time = ts->msec_timestamp;
++    aac->m_last_rtp_ts = ts->msec_timestamp;
+   } else {
+-    if (aac->m_last_rtp_ts == ts) {
++    if (aac->m_last_rtp_ts == ts->msec_timestamp) {
+       aac->m_current_time += aac->m_msec_per_frame;
+       aac->m_current_frame++;
+     } else {
+-      aac->m_last_rtp_ts = ts;
+-      aac->m_current_time = ts;
++      aac->m_last_rtp_ts = ts->msec_timestamp;
++      aac->m_current_time = ts->msec_timestamp;
+       aac->m_current_frame = 0;
+     }
 @@ -239,7 +239,7 @@
-                   aac->m_chans,\r
-                   (audio_format_t)AUDIO_S16SYS,\r
-                   aac->m_output_frame_size);\r
--      uint8_t *now = aac->m_vft->audio_get_buffer(aac->m_ifptr);\r
-+      uint8_t *now = aac->m_vft->audio_get_buffer(aac->m_ifptr, (ts->msec_timestamp * aac->m_freq) / 1000, ts->msec_timestamp);\r
-       aac->m_audio_inited = 1;\r
-     }\r
-     /*\r
+                   aac->m_chans,
+                   (audio_format_t)AUDIO_S16SYS,
+                   aac->m_output_frame_size);
+-      uint8_t *now = aac->m_vft->audio_get_buffer(aac->m_ifptr);
++      uint8_t *now = aac->m_vft->audio_get_buffer(aac->m_ifptr, (ts->msec_timestamp * aac->m_freq) / 1000, ts->msec_timestamp);
+       aac->m_audio_inited = 1;
+     }
+     /*
 @@ -281,6 +281,7 @@
- };\r
\r
- static int aac_codec_check (lib_message_func_t message,\r
-+              const char *stream_type,\r
-                 const char *compressor,\r
-                 int type,\r
-                 int profile,\r
+ };
+ static int aac_codec_check (lib_message_func_t message,
++              const char *stream_type,
+                 const char *compressor,
+                 int type,
+                 int profile,
 @@ -322,7 +323,7 @@
-   }\r
-   if (userdata != NULL) {\r
-     mpeg4_audio_config_t audio_config;\r
--    decode_mpeg4_audio_config(userdata, userdata_size, &audio_config);\r
-+    decode_mpeg4_audio_config(userdata, userdata_size, &audio_config, 1 /* ??? */);\r
-     message(LOG_DEBUG, "aac", "audio type is %d", audio_config.audio_object_type);\r
-     if (fmtp != NULL) free_fmtp_parse(fmtp);\r
\r
+   }
+   if (userdata != NULL) {
+     mpeg4_audio_config_t audio_config;
+-    decode_mpeg4_audio_config(userdata, userdata_size, &audio_config);
++    decode_mpeg4_audio_config(userdata, userdata_size, &audio_config, 1 /* ??? */);
+     message(LOG_DEBUG, "aac", "audio type is %d", audio_config.audio_object_type);
+     if (fmtp != NULL) free_fmtp_parse(fmtp);
 --- faad2/plugins/mpeg4ip/aa_file.cpp.orig     2004-01-05 15:05:12.000000000 +0100
 +++ faad2/plugins/mpeg4ip/aa_file.cpp  2006-08-24 08:33:42.189412000 +0200
 @@ -77,7 +77,7 @@
\r
- int aac_file_next_frame (codec_data_t *your,\r
-              uint8_t **buffer,\r
--             uint64_t *ts)\r
-+             frame_timestamp_t *ts)\r
- {\r
-   aac_codec_t *aac = (aac_codec_t *)your;\r
\r
+ int aac_file_next_frame (codec_data_t *your,
+              uint8_t **buffer,
+-             uint64_t *ts)
++             frame_timestamp_t *ts)
+ {
+   aac_codec_t *aac = (aac_codec_t *)your;
 @@ -98,7 +98,10 @@
-   uint64_t calc;\r
-   calc = aac->m_framecount * 1024 * M_LLU;\r
-   calc /= aac->m_freq;\r
--  *ts = calc;\r
-+  ts->msec_timestamp = calc;\r
-+  ts->audio_freq_timestamp = calc; /* XXX */\r
-+  ts->audio_freq = 1; /* XXX */\r
-+  ts->timestamp_is_pts = false;\r
-   *buffer = aac->m_buffer;\r
-   aac->m_framecount++;\r
-   return (aac->m_buffer_size);\r
+   uint64_t calc;
+   calc = aac->m_framecount * 1024 * M_LLU;
+   calc /= aac->m_freq;
+-  *ts = calc;
++  ts->msec_timestamp = calc;
++  ts->audio_freq_timestamp = calc; /* XXX */
++  ts->audio_freq = 1; /* XXX */
++  ts->timestamp_is_pts = false;
+   *buffer = aac->m_buffer;
+   aac->m_framecount++;
+   return (aac->m_buffer_size);
 --- faad2/plugins/mpeg4ip/faad2.h.orig 2004-01-05 15:05:12.000000000 +0100
 +++ faad2/plugins/mpeg4ip/faad2.h      2006-08-24 08:29:23.233228250 +0200
 @@ -81,7 +81,7 @@
\r
- int aac_file_next_frame(codec_data_t *ifptr,\r
-             uint8_t **buffer,\r
--            uint64_t *ts);\r
-+            frame_timestamp_t *ts);\r
- int aac_file_eof(codec_data_t *ifptr);\r
\r
- void aac_file_used_for_frame(codec_data_t *ifptr,\r
---- faad2/configure.in.orig    2006-08-24 00:22:15.814628000 +0200
-+++ faad2/configure.in 2006-08-24 18:02:34.414542750 +0200
-@@ -89,6 +89,8 @@
-    if test x$external_mp4v2 = xyes; then\r
-       AM_CONDITIONAL(HAVE_MPEG4IP_PLUG, true)\r
-       AC_MSG_NOTICE("Building MPEG4IP plugin")\r
-+      MPEG4IP_PLAYER_PLUGIN_DIR="`mpeg4ip-config --player-plugin-dir`"\r
-+      AC_SUBST(MPEG4IP_PLAYER_PLUGIN_DIR)\r
-    else\r
-       AC_MSG_NOTICE("MPEG4IP libmp4v2 is required for MPEG4IP plugin")\r
-    fi\r
+ int aac_file_next_frame(codec_data_t *ifptr,
+             uint8_t **buffer,
+-            uint64_t *ts);
++            frame_timestamp_t *ts);
+ int aac_file_eof(codec_data_t *ifptr);
+ void aac_file_used_for_frame(codec_data_t *ifptr,
+--- faad2/configure.in.orig    2006-09-25 21:52:53.000000000 +0200
++++ faad2/configure.in 2007-11-04 11:51:50.486008814 +0100
+@@ -123,6 +123,8 @@
+    if test x$external_mp4v2 = xyes; then
+       AM_CONDITIONAL(HAVE_MPEG4IP_PLUG, true)
+       AC_MSG_NOTICE("Building MPEG4IP plugin")
++      MPEG4IP_PLAYER_PLUGIN_DIR="`mpeg4ip-config --player-plugin-dir`"
++      AC_SUBST(MPEG4IP_PLAYER_PLUGIN_DIR)
+    else
+       AC_MSG_NOTICE("MPEG4IP libmp4v2 is required for MPEG4IP plugin")
+    fi
index 5127ffc513fd512129a843b5fe4e4f68a99a5815..63d00940d39883123a844d13e2dafd41b2b94a63 100644 (file)
@@ -1,10 +1,10 @@
 --- faad2/libfaad/Makefile.am.orig     2007-01-16 17:52:58.000000000 +0000
 +++ faad2/libfaad/Makefile.am  2007-01-16 17:53:29.000000000 +0000
 @@ -3,6 +3,7 @@
-                   $(top_srcdir)/include/neaacdec.h\r
\r
- libfaad_la_LIBADD = -lm\r
-+libfaad_la_LDFLAGS = -version-info 1:0:0\r
\r
- libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \\r
- drm_dec.c error.c filtbank.c \\r
+                   $(top_srcdir)/include/neaacdec.h
+ libfaad_la_LIBADD = -lm
++libfaad_la_LDFLAGS = -version-info 1:0:0
+ libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
+ drm_dec.c error.c filtbank.c \
This page took 0.074505 seconds and 4 git commands to generate.