]> git.pld-linux.org Git - packages/ezcomponents.git/blob - ezcomponents.spec
f9d40e1d5eacf9b3d0d0e65fdfefb4d7233c49ce
[packages/ezcomponents.git] / ezcomponents.spec
1 %include        /usr/lib/rpm/macros.php
2 Summary:        eZ Components
3 Name:           ezcomponents
4 Version:        2008.2
5 Release:        0.1
6 License:        New BSD License
7 Group:          Development/Languages/PHP
8 Source0:        http://ezcomponents.org/files/downloads/%{name}-%{version}.tar.bz2
9 # Source0-md5:  57b211e2e85670633ebb165e14742f95
10 URL:            http://www.ezcomponents.org/
11 BuildRequires:  php-common >= 4:5.1
12 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
13 BuildRequires:  rpmbuild(macros) >= 1.461
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _appdir %{php_data_dir}/%{name}
18
19 # fool adapter: allow version macro in url
20 %define         docver  %{version}
21
22 %description
23 eZ Components is an enterprise ready general purpose PHP components
24 library used independently or together for PHP application
25 development. With eZ Components, developers do not have to reinvent
26 the wheel, instead they can concentrate on solving customer-specific
27 needs.
28
29 %package Archive
30 Summary:        Archive
31 Group:          Development/Languages/PHP
32 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Archive.html
33 Requires:       %{name} = %{version}-%{release}
34
35 %description Archive
36 The component allows you to create, modify, and extract archive files
37 of various formats. The currently supported archives formats are Tar
38 (with the flavours: ustar, v7, pax, and gnu) and Zip.
39
40 %package Authentication
41 Summary:        Authentication
42 Group:          Development/Languages/PHP
43 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Authentication.html
44 Requires:       %{name} = %{version}-%{release}
45
46 %description Authentication
47 The purpose of the Authentication component is to provide support for
48 different means of identification and authentication of users using
49 different providers and protocols.
50
51 %package AuthenticationDatabaseTiein
52 Summary:        AuthenticationDatabaseTiein
53 Group:          Development/Languages/PHP
54 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_AuthenticationDatabaseTiein.html
55 Requires:       %{name} = %{version}-%{release}
56
57 %description AuthenticationDatabaseTiein
58 The purpose of the Authentication component is to provide support for
59 different means of identification and authentication of users using
60 different providers and protocols.
61
62 %package Base
63 Summary:        Base
64 Group:          Development/Languages/PHP
65 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Base.html
66 Requires:       %{name} = %{version}-%{release}
67
68 %description Base
69 The Base package provides the basic infrastructure that all packages
70 rely on. Therefore every component relies on this package.
71
72 %package Cache
73 Summary:        Cache
74 Group:          Development/Languages/PHP
75 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Cache.html
76 Requires:       %{name} = %{version}-%{release}
77
78 %description Cache
79 A solution for caching, supporting multiple backends allowing you to
80 specify the best performing solution for your caching-problem.
81
82 %package Configuration
83 Summary:        Configuration
84 Group:          Development/Languages/PHP
85 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Configuration.html
86 Requires:       %{name} = %{version}-%{release}
87
88 %description Configuration
89 A component that allows you to use configuration files in different
90 formats. The formats include the standard .ini file, and an array
91 based format.
92
93 %package ConsoleTools
94 Summary:        ConsoleTools
95 Group:          Development/Languages/PHP
96 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ConsoleTools.html
97 Requires:       %{name} = %{version}-%{release}
98
99 %description ConsoleTools
100 A set of classes to do different actions with the console (also called
101 shell). It can render a progress bar, tables and a status bar and
102 contains a class for parsing command line options.
103
104 %package Database
105 Summary:        Database
106 Group:          Development/Languages/PHP
107 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Database.html
108 Requires:       %{name} = %{version}-%{release}
109
110 %description Database
111 A lightweight database layer on top of PHP's PDO that allows you to
112 utilize a database without having to take care of differences in SQL
113 dialects.
114
115 %package DatabaseSchema
116 Summary:        DatabaseSchema
117 Group:          Development/Languages/PHP
118 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_DatabaseSchema.html
119 Requires:       %{name} = %{version}-%{release}
120
121 %description DatabaseSchema
122 A set of classes that allow you to extract information from a database
123 schema, compare database schemas and apply a set of changes to a
124 database schema.
125
126 %package Debug
127 Summary:        Debug
128 Group:          Development/Languages/PHP
129 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Debug.html
130 Requires:       %{name} = %{version}-%{release}
131
132 %description Debug
133 This component provides a set of classes that help you to debug an
134 application. It provides timers and report generators for different
135 formats that give a summary of warnings and errors that occurred
136 within your application.
137
138 %package Document
139 Summary:        Document
140 Group:          Development/Languages/PHP
141 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Document.html
142 Requires:       %{name} = %{version}-%{release}
143
144 %description Document
145 The Document components provides a general conversion framework for
146 different semantic document markup languages like XHTML, Docbook, RST
147 and similar.
148
149 %package EventLog
150 Summary:        EventLog
151 Group:          Development/Languages/PHP
152 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLog.html
153 Requires:       %{name} = %{version}-%{release}
154
155 %description EventLog
156 Allows you to log events or audit trails into files or other storage
157 spaces in different formats.
158
159 %package EventLogDatabaseTiein
160 Summary:        EventLogDatabaseTiein
161 Group:          Development/Languages/PHP
162 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLogDatabaseTiein.html
163 Requires:       %{name} = %{version}-%{release}
164
165 %description EventLogDatabaseTiein
166 Contains the database writer backend for the EventLog component.
167
168 %package Execution
169 Summary:        Execution
170 Group:          Development/Languages/PHP
171 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Execution.html
172 Requires:       %{name} = %{version}-%{release}
173
174 %description Execution
175 Provides functionality to give feedback to your application's users
176 when a fatal error happened or an uncaught exception was thrown.
177
178 %package Feed
179 Summary:        Feed
180 Group:          Development/Languages/PHP
181 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Feed.html
182 Requires:       %{name} = %{version}-%{release}
183
184 %description Feed
185 This component handles parsing and creating RSS1, RSS2 and ATOM feeds,
186 with support for different feed modules (dc, content, creativeCommons,
187 geo, iTunes).
188
189 %package File
190 Summary:        File
191 Group:          Development/Languages/PHP
192 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_File.html
193 Requires:       %{name} = %{version}-%{release}
194
195 %description File
196 Provides support for file operations which are not covered by PHP or
197 are just missing.
198
199 %package Graph
200 Summary:        Graph
201 Group:          Development/Languages/PHP
202 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Graph.html
203 Requires:       %{name} = %{version}-%{release}
204
205 %description Graph
206 A component for creating pie charts, line graphs and other kinds of
207 diagrams.
208
209 %package GraphDatabaseTiein
210 Summary:        GraphDatabaseTiein
211 Group:          Development/Languages/PHP
212 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_GraphDatabaseTiein.html
213 Requires:       %{name} = %{version}-%{release}
214
215 %description GraphDatabaseTiein
216 The GraphDatabaseTiein provides functionality to directly use PDO
217 statements as basis for ezcGraph Datasets.
218
219 %package ImageAnalysis
220 Summary:        ImageAnalysis
221 Group:          Development/Languages/PHP
222 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageAnalysis.html
223 Requires:       %{name} = %{version}-%{release}
224
225 %description ImageAnalysis
226 This class allows you to analyse image files in different ways. At
227 least the MIME type of the file is returned. In some cases (JPEG, TIFF
228 and GIF) additional information is gathered as well.
229
230 %package ImageConversion
231 Summary:        ImageConversion
232 Group:          Development/Languages/PHP
233 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageConversion.html
234 Requires:       %{name} = %{version}-%{release}
235
236 %description ImageConversion
237 A set of classes to apply different filters on images, such as colour
238 changes, resizing and special effects.
239
240 %package Mail
241 Summary:        Mail
242 Group:          Development/Languages/PHP
243 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Mail.html
244 Requires:       %{name} = %{version}-%{release}
245
246 %description Mail
247 The component allows you construct and/or parse Mail messages
248 conforming to the mail standard. It has support for attachments,
249 multipart messages and HTML mail. It also interfaces with SMTP to send
250 mail or IMAP, POP3 or mbox to retrieve e-mail.
251
252 %package MvcMailTiein
253 Summary:        MvcMailTiein
254 Group:          Development/Languages/PHP
255 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcMailTiein.html
256 Requires:       %{name} = %{version}-%{release}
257
258 %description MvcMailTiein
259 This component provides a request parser that extracts request data
260 from e-mail messages.
261
262 %package MvcTemplateTiein
263 Summary:        MvcTemplateTiein
264 Group:          Development/Languages/PHP
265 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTemplateTiein.html
266 Requires:       %{name} = %{version}-%{release}
267
268 %description MvcTemplateTiein
269 This component provides a view handler that renders result data with
270 the Template component.
271
272 %package MvcTools
273 Summary:        MvcTools
274 Group:          Development/Languages/PHP
275 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTools.html
276 Requires:       %{name} = %{version}-%{release}
277
278 %description MvcTools
279 The MvcTools component provides functionality for request parsing,
280 routing, dispatching, views and response writing. With the tools in
281 this component you can very easily build an MVC framework.
282
283 %package PersistentObject
284 Summary:        PersistentObject
285 Group:          Development/Languages/PHP
286 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObject.html
287 Requires:       %{name} = %{version}-%{release}
288
289 %description PersistentObject
290 This component allows you to store an arbitrary data structures to a
291 fixed database table. The component provides all the functionality
292 needed to fetch, list, delete etc these datastructures.
293
294 %package PersistentObjectDatabaseSchemaTiein
295 Summary:        PersistentObjectDatabaseSchemaTiein
296 Group:          Development/Languages/PHP
297 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObjectDatabaseSchemaTiein.html
298 Requires:       %{name} = %{version}-%{release}
299
300 %description PersistentObjectDatabaseSchemaTiein
301 This component allows the automatic generation of PersistentObject
302 definition files from DatabaseSchema definitions.
303
304 %package PhpGenerator
305 Summary:        PhpGenerator
306 Group:          Development/Languages/PHP
307 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PhpGenerator.html
308 Requires:       %{name} = %{version}-%{release}
309
310 %description PhpGenerator
311 Provides a simple interface for creating PHP files and executing PHP
312 code.
313
314 %package Search
315 Summary:        Search
316 Group:          Development/Languages/PHP
317 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Search.html
318 Requires:       %{name} = %{version}-%{release}
319
320 %description Search
321 The Search component provides an interface to index and query
322 documents with different search engine backends.
323
324 %package SignalSlot
325 Summary:        SignalSlot
326 Group:          Development/Languages/PHP
327 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SignalSlot.html
328 Requires:       %{name} = %{version}-%{release}
329
330 %description SignalSlot
331 The SignalSlot component implements a mechanism for inter and intra
332 object communication through the use of signals and slots.
333
334 %package SystemInformation
335 Summary:        SystemInformation
336 Group:          Development/Languages/PHP
337 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SystemInformation.html
338 Requires:       %{name} = %{version}-%{release}
339
340 %description SystemInformation
341 Provides access to common system variables, such as CPU type and
342 speed, and the available amount of memory.
343
344 %package Template
345 Summary:        Template
346 Group:          Development/Languages/PHP
347 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Template.html
348 Requires:       %{name} = %{version}-%{release}
349
350 %description Template
351 A fully functional Templating system, supporting template compilation
352 in different levels, user defined functions and operators, an
353 optimizer, output escaping for different output handlers to prevent
354 XSS and other security problems and a plug in system for extra
355 functionality (such as a Translation system).
356
357 %package TemplateTranslationTiein
358 Summary:        TemplateTranslationTiein
359 Group:          Development/Languages/PHP
360 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TemplateTranslationTiein.html
361 Requires:       %{name} = %{version}-%{release}
362
363 %description TemplateTranslationTiein
364 Provides functionality to use translations inside templates.
365
366 %package Translation
367 Summary:        Translation
368 Group:          Development/Languages/PHP
369 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Translation.html
370 Requires:       %{name} = %{version}-%{release}
371
372 %description Translation
373 A component that reads XML translation definitions (the Qt Linguist
374 format), supports caching of translation contexts and presents you
375 with a class to apply translations to strings. A filter system allows
376 you to transform translation definitions for special use.
377
378 %package TranslationCacheTiein
379 Summary:        TranslationCacheTiein
380 Group:          Development/Languages/PHP
381 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TranslationCacheTiein.html
382 Requires:       %{name} = %{version}-%{release}
383
384 %description TranslationCacheTiein
385 This component adds the TranslationCache backend to the Translation
386 component and allows cached translations.
387
388 %package Tree
389 Summary:        Tree
390 Group:          Development/Languages/PHP
391 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Tree.html
392 Requires:       %{name} = %{version}-%{release}
393
394 %description Tree
395 The Tree component handles the creating, manipulating and querying of
396 tree structures. The component supports different storage algorithms
397 for optimal performance.
398
399 %package TreeDatabaseTiein
400 Summary:        TreeDatabaseTiein
401 Group:          Development/Languages/PHP
402 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreeDatabaseTiein.html
403 Requires:       %{name} = %{version}-%{release}
404
405 %description TreeDatabaseTiein
406 The Tree component handles the creating, manipulating and querying of
407 tree structures. This component implements the database related
408 backends and data stores.
409
410 %package TreePersistentObjectTiein
411 Summary:        TreePersistentObjectTiein
412 Group:          Development/Languages/PHP
413 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreePersistentObjectTiein.html
414 Requires:       %{name} = %{version}-%{release}
415
416 %description TreePersistentObjectTiein
417 The Tree component handles the creating, manipulating and querying of
418 tree structures. This component uses persistent objects as data
419 storage for the data elements of the tree nodes.
420
421 %package Url
422 Summary:        Url
423 Group:          Development/Languages/PHP
424 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Url.html
425 Requires:       %{name} = %{version}-%{release}
426
427 %description Url
428 The Url package provides basic operations to handle urls (parse,
429 build, get/set path, get/set query).
430
431 %package UserInput
432 Summary:        UserInput
433 Group:          Development/Languages/PHP
434 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_UserInput.html
435 Requires:       %{name} = %{version}-%{release}
436
437 %description UserInput
438 A component that assists you to safely user input variables coming
439 into your application. It builds on top of PHP's filter extension and
440 extends it by providing a more inituitive API.
441
442 %package Webdav
443 Summary:        Webdav
444 Group:          Development/Languages/PHP
445 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Webdav.html
446 Requires:       %{name} = %{version}-%{release}
447
448 %description Webdav
449 This component allows you to set up and run your own WebDAV (RFC 2518)
450 server, to enable online content editing for the users of your system
451 through the WebDAV HTTP extension.
452
453 %package Workflow
454 Summary:        Workflow
455 Group:          Development/Languages/PHP
456 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Workflow.html
457 Requires:       %{name} = %{version}-%{release}
458
459 %description Workflow
460 The purpose of the Workflow component is to provide the core
461 functionality of an activity-based workflow system including the
462 definition and execution of workflow specifications.
463
464 %package WorkflowDatabaseTiein
465 Summary:        WorkflowDatabaseTiein
466 Group:          Development/Languages/PHP
467 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowDatabaseTiein.html
468 Requires:       %{name} = %{version}-%{release}
469
470 %description WorkflowDatabaseTiein
471 Contains the database backend for the Workflow component.
472
473 %package WorkflowEventLogTiein
474 Summary:        WorkflowEventLogTiein
475 Group:          Development/Languages/PHP
476 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowEventLogTiein.html
477 Requires:       %{name} = %{version}-%{release}
478
479 %description WorkflowEventLogTiein
480 Contains the EventLog listener for the Workflow component.
481
482 %package WorkflowSignalSlotTiein
483 Summary:        WorkflowSignalSlotTiein
484 Group:          Development/Languages/PHP
485 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowSignalSlotTiein.html
486 Requires:       %{name} = %{version}-%{release}
487
488 %description WorkflowSignalSlotTiein
489 Contains the SignalSlot links for the Workflow component.
490
491 %prep
492 %setup -q
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT%{_appdir}
497
498 cp -a autoload $RPM_BUILD_ROOT%{_appdir}
499
500 for a in [A-Z]*/; do
501         a=${a%/}
502         cp -a $a/src $RPM_BUILD_ROOT%{_appdir}/$a
503
504         # produce spec template
505         cat > $a-desc.spec <<-EOF
506                 %%package $a
507                 Summary:        $a
508                 Group:          Development/Languages/PHP
509                 URL:            http://www.ezcomponents.org/docs/api/%%{version}/classtrees_$a.html
510                 Requires:       %%{name} = %%{version}-%%{release}
511
512                 %%description $a
513                 $(cat $a/DESCRIPTION)
514
515         EOF
516
517         cat > $a-files.spec <<-EOF
518                 %%files $a
519                 %%defattr(644,root,root,755)
520                 %%doc $a/{ChangeLog,CREDITS}$(
521                 if [ "$(ls $a/*.txt 2>/dev/null)" ]; then
522                         echo ""
523                         echo "%%doc $a/*.txt"
524                 fi
525                 )
526                 %%{_appdir}/$a
527
528         EOF
529 done
530 cat *-desc.spec *-files.spec > ez.spec
531 rm -f *-desc.spec *-files.spec
532
533 %clean
534 rm -rf $RPM_BUILD_ROOT
535
536 %files
537 %defattr(644,root,root,755)
538 %dir %{_appdir}
539 %{_appdir}/autoload
540
541 %files Archive
542 %defattr(644,root,root,755)
543 %doc Archive/{ChangeLog,CREDITS}
544 %{_appdir}/Archive
545
546 %files Authentication
547 %defattr(644,root,root,755)
548 %doc Authentication/{ChangeLog,CREDITS}
549 %doc Authentication/*.txt
550 %{_appdir}/Authentication
551
552 %files AuthenticationDatabaseTiein
553 %defattr(644,root,root,755)
554 %doc AuthenticationDatabaseTiein/{ChangeLog,CREDITS}
555 %{_appdir}/AuthenticationDatabaseTiein
556
557 %files Base
558 %defattr(644,root,root,755)
559 %doc Base/{ChangeLog,CREDITS}
560 %doc Base/*.txt
561 %{_appdir}/Base
562
563 %files Cache
564 %defattr(644,root,root,755)
565 %doc Cache/{ChangeLog,CREDITS}
566 %doc Cache/*.txt
567 %{_appdir}/Cache
568
569 %files Configuration
570 %defattr(644,root,root,755)
571 %doc Configuration/{ChangeLog,CREDITS}
572 %{_appdir}/Configuration
573
574 %files ConsoleTools
575 %defattr(644,root,root,755)
576 %doc ConsoleTools/{ChangeLog,CREDITS}
577 %doc ConsoleTools/*.txt
578 %{_appdir}/ConsoleTools
579
580 %files Database
581 %defattr(644,root,root,755)
582 %doc Database/{ChangeLog,CREDITS}
583 %{_appdir}/Database
584
585 %files DatabaseSchema
586 %defattr(644,root,root,755)
587 %doc DatabaseSchema/{ChangeLog,CREDITS}
588 %doc DatabaseSchema/*.txt
589 %{_appdir}/DatabaseSchema
590
591 %files Debug
592 %defattr(644,root,root,755)
593 %doc Debug/{ChangeLog,CREDITS}
594 %doc Debug/*.txt
595 %{_appdir}/Debug
596
597 %files Document
598 %defattr(644,root,root,755)
599 %doc Document/{ChangeLog,CREDITS}
600 %doc Document/*.txt
601 %{_appdir}/Document
602
603 %files EventLog
604 %defattr(644,root,root,755)
605 %doc EventLog/{ChangeLog,CREDITS}
606 %{_appdir}/EventLog
607
608 %files EventLogDatabaseTiein
609 %defattr(644,root,root,755)
610 %doc EventLogDatabaseTiein/{ChangeLog,CREDITS}
611 %{_appdir}/EventLogDatabaseTiein
612
613 %files Execution
614 %defattr(644,root,root,755)
615 %doc Execution/{ChangeLog,CREDITS}
616 %{_appdir}/Execution
617
618 %files Feed
619 %defattr(644,root,root,755)
620 %doc Feed/{ChangeLog,CREDITS}
621 %doc Feed/*.txt
622 %{_appdir}/Feed
623
624 %files File
625 %defattr(644,root,root,755)
626 %doc File/{ChangeLog,CREDITS}
627 %{_appdir}/File
628
629 %files Graph
630 %defattr(644,root,root,755)
631 %doc Graph/{ChangeLog,CREDITS}
632 %{_appdir}/Graph
633
634 %files GraphDatabaseTiein
635 %defattr(644,root,root,755)
636 %doc GraphDatabaseTiein/{ChangeLog,CREDITS}
637 %{_appdir}/GraphDatabaseTiein
638
639 %files ImageAnalysis
640 %defattr(644,root,root,755)
641 %doc ImageAnalysis/{ChangeLog,CREDITS}
642 %{_appdir}/ImageAnalysis
643
644 %files ImageConversion
645 %defattr(644,root,root,755)
646 %doc ImageConversion/{ChangeLog,CREDITS}
647 %doc ImageConversion/*.txt
648 %{_appdir}/ImageConversion
649
650 %files Mail
651 %defattr(644,root,root,755)
652 %doc Mail/{ChangeLog,CREDITS}
653 %doc Mail/*.txt
654 %{_appdir}/Mail
655
656 %files MvcMailTiein
657 %defattr(644,root,root,755)
658 %doc MvcMailTiein/{ChangeLog,CREDITS}
659 %{_appdir}/MvcMailTiein
660
661 %files MvcTemplateTiein
662 %defattr(644,root,root,755)
663 %doc MvcTemplateTiein/{ChangeLog,CREDITS}
664 %{_appdir}/MvcTemplateTiein
665
666 %files MvcTools
667 %defattr(644,root,root,755)
668 %doc MvcTools/{ChangeLog,CREDITS}
669 %doc MvcTools/*.txt
670 %{_appdir}/MvcTools
671
672 %files PersistentObject
673 %defattr(644,root,root,755)
674 %doc PersistentObject/{ChangeLog,CREDITS}
675 %doc PersistentObject/*.txt
676 %{_appdir}/PersistentObject
677
678 %files PersistentObjectDatabaseSchemaTiein
679 %defattr(644,root,root,755)
680 %doc PersistentObjectDatabaseSchemaTiein/{ChangeLog,CREDITS}
681 %{_appdir}/PersistentObjectDatabaseSchemaTiein
682
683 %files PhpGenerator
684 %defattr(644,root,root,755)
685 %doc PhpGenerator/{ChangeLog,CREDITS}
686 %{_appdir}/PhpGenerator
687
688 %files Search
689 %defattr(644,root,root,755)
690 %doc Search/{ChangeLog,CREDITS}
691 %doc Search/*.txt
692 %{_appdir}/Search
693
694 %files SignalSlot
695 %defattr(644,root,root,755)
696 %doc SignalSlot/{ChangeLog,CREDITS}
697 %{_appdir}/SignalSlot
698
699 %files SystemInformation
700 %defattr(644,root,root,755)
701 %doc SystemInformation/{ChangeLog,CREDITS}
702 %{_appdir}/SystemInformation
703
704 %files Template
705 %defattr(644,root,root,755)
706 %doc Template/{ChangeLog,CREDITS}
707 %doc Template/*.txt
708 %{_appdir}/Template
709
710 %files TemplateTranslationTiein
711 %defattr(644,root,root,755)
712 %doc TemplateTranslationTiein/{ChangeLog,CREDITS}
713 %{_appdir}/TemplateTranslationTiein
714
715 %files Translation
716 %defattr(644,root,root,755)
717 %doc Translation/{ChangeLog,CREDITS}
718 %doc Translation/*.txt
719 %{_appdir}/Translation
720
721 %files TranslationCacheTiein
722 %defattr(644,root,root,755)
723 %doc TranslationCacheTiein/{ChangeLog,CREDITS}
724 %{_appdir}/TranslationCacheTiein
725
726 %files Tree
727 %defattr(644,root,root,755)
728 %doc Tree/{ChangeLog,CREDITS}
729 %{_appdir}/Tree
730
731 %files TreeDatabaseTiein
732 %defattr(644,root,root,755)
733 %doc TreeDatabaseTiein/{ChangeLog,CREDITS}
734 %{_appdir}/TreeDatabaseTiein
735
736 %files TreePersistentObjectTiein
737 %defattr(644,root,root,755)
738 %doc TreePersistentObjectTiein/{ChangeLog,CREDITS}
739 %{_appdir}/TreePersistentObjectTiein
740
741 %files Url
742 %defattr(644,root,root,755)
743 %doc Url/{ChangeLog,CREDITS}
744 %doc Url/*.txt
745 %{_appdir}/Url
746
747 %files UserInput
748 %defattr(644,root,root,755)
749 %doc UserInput/{ChangeLog,CREDITS}
750 %{_appdir}/UserInput
751
752 %files Webdav
753 %defattr(644,root,root,755)
754 %doc Webdav/{ChangeLog,CREDITS}
755 %doc Webdav/*.txt
756 %{_appdir}/Webdav
757
758 %files Workflow
759 %defattr(644,root,root,755)
760 %doc Workflow/{ChangeLog,CREDITS}
761 %doc Workflow/*.txt
762 %{_appdir}/Workflow
763
764 %files WorkflowDatabaseTiein
765 %defattr(644,root,root,755)
766 %doc WorkflowDatabaseTiein/{ChangeLog,CREDITS}
767 %{_appdir}/WorkflowDatabaseTiein
768
769 %files WorkflowEventLogTiein
770 %defattr(644,root,root,755)
771 %doc WorkflowEventLogTiein/{ChangeLog,CREDITS}
772 %{_appdir}/WorkflowEventLogTiein
773
774 %files WorkflowSignalSlotTiein
775 %defattr(644,root,root,755)
776 %doc WorkflowSignalSlotTiein/{ChangeLog,CREDITS}
777 %{_appdir}/WorkflowSignalSlotTiein
This page took 0.109365 seconds and 2 git commands to generate.