]> git.pld-linux.org Git - packages/ezcomponents.git/blob - ezcomponents.spec
- new, not tested at all
[packages/ezcomponents.git] / ezcomponents.spec
1 %include        /usr/lib/rpm/macros.php
2 Summary:        eZ Components
3 Name:           ezcomponents
4 Version:        2008.2
5 Release:        0.1
6 License:        New BSD License
7 Group:          Development/Languages/PHP
8 Source0:        http://ezcomponents.org/files/downloads/%{name}-%{version}.tar.bz2
9 # Source0-md5:  57b211e2e85670633ebb165e14742f95
10 URL:            http://www.ezcomponents.org/
11 BuildRequires:  php-common >= 4:5.1
12 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
13 BuildRequires:  rpmbuild(macros) >= 1.461
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _appdir %{php_data_dir}/%{name}
18
19 %description
20 eZ Components is an enterprise ready general purpose PHP components
21 library used independently or together for PHP application
22 development. With eZ Components, developers do not have to reinvent
23 the wheel, instead they can concentrate on solving customer-specific
24 needs.
25
26 %package Archive
27 Summary:        Archive
28 Group:          Development/Languages/PHP
29 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Archive.html
30 Requires:       %{name} = %{version}-%{release}
31
32 %description Archive
33 The component allows you to create, modify, and extract archive files
34 of various formats. The currently supported archives formats are Tar
35 (with the flavours: ustar, v7, pax, and gnu) and Zip.
36
37 %package Authentication
38 Summary:        Authentication
39 Group:          Development/Languages/PHP
40 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Authentication.html
41 Requires:       %{name} = %{version}-%{release}
42
43 %description Authentication
44 The purpose of the Authentication component is to provide support for
45 different means of identification and authentication of users using
46 different providers and protocols.
47
48 %package AuthenticationDatabaseTiein
49 Summary:        AuthenticationDatabaseTiein
50 Group:          Development/Languages/PHP
51 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_AuthenticationDatabaseTiein.html
52 Requires:       %{name} = %{version}-%{release}
53
54 %description AuthenticationDatabaseTiein
55 The purpose of the Authentication component is to provide support for
56 different means of identification and authentication of users using
57 different providers and protocols.
58
59 %package Base
60 Summary:        Base
61 Group:          Development/Languages/PHP
62 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Base.html
63 Requires:       %{name} = %{version}-%{release}
64
65 %description Base
66 The Base package provides the basic infrastructure that all packages
67 rely on. Therefore every component relies on this package.
68
69 %package Cache
70 Summary:        Cache
71 Group:          Development/Languages/PHP
72 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Cache.html
73 Requires:       %{name} = %{version}-%{release}
74
75 %description Cache
76 A solution for caching, supporting multiple backends allowing you to
77 specify the best performing solution for your caching-problem.
78
79 %package Configuration
80 Summary:        Configuration
81 Group:          Development/Languages/PHP
82 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Configuration.html
83 Requires:       %{name} = %{version}-%{release}
84
85 %description Configuration
86 A component that allows you to use configuration files in different
87 formats. The formats include the standard .ini file, and an array
88 based format.
89
90 %package ConsoleTools
91 Summary:        ConsoleTools
92 Group:          Development/Languages/PHP
93 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_ConsoleTools.html
94 Requires:       %{name} = %{version}-%{release}
95
96 %description ConsoleTools
97 A set of classes to do different actions with the console (also called
98 shell). It can render a progress bar, tables and a status bar and
99 contains a class for parsing command line options.
100
101 %package Database
102 Summary:        Database
103 Group:          Development/Languages/PHP
104 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Database.html
105 Requires:       %{name} = %{version}-%{release}
106
107 %description Database
108 A lightweight database layer on top of PHP's PDO that allows you to
109 utilize a database without having to take care of differences in SQL
110 dialects.
111
112 %package DatabaseSchema
113 Summary:        DatabaseSchema
114 Group:          Development/Languages/PHP
115 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_DatabaseSchema.html
116 Requires:       %{name} = %{version}-%{release}
117
118 %description DatabaseSchema
119 A set of classes that allow you to extract information from a database
120 schema, compare database schemas and apply a set of changes to a
121 database schema.
122
123 %package Debug
124 Summary:        Debug
125 Group:          Development/Languages/PHP
126 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Debug.html
127 Requires:       %{name} = %{version}-%{release}
128
129 %description Debug
130 This component provides a set of classes that help you to debug an
131 application. It provides timers and report generators for different
132 formats that give a summary of warnings and errors that occurred
133 within your application.
134
135 %package Document
136 Summary:        Document
137 Group:          Development/Languages/PHP
138 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Document.html
139 Requires:       %{name} = %{version}-%{release}
140
141 %description Document
142 The Document components provides a general conversion framework for
143 different semantic document markup languages like XHTML, Docbook, RST
144 and similar.
145
146 %package EventLog
147 Summary:        EventLog
148 Group:          Development/Languages/PHP
149 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_EventLog.html
150 Requires:       %{name} = %{version}-%{release}
151
152 %description EventLog
153 Allows you to log events or audit trails into files or other storage
154 spaces in different formats.
155
156 %package EventLogDatabaseTiein
157 Summary:        EventLogDatabaseTiein
158 Group:          Development/Languages/PHP
159 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_EventLogDatabaseTiein.html
160 Requires:       %{name} = %{version}-%{release}
161
162 %description EventLogDatabaseTiein
163 Contains the database writer backend for the EventLog component.
164
165 %package Execution
166 Summary:        Execution
167 Group:          Development/Languages/PHP
168 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Execution.html
169 Requires:       %{name} = %{version}-%{release}
170
171 %description Execution
172 Provides functionality to give feedback to your application's users
173 when a fatal error happened or an uncaught exception was thrown.
174
175 %package Feed
176 Summary:        Feed
177 Group:          Development/Languages/PHP
178 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Feed.html
179 Requires:       %{name} = %{version}-%{release}
180
181 %description Feed
182 This component handles parsing and creating RSS1, RSS2 and ATOM feeds,
183 with support for different feed modules (dc, content, creativeCommons,
184 geo, iTunes).
185
186 %package File
187 Summary:        File
188 Group:          Development/Languages/PHP
189 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_File.html
190 Requires:       %{name} = %{version}-%{release}
191
192 %description File
193 Provides support for file operations which are not covered by PHP or
194 are just missing.
195
196 %package Graph
197 Summary:        Graph
198 Group:          Development/Languages/PHP
199 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Graph.html
200 Requires:       %{name} = %{version}-%{release}
201
202 %description Graph
203 A component for creating pie charts, line graphs and other kinds of
204 diagrams.
205
206 %package GraphDatabaseTiein
207 Summary:        GraphDatabaseTiein
208 Group:          Development/Languages/PHP
209 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_GraphDatabaseTiein.html
210 Requires:       %{name} = %{version}-%{release}
211
212 %description GraphDatabaseTiein
213 The GraphDatabaseTiein provides functionality to directly use PDO
214 statements as basis for ezcGraph Datasets.
215
216 %package ImageAnalysis
217 Summary:        ImageAnalysis
218 Group:          Development/Languages/PHP
219 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_ImageAnalysis.html
220 Requires:       %{name} = %{version}-%{release}
221
222 %description ImageAnalysis
223 This class allows you to analyse image files in different ways. At
224 least the MIME type of the file is returned. In some cases (JPEG, TIFF
225 and GIF) additional information is gathered as well.
226
227 %package ImageConversion
228 Summary:        ImageConversion
229 Group:          Development/Languages/PHP
230 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_ImageConversion.html
231 Requires:       %{name} = %{version}-%{release}
232
233 %description ImageConversion
234 A set of classes to apply different filters on images, such as colour
235 changes, resizing and special effects.
236
237 %package Mail
238 Summary:        Mail
239 Group:          Development/Languages/PHP
240 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Mail.html
241 Requires:       %{name} = %{version}-%{release}
242
243 %description Mail
244 The component allows you construct and/or parse Mail messages
245 conforming to the mail standard. It has support for attachments,
246 multipart messages and HTML mail. It also interfaces with SMTP to send
247 mail or IMAP, POP3 or mbox to retrieve e-mail.
248
249 %package MvcMailTiein
250 Summary:        MvcMailTiein
251 Group:          Development/Languages/PHP
252 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_MvcMailTiein.html
253 Requires:       %{name} = %{version}-%{release}
254
255 %description MvcMailTiein
256 This component provides a request parser that extracts request data
257 from e-mail messages.
258
259 %package MvcTemplateTiein
260 Summary:        MvcTemplateTiein
261 Group:          Development/Languages/PHP
262 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_MvcTemplateTiein.html
263 Requires:       %{name} = %{version}-%{release}
264
265 %description MvcTemplateTiein
266 This component provides a view handler that renders result data with
267 the Template component.
268
269 %package MvcTools
270 Summary:        MvcTools
271 Group:          Development/Languages/PHP
272 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_MvcTools.html
273 Requires:       %{name} = %{version}-%{release}
274
275 %description MvcTools
276 The MvcTools component provides functionality for request parsing,
277 routing, dispatching, views and response writing. With the tools in
278 this component you can very easily build an MVC framework.
279
280 %package PersistentObject
281 Summary:        PersistentObject
282 Group:          Development/Languages/PHP
283 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_PersistentObject.html
284 Requires:       %{name} = %{version}-%{release}
285
286 %description PersistentObject
287 This component allows you to store an arbitrary data structures to a
288 fixed database table. The component provides all the functionality
289 needed to fetch, list, delete etc these datastructures.
290
291 %package PersistentObjectDatabaseSchemaTiein
292 Summary:        PersistentObjectDatabaseSchemaTiein
293 Group:          Development/Languages/PHP
294 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_PersistentObjectDatabaseSchemaTiein.html
295 Requires:       %{name} = %{version}-%{release}
296
297 %description PersistentObjectDatabaseSchemaTiein
298 This component allows the automatic generation of PersistentObject
299 definition files from DatabaseSchema definitions.
300
301 %package PhpGenerator
302 Summary:        PhpGenerator
303 Group:          Development/Languages/PHP
304 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_PhpGenerator.html
305 Requires:       %{name} = %{version}-%{release}
306
307 %description PhpGenerator
308 Provides a simple interface for creating PHP files and executing PHP
309 code.
310
311 %package Search
312 Summary:        Search
313 Group:          Development/Languages/PHP
314 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Search.html
315 Requires:       %{name} = %{version}-%{release}
316
317 %description Search
318 The Search component provides an interface to index and query
319 documents with different search engine backends.
320
321 %package SignalSlot
322 Summary:        SignalSlot
323 Group:          Development/Languages/PHP
324 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_SignalSlot.html
325 Requires:       %{name} = %{version}-%{release}
326
327 %description SignalSlot
328 The SignalSlot component implements a mechanism for inter and intra
329 object communication through the use of signals and slots.
330
331 %package SystemInformation
332 Summary:        SystemInformation
333 Group:          Development/Languages/PHP
334 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_SystemInformation.html
335 Requires:       %{name} = %{version}-%{release}
336
337 %description SystemInformation
338 Provides access to common system variables, such as CPU type and
339 speed, and the available amount of memory.
340
341 %package Template
342 Summary:        Template
343 Group:          Development/Languages/PHP
344 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Template.html
345 Requires:       %{name} = %{version}-%{release}
346
347 %description Template
348 A fully functional Templating system, supporting template compilation
349 in different levels, user defined functions and operators, an
350 optimizer, output escaping for different output handlers to prevent
351 XSS and other security problems and a plug in system for extra
352 functionality (such as a Translation system).
353
354 %package TemplateTranslationTiein
355 Summary:        TemplateTranslationTiein
356 Group:          Development/Languages/PHP
357 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_TemplateTranslationTiein.html
358 Requires:       %{name} = %{version}-%{release}
359
360 %description TemplateTranslationTiein
361 Provides functionality to use translations inside templates.
362
363 %package Translation
364 Summary:        Translation
365 Group:          Development/Languages/PHP
366 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Translation.html
367 Requires:       %{name} = %{version}-%{release}
368
369 %description Translation
370 A component that reads XML translation definitions (the Qt Linguist
371 format), supports caching of translation contexts and presents you
372 with a class to apply translations to strings. A filter system allows
373 you to transform translation definitions for special use.
374
375 %package TranslationCacheTiein
376 Summary:        TranslationCacheTiein
377 Group:          Development/Languages/PHP
378 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_TranslationCacheTiein.html
379 Requires:       %{name} = %{version}-%{release}
380
381 %description TranslationCacheTiein
382 This component adds the TranslationCache backend to the Translation
383 component and allows cached translations.
384
385 %package Tree
386 Summary:        Tree
387 Group:          Development/Languages/PHP
388 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Tree.html
389 Requires:       %{name} = %{version}-%{release}
390
391 %description Tree
392 The Tree component handles the creating, manipulating and querying of
393 tree structures. The component supports different storage algorithms
394 for optimal performance.
395
396 %package TreeDatabaseTiein
397 Summary:        TreeDatabaseTiein
398 Group:          Development/Languages/PHP
399 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_TreeDatabaseTiein.html
400 Requires:       %{name} = %{version}-%{release}
401
402 %description TreeDatabaseTiein
403 The Tree component handles the creating, manipulating and querying of
404 tree structures. This component implements the database related
405 backends and data stores.
406
407 %package TreePersistentObjectTiein
408 Summary:        TreePersistentObjectTiein
409 Group:          Development/Languages/PHP
410 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_TreePersistentObjectTiein.html
411 Requires:       %{name} = %{version}-%{release}
412
413 %description TreePersistentObjectTiein
414 The Tree component handles the creating, manipulating and querying of
415 tree structures. This component uses persistent objects as data
416 storage for the data elements of the tree nodes.
417
418 %package Url
419 Summary:        Url
420 Group:          Development/Languages/PHP
421 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Url.html
422 Requires:       %{name} = %{version}-%{release}
423
424 %description Url
425 The Url package provides basic operations to handle urls (parse,
426 build, get/set path, get/set query).
427
428 %package UserInput
429 Summary:        UserInput
430 Group:          Development/Languages/PHP
431 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_UserInput.html
432 Requires:       %{name} = %{version}-%{release}
433
434 %description UserInput
435 A component that assists you to safely user input variables coming
436 into your application. It builds on top of PHP's filter extension and
437 extends it by providing a more inituitive API.
438
439 %package Webdav
440 Summary:        Webdav
441 Group:          Development/Languages/PHP
442 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Webdav.html
443 Requires:       %{name} = %{version}-%{release}
444
445 %description Webdav
446 This component allows you to set up and run your own WebDAV (RFC 2518)
447 server, to enable online content editing for the users of your system
448 through the WebDAV HTTP extension.
449
450 %package Workflow
451 Summary:        Workflow
452 Group:          Development/Languages/PHP
453 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_Workflow.html
454 Requires:       %{name} = %{version}-%{release}
455
456 %description Workflow
457 The purpose of the Workflow component is to provide the core
458 functionality of an activity-based workflow system including the
459 definition and execution of workflow specifications.
460
461 %package WorkflowDatabaseTiein
462 Summary:        WorkflowDatabaseTiein
463 Group:          Development/Languages/PHP
464 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_WorkflowDatabaseTiein.html
465 Requires:       %{name} = %{version}-%{release}
466
467 %description WorkflowDatabaseTiein
468 Contains the database backend for the Workflow component.
469
470 %package WorkflowEventLogTiein
471 Summary:        WorkflowEventLogTiein
472 Group:          Development/Languages/PHP
473 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_WorkflowEventLogTiein.html
474 Requires:       %{name} = %{version}-%{release}
475
476 %description WorkflowEventLogTiein
477 Contains the EventLog listener for the Workflow component.
478
479 %package WorkflowSignalSlotTiein
480 Summary:        WorkflowSignalSlotTiein
481 Group:          Development/Languages/PHP
482 URL:            http://www.ezcomponents.org/docs/api/2008.2/classtrees_WorkflowSignalSlotTiein.html
483 Requires:       %{name} = %{version}-%{release}
484
485 %description WorkflowSignalSlotTiein
486 Contains the SignalSlot links for the Workflow component.
487
488 %prep
489 %setup -q
490
491 %install
492 rm -rf $RPM_BUILD_ROOT
493 install -d $RPM_BUILD_ROOT%{_appdir}
494
495 cp -a autoload $RPM_BUILD_ROOT%{_appdir}
496
497 for a in [A-Z]*/; do
498         a=${a%/}
499         cp -a $a/src $RPM_BUILD_ROOT%{_appdir}/$a
500
501         # produce spec template
502         cat > $a-desc.spec <<-EOF
503                 %%package $a
504                 Summary:        $a
505                 Group:          Development/Languages/PHP
506                 URL:            http://www.ezcomponents.org/docs/api/%%{version}/classtrees_$a.html
507                 Requires:       %%{name} = %%{version}-%%{release}
508
509                 %%description $a
510                 $(cat $a/DESCRIPTION)
511
512         EOF
513
514         cat > $a-files.spec <<-EOF
515                 %%files $a
516                 %%defattr(644,root,root,755)
517                 %%doc $a/{ChangeLog,CREDITS}$(
518                 if [ "$(ls $a/*.txt 2>/dev/null)" ]; then
519                         echo ""
520                         echo "%%doc $a/*.txt"
521                 fi
522                 )
523                 %%{_appdir}/$a
524
525         EOF
526 done
527 cat *-desc.spec *-files.spec > ez.spec
528 rm -f *-desc.spec *-files.spec
529
530 %clean
531 rm -rf $RPM_BUILD_ROOT
532
533 %files
534 %defattr(644,root,root,755)
535 %dir %{_appdir}
536 %{_appdir}/autoload
537
538 %files Archive
539 %defattr(644,root,root,755)
540 %doc Archive/{ChangeLog,CREDITS}
541 %{_appdir}/Archive
542
543 %files Authentication
544 %defattr(644,root,root,755)
545 %doc Authentication/{ChangeLog,CREDITS}
546 %doc Authentication/*.txt
547 %{_appdir}/Authentication
548
549 %files AuthenticationDatabaseTiein
550 %defattr(644,root,root,755)
551 %doc AuthenticationDatabaseTiein/{ChangeLog,CREDITS}
552 %{_appdir}/AuthenticationDatabaseTiein
553
554 %files Base
555 %defattr(644,root,root,755)
556 %doc Base/{ChangeLog,CREDITS}
557 %doc Base/*.txt
558 %{_appdir}/Base
559
560 %files Cache
561 %defattr(644,root,root,755)
562 %doc Cache/{ChangeLog,CREDITS}
563 %doc Cache/*.txt
564 %{_appdir}/Cache
565
566 %files Configuration
567 %defattr(644,root,root,755)
568 %doc Configuration/{ChangeLog,CREDITS}
569 %{_appdir}/Configuration
570
571 %files ConsoleTools
572 %defattr(644,root,root,755)
573 %doc ConsoleTools/{ChangeLog,CREDITS}
574 %doc ConsoleTools/*.txt
575 %{_appdir}/ConsoleTools
576
577 %files Database
578 %defattr(644,root,root,755)
579 %doc Database/{ChangeLog,CREDITS}
580 %{_appdir}/Database
581
582 %files DatabaseSchema
583 %defattr(644,root,root,755)
584 %doc DatabaseSchema/{ChangeLog,CREDITS}
585 %doc DatabaseSchema/*.txt
586 %{_appdir}/DatabaseSchema
587
588 %files Debug
589 %defattr(644,root,root,755)
590 %doc Debug/{ChangeLog,CREDITS}
591 %doc Debug/*.txt
592 %{_appdir}/Debug
593
594 %files Document
595 %defattr(644,root,root,755)
596 %doc Document/{ChangeLog,CREDITS}
597 %doc Document/*.txt
598 %{_appdir}/Document
599
600 %files EventLog
601 %defattr(644,root,root,755)
602 %doc EventLog/{ChangeLog,CREDITS}
603 %{_appdir}/EventLog
604
605 %files EventLogDatabaseTiein
606 %defattr(644,root,root,755)
607 %doc EventLogDatabaseTiein/{ChangeLog,CREDITS}
608 %{_appdir}/EventLogDatabaseTiein
609
610 %files Execution
611 %defattr(644,root,root,755)
612 %doc Execution/{ChangeLog,CREDITS}
613 %{_appdir}/Execution
614
615 %files Feed
616 %defattr(644,root,root,755)
617 %doc Feed/{ChangeLog,CREDITS}
618 %doc Feed/*.txt
619 %{_appdir}/Feed
620
621 %files File
622 %defattr(644,root,root,755)
623 %doc File/{ChangeLog,CREDITS}
624 %{_appdir}/File
625
626 %files Graph
627 %defattr(644,root,root,755)
628 %doc Graph/{ChangeLog,CREDITS}
629 %{_appdir}/Graph
630
631 %files GraphDatabaseTiein
632 %defattr(644,root,root,755)
633 %doc GraphDatabaseTiein/{ChangeLog,CREDITS}
634 %{_appdir}/GraphDatabaseTiein
635
636 %files ImageAnalysis
637 %defattr(644,root,root,755)
638 %doc ImageAnalysis/{ChangeLog,CREDITS}
639 %{_appdir}/ImageAnalysis
640
641 %files ImageConversion
642 %defattr(644,root,root,755)
643 %doc ImageConversion/{ChangeLog,CREDITS}
644 %doc ImageConversion/*.txt
645 %{_appdir}/ImageConversion
646
647 %files Mail
648 %defattr(644,root,root,755)
649 %doc Mail/{ChangeLog,CREDITS}
650 %doc Mail/*.txt
651 %{_appdir}/Mail
652
653 %files MvcMailTiein
654 %defattr(644,root,root,755)
655 %doc MvcMailTiein/{ChangeLog,CREDITS}
656 %{_appdir}/MvcMailTiein
657
658 %files MvcTemplateTiein
659 %defattr(644,root,root,755)
660 %doc MvcTemplateTiein/{ChangeLog,CREDITS}
661 %{_appdir}/MvcTemplateTiein
662
663 %files MvcTools
664 %defattr(644,root,root,755)
665 %doc MvcTools/{ChangeLog,CREDITS}
666 %doc MvcTools/*.txt
667 %{_appdir}/MvcTools
668
669 %files PersistentObject
670 %defattr(644,root,root,755)
671 %doc PersistentObject/{ChangeLog,CREDITS}
672 %doc PersistentObject/*.txt
673 %{_appdir}/PersistentObject
674
675 %files PersistentObjectDatabaseSchemaTiein
676 %defattr(644,root,root,755)
677 %doc PersistentObjectDatabaseSchemaTiein/{ChangeLog,CREDITS}
678 %{_appdir}/PersistentObjectDatabaseSchemaTiein
679
680 %files PhpGenerator
681 %defattr(644,root,root,755)
682 %doc PhpGenerator/{ChangeLog,CREDITS}
683 %{_appdir}/PhpGenerator
684
685 %files Search
686 %defattr(644,root,root,755)
687 %doc Search/{ChangeLog,CREDITS}
688 %doc Search/*.txt
689 %{_appdir}/Search
690
691 %files SignalSlot
692 %defattr(644,root,root,755)
693 %doc SignalSlot/{ChangeLog,CREDITS}
694 %{_appdir}/SignalSlot
695
696 %files SystemInformation
697 %defattr(644,root,root,755)
698 %doc SystemInformation/{ChangeLog,CREDITS}
699 %{_appdir}/SystemInformation
700
701 %files Template
702 %defattr(644,root,root,755)
703 %doc Template/{ChangeLog,CREDITS}
704 %doc Template/*.txt
705 %{_appdir}/Template
706
707 %files TemplateTranslationTiein
708 %defattr(644,root,root,755)
709 %doc TemplateTranslationTiein/{ChangeLog,CREDITS}
710 %{_appdir}/TemplateTranslationTiein
711
712 %files Translation
713 %defattr(644,root,root,755)
714 %doc Translation/{ChangeLog,CREDITS}
715 %doc Translation/*.txt
716 %{_appdir}/Translation
717
718 %files TranslationCacheTiein
719 %defattr(644,root,root,755)
720 %doc TranslationCacheTiein/{ChangeLog,CREDITS}
721 %{_appdir}/TranslationCacheTiein
722
723 %files Tree
724 %defattr(644,root,root,755)
725 %doc Tree/{ChangeLog,CREDITS}
726 %{_appdir}/Tree
727
728 %files TreeDatabaseTiein
729 %defattr(644,root,root,755)
730 %doc TreeDatabaseTiein/{ChangeLog,CREDITS}
731 %{_appdir}/TreeDatabaseTiein
732
733 %files TreePersistentObjectTiein
734 %defattr(644,root,root,755)
735 %doc TreePersistentObjectTiein/{ChangeLog,CREDITS}
736 %{_appdir}/TreePersistentObjectTiein
737
738 %files Url
739 %defattr(644,root,root,755)
740 %doc Url/{ChangeLog,CREDITS}
741 %doc Url/*.txt
742 %{_appdir}/Url
743
744 %files UserInput
745 %defattr(644,root,root,755)
746 %doc UserInput/{ChangeLog,CREDITS}
747 %{_appdir}/UserInput
748
749 %files Webdav
750 %defattr(644,root,root,755)
751 %doc Webdav/{ChangeLog,CREDITS}
752 %doc Webdav/*.txt
753 %{_appdir}/Webdav
754
755 %files Workflow
756 %defattr(644,root,root,755)
757 %doc Workflow/{ChangeLog,CREDITS}
758 %doc Workflow/*.txt
759 %{_appdir}/Workflow
760
761 %files WorkflowDatabaseTiein
762 %defattr(644,root,root,755)
763 %doc WorkflowDatabaseTiein/{ChangeLog,CREDITS}
764 %{_appdir}/WorkflowDatabaseTiein
765
766 %files WorkflowEventLogTiein
767 %defattr(644,root,root,755)
768 %doc WorkflowEventLogTiein/{ChangeLog,CREDITS}
769 %{_appdir}/WorkflowEventLogTiein
770
771 %files WorkflowSignalSlotTiein
772 %defattr(644,root,root,755)
773 %doc WorkflowSignalSlotTiein/{ChangeLog,CREDITS}
774 %{_appdir}/WorkflowSignalSlotTiein
This page took 0.207689 seconds and 3 git commands to generate.