]> git.pld-linux.org Git - packages/ezcomponents.git/blame - ezcomponents.spec
- update version
[packages/ezcomponents.git] / ezcomponents.spec
CommitLineData
e2f34710
ER
1%include /usr/lib/rpm/macros.php
2Summary: eZ Components
3Name: ezcomponents
4Version: 2008.2
5Release: 0.1
6License: New BSD License
7Group: Development/Languages/PHP
8Source0: http://ezcomponents.org/files/downloads/%{name}-%{version}.tar.bz2
9# Source0-md5: 57b211e2e85670633ebb165e14742f95
10URL: http://www.ezcomponents.org/
9ffad5ec 11BuildRequires: php-common >= 4:5.2.1
e2f34710
ER
12BuildRequires: rpm-php-pearprov >= 4.4.2-11
13BuildRequires: rpmbuild(macros) >= 1.461
14BuildArch: noarch
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define _appdir %{php_data_dir}/%{name}
18
6af5966a
ER
19# fool adapter: allow version macro in url
20%define docver %{version}
21
e2f34710
ER
22%description
23eZ Components is an enterprise ready general purpose PHP components
24library used independently or together for PHP application
25development. With eZ Components, developers do not have to reinvent
26the wheel, instead they can concentrate on solving customer-specific
27needs.
28
29%package Archive
30Summary: Archive
31Group: Development/Languages/PHP
6af5966a 32URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Archive.html
e2f34710
ER
33Requires: %{name} = %{version}-%{release}
34
35%description Archive
36The component allows you to create, modify, and extract archive files
37of various formats. The currently supported archives formats are Tar
38(with the flavours: ustar, v7, pax, and gnu) and Zip.
39
40%package Authentication
41Summary: Authentication
42Group: Development/Languages/PHP
6af5966a 43URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Authentication.html
e2f34710
ER
44Requires: %{name} = %{version}-%{release}
45
46%description Authentication
47The purpose of the Authentication component is to provide support for
48different means of identification and authentication of users using
49different providers and protocols.
50
51%package AuthenticationDatabaseTiein
52Summary: AuthenticationDatabaseTiein
53Group: Development/Languages/PHP
6af5966a 54URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_AuthenticationDatabaseTiein.html
e2f34710
ER
55Requires: %{name} = %{version}-%{release}
56
57%description AuthenticationDatabaseTiein
58The purpose of the Authentication component is to provide support for
59different means of identification and authentication of users using
60different providers and protocols.
61
62%package Base
63Summary: Base
64Group: Development/Languages/PHP
6af5966a 65URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Base.html
e2f34710
ER
66Requires: %{name} = %{version}-%{release}
67
68%description Base
69The Base package provides the basic infrastructure that all packages
70rely on. Therefore every component relies on this package.
71
72%package Cache
73Summary: Cache
74Group: Development/Languages/PHP
6af5966a 75URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Cache.html
e2f34710
ER
76Requires: %{name} = %{version}-%{release}
77
78%description Cache
79A solution for caching, supporting multiple backends allowing you to
80specify the best performing solution for your caching-problem.
81
82%package Configuration
83Summary: Configuration
84Group: Development/Languages/PHP
6af5966a 85URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Configuration.html
e2f34710
ER
86Requires: %{name} = %{version}-%{release}
87
88%description Configuration
89A component that allows you to use configuration files in different
90formats. The formats include the standard .ini file, and an array
91based format.
92
93%package ConsoleTools
94Summary: ConsoleTools
95Group: Development/Languages/PHP
6af5966a 96URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ConsoleTools.html
e2f34710
ER
97Requires: %{name} = %{version}-%{release}
98
99%description ConsoleTools
100A set of classes to do different actions with the console (also called
101shell). It can render a progress bar, tables and a status bar and
102contains a class for parsing command line options.
103
104%package Database
105Summary: Database
106Group: Development/Languages/PHP
6af5966a 107URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Database.html
e2f34710
ER
108Requires: %{name} = %{version}-%{release}
109
110%description Database
111A lightweight database layer on top of PHP's PDO that allows you to
112utilize a database without having to take care of differences in SQL
113dialects.
114
115%package DatabaseSchema
116Summary: DatabaseSchema
117Group: Development/Languages/PHP
6af5966a 118URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_DatabaseSchema.html
e2f34710
ER
119Requires: %{name} = %{version}-%{release}
120
121%description DatabaseSchema
122A set of classes that allow you to extract information from a database
123schema, compare database schemas and apply a set of changes to a
124database schema.
125
126%package Debug
127Summary: Debug
128Group: Development/Languages/PHP
6af5966a 129URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Debug.html
e2f34710
ER
130Requires: %{name} = %{version}-%{release}
131
132%description Debug
133This component provides a set of classes that help you to debug an
134application. It provides timers and report generators for different
135formats that give a summary of warnings and errors that occurred
136within your application.
137
138%package Document
139Summary: Document
140Group: Development/Languages/PHP
6af5966a 141URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Document.html
e2f34710
ER
142Requires: %{name} = %{version}-%{release}
143
144%description Document
145The Document components provides a general conversion framework for
146different semantic document markup languages like XHTML, Docbook, RST
147and similar.
148
149%package EventLog
150Summary: EventLog
151Group: Development/Languages/PHP
6af5966a 152URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLog.html
e2f34710
ER
153Requires: %{name} = %{version}-%{release}
154
155%description EventLog
156Allows you to log events or audit trails into files or other storage
157spaces in different formats.
158
159%package EventLogDatabaseTiein
160Summary: EventLogDatabaseTiein
161Group: Development/Languages/PHP
6af5966a 162URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLogDatabaseTiein.html
e2f34710
ER
163Requires: %{name} = %{version}-%{release}
164
165%description EventLogDatabaseTiein
166Contains the database writer backend for the EventLog component.
167
168%package Execution
169Summary: Execution
170Group: Development/Languages/PHP
6af5966a 171URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Execution.html
e2f34710
ER
172Requires: %{name} = %{version}-%{release}
173
174%description Execution
175Provides functionality to give feedback to your application's users
176when a fatal error happened or an uncaught exception was thrown.
177
178%package Feed
179Summary: Feed
180Group: Development/Languages/PHP
6af5966a 181URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Feed.html
e2f34710
ER
182Requires: %{name} = %{version}-%{release}
183
184%description Feed
185This component handles parsing and creating RSS1, RSS2 and ATOM feeds,
186with support for different feed modules (dc, content, creativeCommons,
187geo, iTunes).
188
189%package File
190Summary: File
191Group: Development/Languages/PHP
6af5966a 192URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_File.html
e2f34710
ER
193Requires: %{name} = %{version}-%{release}
194
195%description File
196Provides support for file operations which are not covered by PHP or
197are just missing.
198
199%package Graph
200Summary: Graph
201Group: Development/Languages/PHP
6af5966a 202URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Graph.html
e2f34710
ER
203Requires: %{name} = %{version}-%{release}
204
205%description Graph
206A component for creating pie charts, line graphs and other kinds of
207diagrams.
208
209%package GraphDatabaseTiein
210Summary: GraphDatabaseTiein
211Group: Development/Languages/PHP
6af5966a 212URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_GraphDatabaseTiein.html
e2f34710
ER
213Requires: %{name} = %{version}-%{release}
214
215%description GraphDatabaseTiein
216The GraphDatabaseTiein provides functionality to directly use PDO
217statements as basis for ezcGraph Datasets.
218
219%package ImageAnalysis
220Summary: ImageAnalysis
221Group: Development/Languages/PHP
6af5966a 222URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageAnalysis.html
e2f34710
ER
223Requires: %{name} = %{version}-%{release}
224
225%description ImageAnalysis
226This class allows you to analyse image files in different ways. At
227least the MIME type of the file is returned. In some cases (JPEG, TIFF
228and GIF) additional information is gathered as well.
229
230%package ImageConversion
231Summary: ImageConversion
232Group: Development/Languages/PHP
6af5966a 233URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageConversion.html
e2f34710
ER
234Requires: %{name} = %{version}-%{release}
235
236%description ImageConversion
237A set of classes to apply different filters on images, such as colour
238changes, resizing and special effects.
239
240%package Mail
241Summary: Mail
242Group: Development/Languages/PHP
6af5966a 243URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Mail.html
e2f34710
ER
244Requires: %{name} = %{version}-%{release}
245
246%description Mail
247The component allows you construct and/or parse Mail messages
248conforming to the mail standard. It has support for attachments,
249multipart messages and HTML mail. It also interfaces with SMTP to send
250mail or IMAP, POP3 or mbox to retrieve e-mail.
251
252%package MvcMailTiein
253Summary: MvcMailTiein
254Group: Development/Languages/PHP
6af5966a 255URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcMailTiein.html
e2f34710
ER
256Requires: %{name} = %{version}-%{release}
257
258%description MvcMailTiein
259This component provides a request parser that extracts request data
260from e-mail messages.
261
262%package MvcTemplateTiein
263Summary: MvcTemplateTiein
264Group: Development/Languages/PHP
6af5966a 265URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTemplateTiein.html
e2f34710
ER
266Requires: %{name} = %{version}-%{release}
267
268%description MvcTemplateTiein
269This component provides a view handler that renders result data with
270the Template component.
271
272%package MvcTools
273Summary: MvcTools
274Group: Development/Languages/PHP
6af5966a 275URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTools.html
e2f34710
ER
276Requires: %{name} = %{version}-%{release}
277
278%description MvcTools
279The MvcTools component provides functionality for request parsing,
280routing, dispatching, views and response writing. With the tools in
281this component you can very easily build an MVC framework.
282
283%package PersistentObject
284Summary: PersistentObject
285Group: Development/Languages/PHP
6af5966a 286URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObject.html
e2f34710
ER
287Requires: %{name} = %{version}-%{release}
288
289%description PersistentObject
290This component allows you to store an arbitrary data structures to a
291fixed database table. The component provides all the functionality
292needed to fetch, list, delete etc these datastructures.
293
294%package PersistentObjectDatabaseSchemaTiein
295Summary: PersistentObjectDatabaseSchemaTiein
296Group: Development/Languages/PHP
6af5966a 297URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObjectDatabaseSchemaTiein.html
e2f34710
ER
298Requires: %{name} = %{version}-%{release}
299
300%description PersistentObjectDatabaseSchemaTiein
301This component allows the automatic generation of PersistentObject
302definition files from DatabaseSchema definitions.
303
304%package PhpGenerator
305Summary: PhpGenerator
306Group: Development/Languages/PHP
6af5966a 307URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PhpGenerator.html
e2f34710
ER
308Requires: %{name} = %{version}-%{release}
309
310%description PhpGenerator
311Provides a simple interface for creating PHP files and executing PHP
312code.
313
314%package Search
315Summary: Search
316Group: Development/Languages/PHP
6af5966a 317URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Search.html
e2f34710
ER
318Requires: %{name} = %{version}-%{release}
319
320%description Search
321The Search component provides an interface to index and query
322documents with different search engine backends.
323
324%package SignalSlot
325Summary: SignalSlot
326Group: Development/Languages/PHP
6af5966a 327URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SignalSlot.html
e2f34710
ER
328Requires: %{name} = %{version}-%{release}
329
330%description SignalSlot
331The SignalSlot component implements a mechanism for inter and intra
332object communication through the use of signals and slots.
333
334%package SystemInformation
335Summary: SystemInformation
336Group: Development/Languages/PHP
6af5966a 337URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SystemInformation.html
e2f34710
ER
338Requires: %{name} = %{version}-%{release}
339
340%description SystemInformation
341Provides access to common system variables, such as CPU type and
342speed, and the available amount of memory.
343
344%package Template
345Summary: Template
346Group: Development/Languages/PHP
6af5966a 347URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Template.html
e2f34710
ER
348Requires: %{name} = %{version}-%{release}
349
350%description Template
351A fully functional Templating system, supporting template compilation
352in different levels, user defined functions and operators, an
353optimizer, output escaping for different output handlers to prevent
354XSS and other security problems and a plug in system for extra
355functionality (such as a Translation system).
356
357%package TemplateTranslationTiein
358Summary: TemplateTranslationTiein
359Group: Development/Languages/PHP
6af5966a 360URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TemplateTranslationTiein.html
e2f34710
ER
361Requires: %{name} = %{version}-%{release}
362
363%description TemplateTranslationTiein
364Provides functionality to use translations inside templates.
365
366%package Translation
367Summary: Translation
368Group: Development/Languages/PHP
6af5966a 369URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Translation.html
e2f34710
ER
370Requires: %{name} = %{version}-%{release}
371
372%description Translation
373A component that reads XML translation definitions (the Qt Linguist
374format), supports caching of translation contexts and presents you
375with a class to apply translations to strings. A filter system allows
376you to transform translation definitions for special use.
377
378%package TranslationCacheTiein
379Summary: TranslationCacheTiein
380Group: Development/Languages/PHP
6af5966a 381URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TranslationCacheTiein.html
e2f34710
ER
382Requires: %{name} = %{version}-%{release}
383
384%description TranslationCacheTiein
385This component adds the TranslationCache backend to the Translation
386component and allows cached translations.
387
388%package Tree
389Summary: Tree
390Group: Development/Languages/PHP
6af5966a 391URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Tree.html
e2f34710
ER
392Requires: %{name} = %{version}-%{release}
393
394%description Tree
395The Tree component handles the creating, manipulating and querying of
396tree structures. The component supports different storage algorithms
397for optimal performance.
398
399%package TreeDatabaseTiein
400Summary: TreeDatabaseTiein
401Group: Development/Languages/PHP
6af5966a 402URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreeDatabaseTiein.html
e2f34710
ER
403Requires: %{name} = %{version}-%{release}
404
405%description TreeDatabaseTiein
406The Tree component handles the creating, manipulating and querying of
407tree structures. This component implements the database related
408backends and data stores.
409
410%package TreePersistentObjectTiein
411Summary: TreePersistentObjectTiein
412Group: Development/Languages/PHP
6af5966a 413URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreePersistentObjectTiein.html
e2f34710
ER
414Requires: %{name} = %{version}-%{release}
415
416%description TreePersistentObjectTiein
417The Tree component handles the creating, manipulating and querying of
418tree structures. This component uses persistent objects as data
419storage for the data elements of the tree nodes.
420
421%package Url
422Summary: Url
423Group: Development/Languages/PHP
6af5966a 424URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Url.html
e2f34710
ER
425Requires: %{name} = %{version}-%{release}
426
427%description Url
428The Url package provides basic operations to handle urls (parse,
429build, get/set path, get/set query).
430
431%package UserInput
432Summary: UserInput
433Group: Development/Languages/PHP
6af5966a 434URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_UserInput.html
e2f34710
ER
435Requires: %{name} = %{version}-%{release}
436
437%description UserInput
438A component that assists you to safely user input variables coming
439into your application. It builds on top of PHP's filter extension and
440extends it by providing a more inituitive API.
441
442%package Webdav
443Summary: Webdav
444Group: Development/Languages/PHP
6af5966a 445URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Webdav.html
e2f34710
ER
446Requires: %{name} = %{version}-%{release}
447
448%description Webdav
449This component allows you to set up and run your own WebDAV (RFC 2518)
450server, to enable online content editing for the users of your system
451through the WebDAV HTTP extension.
452
453%package Workflow
454Summary: Workflow
455Group: Development/Languages/PHP
6af5966a 456URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Workflow.html
e2f34710
ER
457Requires: %{name} = %{version}-%{release}
458
459%description Workflow
460The purpose of the Workflow component is to provide the core
461functionality of an activity-based workflow system including the
462definition and execution of workflow specifications.
463
464%package WorkflowDatabaseTiein
465Summary: WorkflowDatabaseTiein
466Group: Development/Languages/PHP
6af5966a 467URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowDatabaseTiein.html
e2f34710
ER
468Requires: %{name} = %{version}-%{release}
469
470%description WorkflowDatabaseTiein
471Contains the database backend for the Workflow component.
472
473%package WorkflowEventLogTiein
474Summary: WorkflowEventLogTiein
475Group: Development/Languages/PHP
6af5966a 476URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowEventLogTiein.html
e2f34710
ER
477Requires: %{name} = %{version}-%{release}
478
479%description WorkflowEventLogTiein
480Contains the EventLog listener for the Workflow component.
481
482%package WorkflowSignalSlotTiein
483Summary: WorkflowSignalSlotTiein
484Group: Development/Languages/PHP
6af5966a 485URL: http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowSignalSlotTiein.html
e2f34710
ER
486Requires: %{name} = %{version}-%{release}
487
488%description WorkflowSignalSlotTiein
489Contains the SignalSlot links for the Workflow component.
490
491%prep
492%setup -q
493
494%install
495rm -rf $RPM_BUILD_ROOT
496install -d $RPM_BUILD_ROOT%{_appdir}
497
498cp -a autoload $RPM_BUILD_ROOT%{_appdir}
499
500for a in [A-Z]*/; do
501 a=${a%/}
502 cp -a $a/src $RPM_BUILD_ROOT%{_appdir}/$a
503
504 # produce spec template
505 cat > $a-desc.spec <<-EOF
506 %%package $a
507 Summary: $a
508 Group: Development/Languages/PHP
509 URL: http://www.ezcomponents.org/docs/api/%%{version}/classtrees_$a.html
510 Requires: %%{name} = %%{version}-%%{release}
511
512 %%description $a
513 $(cat $a/DESCRIPTION)
514
515 EOF
516
517 cat > $a-files.spec <<-EOF
518 %%files $a
519 %%defattr(644,root,root,755)
520 %%doc $a/{ChangeLog,CREDITS}$(
521 if [ "$(ls $a/*.txt 2>/dev/null)" ]; then
522 echo ""
523 echo "%%doc $a/*.txt"
524 fi
525 )
526 %%{_appdir}/$a
527
528 EOF
529done
530cat *-desc.spec *-files.spec > ez.spec
531rm -f *-desc.spec *-files.spec
532
533%clean
534rm -rf $RPM_BUILD_ROOT
535
536%files
537%defattr(644,root,root,755)
538%dir %{_appdir}
539%{_appdir}/autoload
540
541%files Archive
542%defattr(644,root,root,755)
543%doc Archive/{ChangeLog,CREDITS}
544%{_appdir}/Archive
545
546%files Authentication
547%defattr(644,root,root,755)
548%doc Authentication/{ChangeLog,CREDITS}
549%doc Authentication/*.txt
550%{_appdir}/Authentication
551
552%files AuthenticationDatabaseTiein
553%defattr(644,root,root,755)
554%doc AuthenticationDatabaseTiein/{ChangeLog,CREDITS}
555%{_appdir}/AuthenticationDatabaseTiein
556
557%files Base
558%defattr(644,root,root,755)
559%doc Base/{ChangeLog,CREDITS}
560%doc Base/*.txt
561%{_appdir}/Base
562
563%files Cache
564%defattr(644,root,root,755)
565%doc Cache/{ChangeLog,CREDITS}
566%doc Cache/*.txt
567%{_appdir}/Cache
568
569%files Configuration
570%defattr(644,root,root,755)
571%doc Configuration/{ChangeLog,CREDITS}
572%{_appdir}/Configuration
573
574%files ConsoleTools
575%defattr(644,root,root,755)
576%doc ConsoleTools/{ChangeLog,CREDITS}
577%doc ConsoleTools/*.txt
578%{_appdir}/ConsoleTools
579
580%files Database
581%defattr(644,root,root,755)
582%doc Database/{ChangeLog,CREDITS}
583%{_appdir}/Database
584
585%files DatabaseSchema
586%defattr(644,root,root,755)
587%doc DatabaseSchema/{ChangeLog,CREDITS}
588%doc DatabaseSchema/*.txt
589%{_appdir}/DatabaseSchema
590
591%files Debug
592%defattr(644,root,root,755)
593%doc Debug/{ChangeLog,CREDITS}
594%doc Debug/*.txt
595%{_appdir}/Debug
596
597%files Document
598%defattr(644,root,root,755)
599%doc Document/{ChangeLog,CREDITS}
600%doc Document/*.txt
601%{_appdir}/Document
602
603%files EventLog
604%defattr(644,root,root,755)
605%doc EventLog/{ChangeLog,CREDITS}
606%{_appdir}/EventLog
607
608%files EventLogDatabaseTiein
609%defattr(644,root,root,755)
610%doc EventLogDatabaseTiein/{ChangeLog,CREDITS}
611%{_appdir}/EventLogDatabaseTiein
612
613%files Execution
614%defattr(644,root,root,755)
615%doc Execution/{ChangeLog,CREDITS}
616%{_appdir}/Execution
617
618%files Feed
619%defattr(644,root,root,755)
620%doc Feed/{ChangeLog,CREDITS}
621%doc Feed/*.txt
622%{_appdir}/Feed
623
624%files File
625%defattr(644,root,root,755)
626%doc File/{ChangeLog,CREDITS}
627%{_appdir}/File
628
629%files Graph
630%defattr(644,root,root,755)
631%doc Graph/{ChangeLog,CREDITS}
632%{_appdir}/Graph
633
634%files GraphDatabaseTiein
635%defattr(644,root,root,755)
636%doc GraphDatabaseTiein/{ChangeLog,CREDITS}
637%{_appdir}/GraphDatabaseTiein
638
639%files ImageAnalysis
640%defattr(644,root,root,755)
641%doc ImageAnalysis/{ChangeLog,CREDITS}
642%{_appdir}/ImageAnalysis
643
644%files ImageConversion
645%defattr(644,root,root,755)
646%doc ImageConversion/{ChangeLog,CREDITS}
647%doc ImageConversion/*.txt
648%{_appdir}/ImageConversion
649
650%files Mail
651%defattr(644,root,root,755)
652%doc Mail/{ChangeLog,CREDITS}
653%doc Mail/*.txt
654%{_appdir}/Mail
655
656%files MvcMailTiein
657%defattr(644,root,root,755)
658%doc MvcMailTiein/{ChangeLog,CREDITS}
659%{_appdir}/MvcMailTiein
660
661%files MvcTemplateTiein
662%defattr(644,root,root,755)
663%doc MvcTemplateTiein/{ChangeLog,CREDITS}
664%{_appdir}/MvcTemplateTiein
665
666%files MvcTools
667%defattr(644,root,root,755)
668%doc MvcTools/{ChangeLog,CREDITS}
669%doc MvcTools/*.txt
670%{_appdir}/MvcTools
671
672%files PersistentObject
673%defattr(644,root,root,755)
674%doc PersistentObject/{ChangeLog,CREDITS}
675%doc PersistentObject/*.txt
676%{_appdir}/PersistentObject
677
678%files PersistentObjectDatabaseSchemaTiein
679%defattr(644,root,root,755)
680%doc PersistentObjectDatabaseSchemaTiein/{ChangeLog,CREDITS}
681%{_appdir}/PersistentObjectDatabaseSchemaTiein
682
683%files PhpGenerator
684%defattr(644,root,root,755)
685%doc PhpGenerator/{ChangeLog,CREDITS}
686%{_appdir}/PhpGenerator
687
688%files Search
689%defattr(644,root,root,755)
690%doc Search/{ChangeLog,CREDITS}
691%doc Search/*.txt
692%{_appdir}/Search
693
694%files SignalSlot
695%defattr(644,root,root,755)
696%doc SignalSlot/{ChangeLog,CREDITS}
697%{_appdir}/SignalSlot
698
699%files SystemInformation
700%defattr(644,root,root,755)
701%doc SystemInformation/{ChangeLog,CREDITS}
702%{_appdir}/SystemInformation
703
704%files Template
705%defattr(644,root,root,755)
706%doc Template/{ChangeLog,CREDITS}
707%doc Template/*.txt
708%{_appdir}/Template
709
710%files TemplateTranslationTiein
711%defattr(644,root,root,755)
712%doc TemplateTranslationTiein/{ChangeLog,CREDITS}
713%{_appdir}/TemplateTranslationTiein
714
715%files Translation
716%defattr(644,root,root,755)
717%doc Translation/{ChangeLog,CREDITS}
718%doc Translation/*.txt
719%{_appdir}/Translation
720
721%files TranslationCacheTiein
722%defattr(644,root,root,755)
723%doc TranslationCacheTiein/{ChangeLog,CREDITS}
724%{_appdir}/TranslationCacheTiein
725
726%files Tree
727%defattr(644,root,root,755)
728%doc Tree/{ChangeLog,CREDITS}
729%{_appdir}/Tree
730
731%files TreeDatabaseTiein
732%defattr(644,root,root,755)
733%doc TreeDatabaseTiein/{ChangeLog,CREDITS}
734%{_appdir}/TreeDatabaseTiein
735
736%files TreePersistentObjectTiein
737%defattr(644,root,root,755)
738%doc TreePersistentObjectTiein/{ChangeLog,CREDITS}
739%{_appdir}/TreePersistentObjectTiein
740
741%files Url
742%defattr(644,root,root,755)
743%doc Url/{ChangeLog,CREDITS}
744%doc Url/*.txt
745%{_appdir}/Url
746
747%files UserInput
748%defattr(644,root,root,755)
749%doc UserInput/{ChangeLog,CREDITS}
750%{_appdir}/UserInput
751
752%files Webdav
753%defattr(644,root,root,755)
754%doc Webdav/{ChangeLog,CREDITS}
755%doc Webdav/*.txt
756%{_appdir}/Webdav
757
758%files Workflow
759%defattr(644,root,root,755)
760%doc Workflow/{ChangeLog,CREDITS}
761%doc Workflow/*.txt
762%{_appdir}/Workflow
763
764%files WorkflowDatabaseTiein
765%defattr(644,root,root,755)
766%doc WorkflowDatabaseTiein/{ChangeLog,CREDITS}
767%{_appdir}/WorkflowDatabaseTiein
768
769%files WorkflowEventLogTiein
770%defattr(644,root,root,755)
771%doc WorkflowEventLogTiein/{ChangeLog,CREDITS}
772%{_appdir}/WorkflowEventLogTiein
773
774%files WorkflowSignalSlotTiein
775%defattr(644,root,root,755)
776%doc WorkflowSignalSlotTiein/{ChangeLog,CREDITS}
777%{_appdir}/WorkflowSignalSlotTiein
This page took 0.268267 seconds and 4 git commands to generate.