]> git.pld-linux.org Git - packages/ez-ipupdate.git/blame - ez-ipupdate.spec
- fix init script
[packages/ez-ipupdate.git] / ez-ipupdate.spec
CommitLineData
8a074274
AM
1Summary: Client for Dynamic DNS Services
2Name: ez-ipupdate
3Version: 3.0.11b8
4Release: 1
5Group: Networking
6License: GPL
7Source0: http://www.gusnet.cx/proj/ez-ipupdate/dist/%{name}-%{version}.tar.gz
8# Source0-md5: 000211add4c4845ffa4211841bff4fb0
9Source1: %{name}.init
10BuildRequires: autoconf
11BuildRequires: automake
12BuildRequires: perl
13URL: http://www.gusnet.cx/proj/ez-ipupdate/
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17ez-ipupdate is a small utility for updating your host name for any of
18the dynamic DNS service offered at:
19
20 - http://www.ez-ip.net
21 - http://www.justlinux.com
22 - http://www.dhs.org
23 - http://www.dyndns.org
24 - http://www.ods.org
25 - http://gnudip.cheapnet.net (GNUDip)
26 - http://www.dyn.ca (GNUDip)
27 - http://www.tzo.com
28 - http://www.easydns.com
29 - http://www.dyns.cx
30 - http://www.hn.org
31 - http://www.zoneedit.com
32
33it is pure C and works on Linux, *BSD and Solaris.
34
35Don't forget to create your own config file ( in /etc/ez-ipupdate.conf
36) You can find some example in /usr/share/doc/%{name}-%{version}
37
38%prep
39%setup -q
40
41%build
42install %{_datadir}/automake/config.* .
43%{__aclocal}
44%{__autoconf}
45%configure
46%{__make}
47
48%install
49rm -rf $RPM_BUILD_ROOT
d5b20598 50install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
8a074274
AM
51
52%{__make} install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
56touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
57
58perl -pi -e "s|\%{_prefix}\/local\/bin|\%{_prefix}\/bin|" *.conf
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post
64/sbin/chkconfig --add %{name}
65if [ -f /var/lock/subsys/%{name} ]; then
66 /etc/rc.d/init.d/%{name} restart >&2
67else
68 echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
69fi
70
71%preun
72if [ "$1" = "0" ]; then
73 if [ -f /var/lock/subsys/%{name} ]; then
74 /etc/rc.d/init.d/%{name} stop >&2
75 fi
76 /sbin/chkconfig --del %{name}
77fi
78
79%files
80%defattr(644,root,root,755)
81%doc README CHANGELOG
82%doc *.conf
83%attr(755,root,root) %{_bindir}/*
84%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
85%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
This page took 0.05754 seconds and 4 git commands to generate.