]> git.pld-linux.org Git - packages/expect.git/blobdiff - expect.spec
- updated to 5.41.0
[packages/expect.git] / expect.spec
index ec6a44748ada44bc59bdc55a8a9034996dc72ec8..d521dd8946e6c71ca1be0143a4db0d2be6fb4add 100644 (file)
@@ -1,32 +1,36 @@
-Summary:       tcl extension
-Summary(de):   tcl-Erweiterung
-Summary(fr):   Extension tcl
-Summary(pl):   Rozszerzenie TCL
-Summary(ru):   òÁÓÛÉÒÅÎÉÅ tcl ÄÌÑ ÕÐÒÁ×ÌÅÎÉÑ ÐÒÏÇÒÁÍÍÁÍÉ ÉÚ ÓËÒÉÐÔÏ×
-Summary(tr):   Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
-Summary(uk):   òÏÚÛÉÒÅÎÎÑ tcl ÄÌÑ ËÅÒÕ×ÁÎÎÑ ÐÒÏÇÒÁÍÁÍÉ Ú¦ ÓËÒÉÐÔ¦×
+Summary:       Tcl extension
+Summary(de):   Tcl-Erweiterung
+Summary(fr):   Extension Tcl
+Summary(pl):   Rozszerzenie Tcl
+Summary(ru):   òÁÓÛÉÒÅÎÉÅ Tcl ÄÌÑ ÕÐÒÁ×ÌÅÎÉÑ ÐÒÏÇÒÁÍÍÁÍÉ ÉÚ ÓËÒÉÐÔÏ×
+Summary(tr):   Programlar arasý etkileþimi mümkün kýlan Tcl geniþletmesi
+Summary(uk):   òÏÚÛÉÒÅÎÎÑ Tcl ÄÌÑ ËÅÒÕ×ÁÎÎÑ ÐÒÏÇÒÁÍÁÍÉ Ú¦ ÓËÒÉÐÔ¦×
 Name:          expect
-%define        major   5.39
+%define        major   5.41
 Version:       %{major}.0
 Release:       1
 License:       BSD
 Group:         Development/Languages/Tcl
 Source0:       http://expect.nist.gov/src/%{name}-%{version}.tar.gz
-# Source0-md5: 38a39787ef888f4fa009a8384d5c7c0a
+# Source0-md5: 490664773286690d111d9cd055c50700
 Patch0:                %{name}-pty.patch
 Patch1:                %{name}-alpha.patch
 Patch2:                %{name}-bug7869.patch
 Patch3:                %{name}-fixcat.patch
 Patch4:                %{name}-jbj.patch
 Patch5:                %{name}-soname.patch
+Patch6:                %{name}-lib64.patch
 Icon:          tcl.gif
 URL:           http://expect.nist.gov/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: tcl-devel >= 8.4.4
-BuildRequires: tk-devel >= 8.4.3
+BuildRequires: tcl-devel >= 8.4.6
+BuildRequires: tk-devel >= 8.4.6
+Requires:      tcl >= 8.4.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 Expect is a tool for automating interactive applications such as
 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
@@ -65,10 +69,10 @@ Expect - 
 ÐÒÏÇÒÁÍÁÍÉ ÔÁ ×ÚÁ¤ÍÏĦÑÔÉ Ú ÎÉÍÉ Ú¦ ÓËÒÉÐÔ¦×.
 
 %package X11
-Summary:       tk extension
-Summary(pl):   Rozszerzenie tk
+Summary:       Tk extension
+Summary(pl):   Rozszerzenie Tk
 Group:         Development/Languages/Tcl
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description X11
 This package contains expectk, which is an Tk extension, just as
@@ -79,29 +83,29 @@ Ten pakiet zawiera expectk, kt
 expect jest dla Tcl.
 
 %package devel
-Summary:       tcl extension header files and development documentation
-Summary(pl):   Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka TCL
+Summary:       Tcl extension header files and development documentation
+Summary(pl):   Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka Tcl
 Group:         Development/Languages/Tcl
-Requires:      %{name} = %{version}
-Requires:      tcl-devel
+Requires:      %{name} = %{version}-%{release}
+Requires:      tcl-devel >= 8.4.6
 
 %description devel
 Tcl extension language header files and develppment documentation.
 
 %description devel -l pl
-Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka TCL.
+Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka Tcl.
 
-%package       static
-Summary:       tcl extension static library
-Summary(pl):   Biblioteka statyczna rozszerzenia jêzyka TCL
+%package static
+Summary:       Tcl extension static library
+Summary(pl):   Biblioteka statyczna rozszerzenia jêzyka Tcl
 Group:         Development/Languages/Tcl
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Tcl extension language static library.
 
 %description static -l pl
-Biblioteka statyczna rozszerzenia jêzyka TCL.
+Biblioteka statyczna rozszerzenia jêzyka Tcl.
 
 %prep
 %setup -q -n %{name}-%{major}
@@ -111,23 +115,25 @@ Biblioteka statyczna rozszerzenia j
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%ifarch amd64
+%patch6 -p1
+%endif
 
 chmod +w {.,testsuite}/configure
 
 %build
 install /usr/share/automake/config.* .
-%{__aclocal}
+# only local macros, don't call aclocal
 %{__autoconf}
 cd testsuite
-# aclocal doesn't work
 cp ../aclocal.m4 .
 %{__autoconf}
 cd -
 %configure \
        --enable-gcc \
        --enable-shared \
-       --with-tclconfig=%{_libdir} \
-       --with-tkconfig=%{_libdir} \
+       --with-tclconfig=%{_ulibdir} \
+       --with-tkconfig=%{_ulibdir} \
        --with-tclinclude=%{_includedir} \
        --with-tkinclude=%{_includedir}
 
This page took 0.09847 seconds and 4 git commands to generate.