]> git.pld-linux.org Git - packages/exo.git/commitdiff
- 0.5.4, XFCE 4.8pre1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 14 Nov 2010 12:05:05 +0000 (12:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    exo.spec -> 1.41.2.1

exo.spec

index 9226a3d451dadd26159b7052424980401362d9ab..d96802791b49f5f78fe8d310a6bb5493fd106210 100644 (file)
--- a/exo.spec
+++ b/exo.spec
@@ -1,19 +1,22 @@
 #
+# TODO:
+#      - html doc needs love
+#
 # Conditional build:
 %bcond_without apidocs         # disable gtk-doc
 %bcond_without static_libs     # don't build static library
 #
-%define                xfce_version    4.6.1
+%define                xfce_version    4.8pre1
 #
 Summary:       Extension library to Xfce developed by os-cillation
 Summary(pl.UTF-8):     Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
 Name:          exo
-Version:       0.3.101
-Release:       5
+Version:       0.5.4
+Release:       0.1
 License:       GPL v2
 Group:         X11/Libraries
-Source0:       http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: 1c0eebb360f53eab70454b70e1bde36e
+Source0:       http://www.xfce.org/archive/xfce/%{xfce_version}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 18cfb12de8f11c6a6fe06d16eff0fa1c
 URL:           http://www.os-cillation.com/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -22,11 +25,11 @@ BuildRequires:      gettext-devel
 BuildRequires: gtk+2-devel >= 2:2.10.6
 %{?with_apidocs:BuildRequires: gtk-doc >= 1.7}
 BuildRequires: gtk-doc-automake
-BuildRequires: hal-devel >= 0.5.7
 BuildRequires: intltool >= 0.35.0
 BuildRequires: libnotify-devel >= 0.4.0
 BuildRequires: libtool
-BuildRequires: libxfce4util-devel >= %{xfce_version}
+#BuildRequires:        libxfce4util-devel >= %{xfce_version}
+BuildRequires: libxfce4util-devel >= 4.7.0
 BuildRequires: perl-URI
 BuildRequires: pkgconfig
 BuildRequires: python-pygtk-devel >= 2:2.10.3
@@ -78,8 +81,8 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki libexo
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gtk+2-devel >= 2:2.10.6
-Requires:      hal-devel >= 0.5.7
-Requires:      libxfce4util-devel >= %{xfce_version}
+#Requires:     libxfce4util-devel >= %{xfce_version}
+Requires:      libxfce4util-devel >= 4.7.0
 Provides:      libexo-devel
 Obsoletes:     libexo-devel
 
@@ -141,7 +144,6 @@ Pliki programistyczne wiązań Pythona do libexo.
 %{__autoconf}
 %configure \
        --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
-       --enable-hal \
        --enable-notifications \
        --enable-python \
        --with-html-dir=%{_gtkdocdir} \
@@ -155,19 +157,29 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
+rm $RPM_BUILD_ROOT%{py_sitedir}/exo-0.5/*.{a,la}
+rm $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.{a,la}
 
 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
 
 %py_postclean
 
-%find_lang libexo-0.3
+%find_lang exo-1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post
+/sbin/ldconfig
+umask 022
+%{_bindir}/gio-querymodules %{_libdir}/gio/modules
+exit 0
+
+%postun
+/sbin/ldconfig
+umask 022
+%{_bindir}/gio-querymodules %{_libdir}/gio/modules
+exit 0
 
 %post  -n xfce-preferred-applications
 %update_icon_cache hicolor
@@ -175,40 +187,41 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -n xfce-preferred-applications
 %update_icon_cache hicolor
 
-%files -f libexo-0.3.lang
+%files -f exo-1.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog HACKING NEWS README TODO
-%attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
-%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
-%{_pixmapsdir}/exo-0.3
+%attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
+%attr(755,root,root) %{_libdir}/gio/modules/libexo-module-1.so
+%{_pixmapsdir}/exo-1
 
 %files -n xfce-preferred-applications
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
-%attr(755,root,root) %{_libdir}/exo-helper-0.3
-%attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
+%dir %{_libdir}/xfce4/exo-1
+%attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
+%attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
-%{_datadir}/xfce4/doc/C/*.html
-%{_datadir}/xfce4/doc/C/images/*.png
-%lang(da) %{_datadir}/xfce4/doc/da/*.html
-%lang(es) %{_datadir}/xfce4/doc/es/*.html
-%lang(es) %{_datadir}/xfce4/doc/es/images/*.png
-%lang(fr) %{_datadir}/xfce4/doc/fr/*.html
-%lang(fr) %{_datadir}/xfce4/doc/fr/images/*.png
-%lang(gl) %{_datadir}/xfce4/doc/gl/*.html
-%lang(id) %{_datadir}/xfce4/doc/id/*.html
-%lang(id) %{_datadir}/xfce4/doc/id/images/*.png
-%lang(it) %{_datadir}/xfce4/doc/it/*.html
-%lang(it) %{_datadir}/xfce4/doc/it/images/*.png
-%lang(ja) %{_datadir}/xfce4/doc/ja/*.html
-%lang(ja) %{_datadir}/xfce4/doc/ja/images/*.png
-%lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*.html
-%lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/images/*.png
-%lang(tr) %{_datadir}/xfce4/doc/tr/*.html
-%lang(tr) %{_datadir}/xfce4/doc/tr/images/*.png
+# this needs love
+%{_datadir}/doc/exo/html/exo-preferred-applications.css
+%{_datadir}/doc/exo/html/C
+%lang(bn) %{_datadir}/doc/exo/html/bn
+%lang(ca) %{_datadir}/doc/exo/html/ca
+%lang(da) %{_datadir}/doc/exo/html/da
+%lang(de) %{_datadir}/doc/exo/html/de
+%lang(es) %{_datadir}/doc/exo/html/es
+%lang(fr) %{_datadir}/doc/exo/html/fr
+%lang(gl) %{_datadir}/doc/exo/html/gl
+%lang(id) %{_datadir}/doc/exo/html/id
+%lang(it) %{_datadir}/doc/exo/html/it
+%lang(ja) %{_datadir}/doc/exo/html/ja
+%lang(pt) %{_datadir}/doc/exo/html/pt
+%lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
+%lang(ru) %{_datadir}/doc/exo/html/ru
+%lang(tr) %{_datadir}/doc/exo/html/tr
+%lang(ug) %{_datadir}/doc/exo/html/ug
+%lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
+###################
 %dir %{_datadir}/xfce4/helpers
 %{_datadir}/xfce4/helpers/*.desktop
 %{_desktopdir}/*.desktop
@@ -220,34 +233,30 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
-%{_gtkdocdir}/exo
+%{_gtkdocdir}/exo-1
 %endif
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libexo-0.3.so
-%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
-%{_libdir}/libexo-0.3.la
-%{_libdir}/libexo-hal-0.3.la
-%{_includedir}/exo-0.3
-%{_pkgconfigdir}/exo-0.3.pc
-%{_pkgconfigdir}/exo-hal-0.3.pc
+%attr(755,root,root) %{_libdir}/libexo-1.so
+%{_libdir}/libexo-1.la
+%{_includedir}/exo-1
+%{_pkgconfigdir}/exo-1.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libexo-0.3.a
-%{_libdir}/libexo-hal-0.3.a
+%{_libdir}/libexo-1.a
 %endif
 
 %files -n python-exo
 %defattr(644,root,root,755)
-%dir %{py_sitedir}/exo-0.3
-%attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
-%dir %{py_sitedir}/exo-0.3/exo
-%{py_sitedir}/exo-0.3/exo/*.py[co]
+%dir %{py_sitedir}/exo-0.5
+%attr(755,root,root) %{py_sitedir}/exo-0.5/_exo.so
+%dir %{py_sitedir}/exo-0.5/exo
+%{py_sitedir}/exo-0.5/exo/*.py[co]
 %{py_sitescriptdir}/*.py[co]
 
 %files -n python-exo-devel
 %defattr(644,root,root,755)
-%{_datadir}/pygtk/2.0/defs/exo-0.3
+%{_datadir}/pygtk/2.0/defs/exo-0.5
This page took 0.046555 seconds and 4 git commands to generate.