]> git.pld-linux.org Git - packages/exo.git/blobdiff - exo.spec
- up to 0.12.0
[packages/exo.git] / exo.spec
index cfe50564bb13aaf062dfef88fcc4a4fd717563d1..cfb7147ffd16eb09e058e55081d6b69190ab06a0 100644 (file)
--- a/exo.spec
+++ b/exo.spec
@@ -2,25 +2,26 @@
 # Conditional build:
 %bcond_without apidocs         # disable gtk-doc
 %bcond_with    static_libs     # don't build static library
-#
-%define                xfce_version    4.10.0
-#
+
+%define                xfce_version    4.12.0
 Summary:       Extension library to Xfce developed by os-cillation
 Summary(pl.UTF-8):     Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
 Name:          exo
-Version:       0.8.0
+Version:       0.12.0
 Release:       1
 License:       GPL v2
 Group:         X11/Libraries
-Source0:       http://archive.xfce.org/xfce/4.10/src/%{name}-%{version}.tar.bz2
-# Source0-md5: 189bd19210e1d7d8601be1cdf27bf259
+Source0:       http://archive.xfce.org/src/xfce/exo/0.12/%{name}-%{version}.tar.bz2
+# Source0-md5: 724afcca224f5fb22b510926d2740e52
+Patch0:                mate-terminal.patch
 URL:           http://www.os-cillation.com/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: docbook-dtd412-xml
-BuildRequires: gettext-devel
-BuildRequires: glib2-devel >= 1:2.27.0
-BuildRequires: gtk+2-devel >= 2:2.14.0
+BuildRequires: gettext-tools
+BuildRequires: glib2-devel >= 1:2.30.0
+BuildRequires: gtk+2-devel >= 2:2.24.0
+BuildRequires: gtk+3-devel
 %{?with_apidocs:BuildRequires: gtk-doc >= 1.9}
 BuildRequires: gtk-doc-automake
 BuildRequires: intltool >= 0.35.0
@@ -29,8 +30,6 @@ BuildRequires:        libxfce4ui-devel >= %{xfce_version}
 BuildRequires: libxfce4util-devel >= %{xfce_version}
 BuildRequires: perl-URI
 BuildRequires: pkgconfig
-BuildRequires: python-pygtk-devel >= 2:2.10.3
-BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.601
 BuildRequires: xfce4-dev-tools >= 4.10.0
 Requires:      glib2 >= 1:2.27.0
@@ -66,6 +65,9 @@ Group:                Documentation
 Requires:      gtk-doc-common
 Provides:      libexo-apidocs
 Obsoletes:     libexo-apidocs
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
 libexo API documentation.
@@ -79,6 +81,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki libexo
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gtk+2-devel >= 2:2.14.0
+Requires:      gtk+3-devel
 Requires:      libxfce4util-devel >= %{xfce_version}
 Provides:      libexo-devel
 Obsoletes:     libexo-devel
@@ -103,33 +106,13 @@ Static libexo library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libexo.
 
-%package -n python-exo
-Summary:       Python binding for libexo library
-Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libexo
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python-libs
-
-%description -n python-exo
-Python binding for libexo library.
-
-%description -n python-exo -l pl.UTF-8
-Wiązania Pythona do biblioteki libexo.
-
-%package -n python-exo-devel
-Summary:       Development files for libexo Python bindings
-Summary(pl.UTF-8):     Pliki programistyczne wiązań Pythona do libexo
-Group:         Libraries/Python
-Requires:      python-exo = %{version}-%{release}
-
-%description -n python-exo-devel
-Development files for libexo Python bindings.
-
-%description -n python-exo-devel -l pl.UTF-8
-Pliki programistyczne wiązań Pythona do libexo.
-
 %prep
 %setup -q
+%patch0 -p1
+
+%{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
+
+mkdir -p m4
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
@@ -141,8 +124,6 @@ Pliki programistyczne wiązań Pythona do libexo.
 %{__autoconf}
 %configure \
        --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
-       --enable-notifications \
-       --enable-python \
        --with-html-dir=%{_gtkdocdir} \
        %{!?with_static_libs:--disable-static} \
        --disable-silent-rules
@@ -151,21 +132,16 @@ Pliki programistyczne wiązań Pythona do libexo.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/exo-*/*.{a,la}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 
-mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,tl}
 # already exists as ur
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
 
 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
 
-%py_postclean
-
 %find_lang exo-1
 
 %clean
@@ -185,43 +161,23 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS ChangeLog HACKING NEWS README TODO
 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
+%attr(755,root,root) %{_libdir}/libexo-2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libexo-2.so.0
 %{_pixmapsdir}/exo-1
 
 %files -n xfce-preferred-applications
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/exo-desktop-item-edit
+%attr(755,root,root) %{_bindir}/exo-open
+%attr(755,root,root) %{_bindir}/exo-preferred-applications
 %dir %{_libdir}/xfce4/exo-1
 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
-%dir %{_datadir}/doc/exo
-%dir %{_datadir}/doc/exo/html
-%{_datadir}/doc/exo/html/exo-preferred-applications.css
-%{_datadir}/doc/exo/html/C
-%lang(bn) %{_datadir}/doc/exo/html/bn
-%lang(ca) %{_datadir}/doc/exo/html/ca
-%lang(da) %{_datadir}/doc/exo/html/da
-%lang(de) %{_datadir}/doc/exo/html/de
-%lang(el) %{_datadir}/doc/exo/html/el
-%lang(es) %{_datadir}/doc/exo/html/es
-%lang(fr) %{_datadir}/doc/exo/html/fr
-%lang(gl) %{_datadir}/doc/exo/html/gl
-%lang(id) %{_datadir}/doc/exo/html/id
-%lang(it) %{_datadir}/doc/exo/html/it
-%lang(ja) %{_datadir}/doc/exo/html/ja
-%lang(pt) %{_datadir}/doc/exo/html/pt
-%lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
-%lang(ru) %{_datadir}/doc/exo/html/ru
-%lang(sv) %{_datadir}/doc/exo/html/sv
-%lang(tr) %{_datadir}/doc/exo/html/tr
-%lang(ug) %{_datadir}/doc/exo/html/ug
-%lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
 %dir %{_datadir}/xfce4/helpers
 %{_datadir}/xfce4/helpers/*.desktop
 %{_desktopdir}/*.desktop
 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
-%{_iconsdir}/hicolor/*/apps/applications-internet.png
-%{_iconsdir}/hicolor/*/apps/applications-other.png
 %{_mandir}/man1/*.1*
 
 %if %{with apidocs}
@@ -232,24 +188,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/exo-csource
 %attr(755,root,root) %{_libdir}/libexo-1.so
+%attr(755,root,root) %{_libdir}/libexo-2.so
 %{_includedir}/exo-1
+%{_includedir}/exo-2
 %{_pkgconfigdir}/exo-1.pc
+%{_pkgconfigdir}/exo-2.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libexo-1.a
+%{_libdir}/libexo-2.a
 %endif
-
-%files -n python-exo
-%defattr(644,root,root,755)
-%dir %{py_sitedir}/exo-0.6
-%attr(755,root,root) %{py_sitedir}/exo-0.6/_exo.so
-%dir %{py_sitedir}/exo-0.6/exo
-%{py_sitedir}/exo-0.6/exo/*.py[co]
-%{py_sitescriptdir}/*.py[co]
-
-%files -n python-exo-devel
-%defattr(644,root,root,755)
-%{_datadir}/pygtk/2.0/defs/exo-0.6
This page took 0.122891 seconds and 4 git commands to generate.