]> git.pld-linux.org Git - packages/exo.git/blobdiff - exo.spec
- spec file renamed to exo.spec
[packages/exo.git] / exo.spec
index 956cf577dc6b5603c5b6c69e7c38aa68c3536e6d..c78bc6e48dd4d44f52dfed778fb85386fd7a1268 100644 (file)
--- a/exo.spec
+++ b/exo.spec
@@ -2,36 +2,36 @@
 # Conditional build:
 %bcond_without static_libs     # don't build static library
 #
-%define                xfce_version    4.4.0
+%define                xfce_version    4.6.0
 #
 Summary:       Extension library to Xfce developed by os-cillation
-Summary(pl.UTF-8):   Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
-Name:          libexo
-Version:       0.3.2
+Summary(pl.UTF-8):     Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
+Name:          exo
+Version:       0.3.100
 Release:       1
 License:       GPL v2
-Group:         Libraries
-Source0:       http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}.tar.bz2
-# Source0-md5: 8b73acc98d0938d1193b31316823b6db
+Group:         X11/Libraries
+Source0:       http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: ebded97ff55f43cd0fe6b16242992ecf
 URL:           http://www.os-cillation.com/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: gettext-devel
 BuildRequires: gtk+2-devel >= 2:2.10.6
 BuildRequires: gtk-doc >= 1.7
-BuildRequires: hal-devel >= 0.5.0
+BuildRequires: hal-devel >= 0.5.7
 BuildRequires: intltool >= 0.35.0
-BuildRequires: libtool
 BuildRequires: libnotify-devel >= 0.4.0
+BuildRequires: libtool
 BuildRequires: libxfce4util-devel >= %{xfce_version}
 BuildRequires: perl-URI
 BuildRequires: pkgconfig
 BuildRequires: python-pygtk-devel >= 2:2.10.3
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.311
-BuildRequires: xfce-mcs-manager-devel >= %{xfce_version}
-BuildRequires: xfce4-dev-tools >= %{xfce_version}
-BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xfce4-dev-tools >= 4.6.0
+Provides:      libexo
+Obsoletes:     libexo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -42,11 +42,11 @@ Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
 
 %package -n xfce-preferred-applications
 Summary:       The Xfce Preferred Applications framework
-Summary(pl.UTF-8):   Struktura Preferowanych Aplikacji Xfce
-Group:         Applications
+Summary(pl.UTF-8):     Struktura Preferowanych Aplikacji Xfce
+Group:         X11/Applications
 Requires(post,postun): gtk+2
 Requires(post,postun): hicolor-icon-theme
-Requires:      xfce-mcs-plugins >= %{xfce_version}
+Requires:      %{name} = %{version}-%{release}
 
 %description -n xfce-preferred-applications
 The Xfce Preferred Applications framework.
@@ -56,9 +56,11 @@ Struktura Preferowanych Aplikacji Xfce.
 
 %package apidocs
 Summary:       libexo API documentation
-Summary(pl.UTF-8):   Dokumentacja API libexo
+Summary(pl.UTF-8):     Dokumentacja API libexo
 Group:         Documentation
 Requires:      gtk-doc-common
+Provides:      libexo-apidocs
+Obsoletes:     libexo-apidocs
 
 %description apidocs
 libexo API documentation.
@@ -68,10 +70,14 @@ Dokumentacja API libexo.
 
 %package devel
 Summary:       Header files for libexo library
-Summary(pl.UTF-8):   Pliki nagłówkowe biblioteki libexo
-Group:         Development/Libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libexo
+Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      gtk+2-devel >= 2:2.10.6
+Requires:      hal-devel >= 0.5.7
 Requires:      libxfce4util-devel >= %{xfce_version}
+Provides:      libexo-devel
+Obsoletes:     libexo-devel
 
 %description devel
 Header files for libexo library.
@@ -81,9 +87,11 @@ Pliki nagłówkowe biblioteki libexo.
 
 %package static
 Summary:       Static libexo library
-Summary(pl.UTF-8):   Statyczna biblioteka libexo
-Group:         Development/Libraries
+Summary(pl.UTF-8):     Statyczna biblioteka libexo
+Group:         X11/Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
+Provides:      libexo-static
+Obsoletes:     libexo-static
 
 %description static
 Static libexo library.
@@ -93,7 +101,7 @@ Statyczna biblioteka libexo.
 
 %package -n python-exo
 Summary:       Python binding for libexo library
-Summary(pl.UTF-8):   Wiązania Pythona do biblioteki libexo
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libexo
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
 %pyrequires_eq python-libs
@@ -106,7 +114,7 @@ Wiązania Pythona do biblioteki libexo.
 
 %package -n python-exo-devel
 Summary:       Development files for libexo Python bindings
-Summary(pl.UTF-8):   Pliki programistyczne wiązań Pythona do libexo
+Summary(pl.UTF-8):     Pliki programistyczne wiązań Pythona do libexo
 Group:         Libraries/Python
 Requires:      python-exo = %{version}-%{release}
 
@@ -117,7 +125,7 @@ Development files for libexo Python bindings.
 Pliki programistyczne wiązań Pythona do libexo.
 
 %prep
-%setup -q -n exo-%{version}
+%setup -q
 
 %build
 %{__intltoolize}
@@ -132,8 +140,7 @@ Pliki programistyczne wiązań Pythona do libexo.
        --enable-notifications \
        --with-html-dir=%{_gtkdocdir} \
        %{!?with_static_libs:--disable-static} \
-       --enable-python \
-       --enable-mcs-plugin
+       --enable-python
 %{__make}
 
 %install
@@ -142,12 +149,14 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/xfce4/mcs-plugins/*.{la,a}
+mv $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
+mv $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
+
 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
 
 %py_postclean
 
-%find_lang %{name}-0.3
+%find_lang libexo-0.3
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -161,11 +170,14 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -n xfce-preferred-applications
 %update_icon_cache hicolor
 
-%files -f %{name}-0.3.lang
+%files -f libexo-0.3.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog HACKING NEWS README TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%{_pixmapsdir}/exo-0.3/
+%attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
+%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
+%{_pixmapsdir}/exo-0.3
 
 %files -n xfce-preferred-applications
 %defattr(644,root,root,755)
@@ -173,11 +185,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
 %attr(755,root,root) %{_libdir}/exo-helper-0.3
 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
-%attr(755,root,root) %{_libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
-%{_datadir}/xfce4/doc/C
-%lang(fr) %{_datadir}/xfce4/doc/fr
-%lang(ja) %{_datadir}/xfce4/doc/ja
+%{_datadir}/xfce4/doc/C/*
+%lang(es) %{_datadir}/xfce4/doc/es/*
+%lang(fr) %{_datadir}/xfce4/doc/fr/*
+%lang(id) %{_datadir}/xfce4/doc/id/*
+%lang(ja) %{_datadir}/xfce4/doc/ja/*
+%lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
+%lang(tr) %{_datadir}/xfce4/doc/tr/*
 %dir %{_datadir}/xfce4/helpers
 %{_datadir}/xfce4/helpers/*.desktop
 %{_desktopdir}/*.desktop
@@ -192,15 +207,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libexo-0.3.so
+%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
+%{_libdir}/libexo-0.3.la
+%{_libdir}/libexo-hal-0.3.la
 %{_includedir}/exo-0.3
-%{_pkgconfigdir}/*.pc
+%{_pkgconfigdir}/exo-0.3.pc
+%{_pkgconfigdir}/exo-hal-0.3.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libexo-0.3.a
+%{_libdir}/libexo-hal-0.3.a
 %endif
 
 %files -n python-exo
This page took 0.044731 seconds and 4 git commands to generate.