]> git.pld-linux.org Git - packages/exo.git/blobdiff - exo.spec
- fix python module install
[packages/exo.git] / exo.spec
index 2635a2c8b606d48f8133042c3ccf8ebc95f7bf0b..8be4a00b9403a20557739e41e185ae9cb11704df 100644 (file)
--- a/exo.spec
+++ b/exo.spec
@@ -1,19 +1,19 @@
 #
 # Conditional build:
 %bcond_without apidocs         # disable gtk-doc
-%bcond_without static_libs     # don't build static library
+%bcond_with    static_libs     # don't build static library
 #
-%define                xfce_version    4.8.0
+%define                xfce_version    4.10.0
 #
 Summary:       Extension library to Xfce developed by os-cillation
 Summary(pl.UTF-8):     Biblioteka rozszerzeĹ„ do Xfce opracowana przez os-cillation
 Name:          exo
-Version:       0.6.0
-Release:       2
+Version:       0.8.0
+Release:       1
 License:       GPL v2
 Group:         X11/Libraries
-Source0:       http://archive.xfce.org/xfce/4.8/src/%{name}-%{version}.tar.bz2
-# Source0-md5: ac9deafdf9de426d8a03855ac549f424
+Source0:       http://archive.xfce.org/xfce/4.10/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 189bd19210e1d7d8601be1cdf27bf259
 URL:           http://www.os-cillation.com/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -25,13 +25,14 @@ BuildRequires:      gtk+2-devel >= 2:2.14.0
 BuildRequires: gtk-doc-automake
 BuildRequires: intltool >= 0.35.0
 BuildRequires: libtool
+BuildRequires: libxfce4ui-devel >= %{xfce_version}
 BuildRequires: libxfce4util-devel >= %{xfce_version}
 BuildRequires: perl-URI
 BuildRequires: pkgconfig
 BuildRequires: python-pygtk-devel >= 2:2.10.3
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.601
-BuildRequires: xfce4-dev-tools >= 4.8.0
+BuildRequires: xfce4-dev-tools >= 4.10.0
 Requires:      glib2 >= 1:2.27.0
 Requires:      xfce4-dirs >= 4.6
 Provides:      libexo
@@ -154,10 +155,11 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/exo-*/*.{a,la}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,ur_PK}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,tl}
+# already exists as ur
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
 
 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
 
This page took 0.254659 seconds and 4 git commands to generate.