]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- python support is gone
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5 #
6 %define         xfce_version    4.10.0
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.8.0
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://archive.xfce.org/xfce/4.10/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  189bd19210e1d7d8601be1cdf27bf259
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.27.0
23 BuildRequires:  gtk+2-devel >= 2:2.14.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.601
33 BuildRequires:  xfce4-dev-tools >= 4.10.0
34 Requires:       glib2 >= 1:2.27.0
35 Requires:       xfce4-dirs >= 4.6
36 Provides:       libexo
37 Obsoletes:      libexo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Extension library to Xfce developed by os-cillation.
42
43 %description -l pl.UTF-8
44 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
45
46 %package -n xfce-preferred-applications
47 Summary:        The Xfce Preferred Applications framework
48 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk-update-icon-cache
52 Requires:       hicolor-icon-theme
53
54 %description -n xfce-preferred-applications
55 The Xfce Preferred Applications framework.
56
57 %description -n xfce-preferred-applications -l pl.UTF-8
58 Struktura Preferowanych Aplikacji Xfce.
59
60 %package apidocs
61 Summary:        libexo API documentation
62 Summary(pl.UTF-8):      Dokumentacja API libexo
63 Group:          Documentation
64 Requires:       gtk-doc-common
65 Provides:       libexo-apidocs
66 Obsoletes:      libexo-apidocs
67
68 %description apidocs
69 libexo API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API libexo.
73
74 %package devel
75 Summary:        Header files for libexo library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
77 Group:          X11/Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       gtk+2-devel >= 2:2.14.0
80 Requires:       libxfce4util-devel >= %{xfce_version}
81 Provides:       libexo-devel
82 Obsoletes:      libexo-devel
83
84 %description devel
85 Header files for libexo library.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki libexo.
89
90 %package static
91 Summary:        Static libexo library
92 Summary(pl.UTF-8):      Statyczna biblioteka libexo
93 Group:          X11/Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Provides:       libexo-static
96 Obsoletes:      libexo-static
97
98 %description static
99 Static libexo library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka libexo.
103
104 %prep
105 %setup -q
106
107 %build
108 %{?with_apidocs:%{__gtkdocize}}
109 %{__intltoolize}
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoheader}
113 %{__automake}
114 %{__autoconf}
115 %configure \
116         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
117         --with-html-dir=%{_gtkdocdir} \
118         %{!?with_static_libs:--disable-static} \
119         --disable-silent-rules
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,tl}
132 # already exists as ur
133 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
134
135 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
136
137 %find_lang exo-1
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %post   -n xfce-preferred-applications
146 %update_icon_cache hicolor
147
148 %postun -n xfce-preferred-applications
149 %update_icon_cache hicolor
150
151 %files -f exo-1.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog HACKING NEWS README TODO
154 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
156 %{_pixmapsdir}/exo-1
157
158 %files -n xfce-preferred-applications
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/*
161 %dir %{_libdir}/xfce4/exo-1
162 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
163 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
165 #%dir %{_datadir}/doc/exo
166 #%dir %{_datadir}/doc/exo/html
167 #%{_datadir}/doc/exo/html/exo-preferred-applications.css
168 #%{_datadir}/doc/exo/html/C
169 #%lang(bn) %{_datadir}/doc/exo/html/bn
170 #%lang(ca) %{_datadir}/doc/exo/html/ca
171 #%lang(da) %{_datadir}/doc/exo/html/da
172 #%lang(de) %{_datadir}/doc/exo/html/de
173 #%lang(el) %{_datadir}/doc/exo/html/el
174 #%lang(es) %{_datadir}/doc/exo/html/es
175 #%lang(fr) %{_datadir}/doc/exo/html/fr
176 #%lang(gl) %{_datadir}/doc/exo/html/gl
177 #%lang(id) %{_datadir}/doc/exo/html/id
178 #%lang(it) %{_datadir}/doc/exo/html/it
179 #%lang(ja) %{_datadir}/doc/exo/html/ja
180 #%lang(pt) %{_datadir}/doc/exo/html/pt
181 #%lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
182 #%lang(ru) %{_datadir}/doc/exo/html/ru
183 #%lang(sv) %{_datadir}/doc/exo/html/sv
184 #%lang(tr) %{_datadir}/doc/exo/html/tr
185 #%lang(ug) %{_datadir}/doc/exo/html/ug
186 #%lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
187 %dir %{_datadir}/xfce4/helpers
188 %{_datadir}/xfce4/helpers/*.desktop
189 %{_desktopdir}/*.desktop
190 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
191 %{_iconsdir}/hicolor/*/apps/applications-internet.png
192 %{_iconsdir}/hicolor/*/apps/applications-other.png
193 %{_mandir}/man1/*.1*
194
195 %if %{with apidocs}
196 %files apidocs
197 %defattr(644,root,root,755)
198 %{_gtkdocdir}/exo-1
199 %endif
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libexo-1.so
204 %{_includedir}/exo-1
205 %{_pkgconfigdir}/exo-1.pc
206
207 %if %{with static_libs}
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libexo-1.a
211 %endif
This page took 0.088789 seconds and 3 git commands to generate.