]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- glib >= 2.29.x fixes
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         xfce_version    4.6.1
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.3.101
12 Release:        6
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  1c0eebb360f53eab70454b70e1bde36e
17 Patch0:         %{name}-gchar.patch
18 URL:            http://www.os-cillation.com/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gettext-devel
23 BuildRequires:  gtk+2-devel >= 2:2.10.6
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  hal-devel >= 0.5.7
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  libnotify-devel >= 0.4.0
29 BuildRequires:  libtool
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  perl-URI
32 BuildRequires:  pkgconfig
33 BuildRequires:  python-pygtk-devel >= 2:2.10.3
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.311
36 BuildRequires:  xfce4-dev-tools >= 4.6.0
37 Requires:       xfce4-dirs >= 4.6
38 Provides:       libexo
39 Obsoletes:      libexo
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Extension library to Xfce developed by os-cillation.
44
45 %description -l pl.UTF-8
46 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
47
48 %package -n xfce-preferred-applications
49 Summary:        The Xfce Preferred Applications framework
50 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
51 Group:          X11/Applications
52 Requires(post,postun):  gtk+2
53 Requires(post,postun):  hicolor-icon-theme
54 Requires:       %{name} = %{version}-%{release}
55
56 %description -n xfce-preferred-applications
57 The Xfce Preferred Applications framework.
58
59 %description -n xfce-preferred-applications -l pl.UTF-8
60 Struktura Preferowanych Aplikacji Xfce.
61
62 %package apidocs
63 Summary:        libexo API documentation
64 Summary(pl.UTF-8):      Dokumentacja API libexo
65 Group:          Documentation
66 Requires:       gtk-doc-common
67 Provides:       libexo-apidocs
68 Obsoletes:      libexo-apidocs
69
70 %description apidocs
71 libexo API documentation.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API libexo.
75
76 %package devel
77 Summary:        Header files for libexo library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gtk+2-devel >= 2:2.10.6
82 Requires:       hal-devel >= 0.5.7
83 Requires:       libxfce4util-devel >= %{xfce_version}
84 Provides:       libexo-devel
85 Obsoletes:      libexo-devel
86
87 %description devel
88 Header files for libexo library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki libexo.
92
93 %package static
94 Summary:        Static libexo library
95 Summary(pl.UTF-8):      Statyczna biblioteka libexo
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Provides:       libexo-static
99 Obsoletes:      libexo-static
100
101 %description static
102 Static libexo library.
103
104 %description static -l pl.UTF-8
105 Statyczna biblioteka libexo.
106
107 %package -n python-exo
108 Summary:        Python binding for libexo library
109 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
110 Group:          Libraries/Python
111 Requires:       %{name} = %{version}-%{release}
112 %pyrequires_eq  python-libs
113
114 %description -n python-exo
115 Python binding for libexo library.
116
117 %description -n python-exo -l pl.UTF-8
118 Wiązania Pythona do biblioteki libexo.
119
120 %package -n python-exo-devel
121 Summary:        Development files for libexo Python bindings
122 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
123 Group:          Libraries/Python
124 Requires:       python-exo = %{version}-%{release}
125
126 %description -n python-exo-devel
127 Development files for libexo Python bindings.
128
129 %description -n python-exo-devel -l pl.UTF-8
130 Pliki programistyczne wiązań Pythona do libexo.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %build
137 %{?with_apidocs:%{__gtkdocize}}
138 %{__intltoolize}
139 %{__libtoolize}
140 %{__aclocal}
141 %{__autoheader}
142 %{__automake}
143 %{__autoconf}
144 %configure \
145         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
146         --enable-hal \
147         --enable-notifications \
148         --enable-python \
149         --with-html-dir=%{_gtkdocdir} \
150         %{!?with_static_libs:--disable-static}
151
152 %{__make}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
161
162 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
163
164 %py_postclean
165
166 %find_lang libexo-0.3
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %post   -n xfce-preferred-applications
175 %update_icon_cache hicolor
176
177 %postun -n xfce-preferred-applications
178 %update_icon_cache hicolor
179
180 %files -f libexo-0.3.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog HACKING NEWS README TODO
183 %attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
185 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
187 %{_pixmapsdir}/exo-0.3
188
189 %files -n xfce-preferred-applications
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/*
192 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
193 %attr(755,root,root) %{_libdir}/exo-helper-0.3
194 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
195 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
196 %{_datadir}/xfce4/doc/C/*.html
197 %{_datadir}/xfce4/doc/C/images/*.png
198 %lang(da) %{_datadir}/xfce4/doc/da/*.html
199 %lang(es) %{_datadir}/xfce4/doc/es/*.html
200 %lang(es) %{_datadir}/xfce4/doc/es/images/*.png
201 %lang(fr) %{_datadir}/xfce4/doc/fr/*.html
202 %lang(fr) %{_datadir}/xfce4/doc/fr/images/*.png
203 %lang(gl) %{_datadir}/xfce4/doc/gl/*.html
204 %lang(id) %{_datadir}/xfce4/doc/id/*.html
205 %lang(id) %{_datadir}/xfce4/doc/id/images/*.png
206 %lang(it) %{_datadir}/xfce4/doc/it/*.html
207 %lang(it) %{_datadir}/xfce4/doc/it/images/*.png
208 %lang(ja) %{_datadir}/xfce4/doc/ja/*.html
209 %lang(ja) %{_datadir}/xfce4/doc/ja/images/*.png
210 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*.html
211 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/images/*.png
212 %lang(tr) %{_datadir}/xfce4/doc/tr/*.html
213 %lang(tr) %{_datadir}/xfce4/doc/tr/images/*.png
214 %dir %{_datadir}/xfce4/helpers
215 %{_datadir}/xfce4/helpers/*.desktop
216 %{_desktopdir}/*.desktop
217 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
218 %{_iconsdir}/hicolor/*/apps/applications-internet.png
219 %{_iconsdir}/hicolor/*/apps/applications-other.png
220 %{_mandir}/man1/*.1*
221
222 %if %{with apidocs}
223 %files apidocs
224 %defattr(644,root,root,755)
225 %{_gtkdocdir}/exo
226 %endif
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libexo-0.3.so
231 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
232 %{_libdir}/libexo-0.3.la
233 %{_libdir}/libexo-hal-0.3.la
234 %{_includedir}/exo-0.3
235 %{_pkgconfigdir}/exo-0.3.pc
236 %{_pkgconfigdir}/exo-hal-0.3.pc
237
238 %if %{with static_libs}
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libexo-0.3.a
242 %{_libdir}/libexo-hal-0.3.a
243 %endif
244
245 %files -n python-exo
246 %defattr(644,root,root,755)
247 %dir %{py_sitedir}/exo-0.3
248 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
249 %dir %{py_sitedir}/exo-0.3/exo
250 %{py_sitedir}/exo-0.3/exo/*.py[co]
251 %{py_sitescriptdir}/*.py[co]
252
253 %files -n python-exo-devel
254 %defattr(644,root,root,755)
255 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.084543 seconds and 3 git commands to generate.