]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
df9a6b29abd42b0ed9320fd3a2c59345cb345435
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5
6 %define         xfce_version    4.10.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.10.2
11 Release:        2
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://archive.xfce.org/src/xfce/exo/0.10/%{name}-%{version}.tar.bz2
15 # Source0-md5:  c70f2a217811bfba2e62f938d4b8f748
16 Patch0:         mate-terminal.patch
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.27.0
23 BuildRequires:  gtk+2-devel >= 2:2.14.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.601
33 BuildRequires:  xfce4-dev-tools >= 4.10.0
34 Requires:       glib2 >= 1:2.27.0
35 Requires:       xfce4-dirs >= 4.6
36 Provides:       libexo
37 Obsoletes:      libexo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Extension library to Xfce developed by os-cillation.
42
43 %description -l pl.UTF-8
44 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
45
46 %package -n xfce-preferred-applications
47 Summary:        The Xfce Preferred Applications framework
48 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk-update-icon-cache
52 Requires:       hicolor-icon-theme
53
54 %description -n xfce-preferred-applications
55 The Xfce Preferred Applications framework.
56
57 %description -n xfce-preferred-applications -l pl.UTF-8
58 Struktura Preferowanych Aplikacji Xfce.
59
60 %package apidocs
61 Summary:        libexo API documentation
62 Summary(pl.UTF-8):      Dokumentacja API libexo
63 Group:          Documentation
64 Requires:       gtk-doc-common
65 Provides:       libexo-apidocs
66 Obsoletes:      libexo-apidocs
67
68 %description apidocs
69 libexo API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API libexo.
73
74 %package devel
75 Summary:        Header files for libexo library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
77 Group:          X11/Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       gtk+2-devel >= 2:2.14.0
80 Requires:       libxfce4util-devel >= %{xfce_version}
81 Provides:       libexo-devel
82 Obsoletes:      libexo-devel
83
84 %description devel
85 Header files for libexo library.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki libexo.
89
90 %package static
91 Summary:        Static libexo library
92 Summary(pl.UTF-8):      Statyczna biblioteka libexo
93 Group:          X11/Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Provides:       libexo-static
96 Obsoletes:      libexo-static
97
98 %description static
99 Static libexo library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka libexo.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107
108 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
109
110 %build
111 %{?with_apidocs:%{__gtkdocize}}
112 %{__intltoolize}
113 %{__libtoolize}
114 %{__aclocal}
115 %{__autoheader}
116 %{__automake}
117 %{__autoconf}
118 %configure \
119         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
120         --with-html-dir=%{_gtkdocdir} \
121         %{!?with_static_libs:--disable-static} \
122         --disable-silent-rules
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133 # already exists as ur
134 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
135
136 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
137
138 %find_lang exo-1
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %post   -n xfce-preferred-applications
147 %update_icon_cache hicolor
148
149 %postun -n xfce-preferred-applications
150 %update_icon_cache hicolor
151
152 %files -f exo-1.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog HACKING NEWS README TODO
155 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
157 %{_pixmapsdir}/exo-1
158
159 %files -n xfce-preferred-applications
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/*
162 %dir %{_libdir}/xfce4/exo-1
163 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
164 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
166 %dir %{_datadir}/xfce4/helpers
167 %{_datadir}/xfce4/helpers/*.desktop
168 %{_desktopdir}/*.desktop
169 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
170 %{_iconsdir}/hicolor/*/apps/applications-internet.png
171 %{_iconsdir}/hicolor/*/apps/applications-other.png
172 %{_mandir}/man1/*.1*
173
174 %if %{with apidocs}
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/exo-1
178 %endif
179
180 %files devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libexo-1.so
183 %{_includedir}/exo-1
184 %{_pkgconfigdir}/exo-1.pc
185
186 %if %{with static_libs}
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libexo-1.a
190 %endif
This page took 0.050128 seconds and 2 git commands to generate.