]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
da6c86ef046bd4ed90c5cbed42f784f8e112c189
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5
6 %define         xfce_version    4.10.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.10.2
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://archive.xfce.org/src/xfce/exo/0.10/%{name}-%{version}.tar.bz2
15 # Source0-md5:  c70f2a217811bfba2e62f938d4b8f748
16 URL:            http://www.os-cillation.com/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.27.0
22 BuildRequires:  gtk+2-devel >= 2:2.14.0
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
24 BuildRequires:  gtk-doc-automake
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libtool
27 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
28 BuildRequires:  libxfce4util-devel >= %{xfce_version}
29 BuildRequires:  perl-URI
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.601
32 BuildRequires:  xfce4-dev-tools >= 4.10.0
33 Requires:       glib2 >= 1:2.27.0
34 Requires:       xfce4-dirs >= 4.6
35 Provides:       libexo
36 Obsoletes:      libexo
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Extension library to Xfce developed by os-cillation.
41
42 %description -l pl.UTF-8
43 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
44
45 %package -n xfce-preferred-applications
46 Summary:        The Xfce Preferred Applications framework
47 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
48 Group:          X11/Applications
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gtk-update-icon-cache
51 Requires:       hicolor-icon-theme
52
53 %description -n xfce-preferred-applications
54 The Xfce Preferred Applications framework.
55
56 %description -n xfce-preferred-applications -l pl.UTF-8
57 Struktura Preferowanych Aplikacji Xfce.
58
59 %package apidocs
60 Summary:        libexo API documentation
61 Summary(pl.UTF-8):      Dokumentacja API libexo
62 Group:          Documentation
63 Requires:       gtk-doc-common
64 Provides:       libexo-apidocs
65 Obsoletes:      libexo-apidocs
66
67 %description apidocs
68 libexo API documentation.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API libexo.
72
73 %package devel
74 Summary:        Header files for libexo library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       gtk+2-devel >= 2:2.14.0
79 Requires:       libxfce4util-devel >= %{xfce_version}
80 Provides:       libexo-devel
81 Obsoletes:      libexo-devel
82
83 %description devel
84 Header files for libexo library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki libexo.
88
89 %package static
90 Summary:        Static libexo library
91 Summary(pl.UTF-8):      Statyczna biblioteka libexo
92 Group:          X11/Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Provides:       libexo-static
95 Obsoletes:      libexo-static
96
97 %description static
98 Static libexo library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka libexo.
102
103 %prep
104 %setup -q
105
106 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
107
108 %build
109 %{?with_apidocs:%{__gtkdocize}}
110 %{__intltoolize}
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoheader}
114 %{__automake}
115 %{__autoconf}
116 %configure \
117         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
118         --with-html-dir=%{_gtkdocdir} \
119         %{!?with_static_libs:--disable-static} \
120         --disable-silent-rules
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
131
132 #mv -f $RPM_BUILD_ROOT%{_localedir}/{tl_PH,tl}
133 # already exists as ur
134 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
135
136 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
137
138 %find_lang exo-1
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %post   -n xfce-preferred-applications
147 %update_icon_cache hicolor
148
149 %postun -n xfce-preferred-applications
150 %update_icon_cache hicolor
151
152 %files -f exo-1.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog HACKING NEWS README TODO
155 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
157 %{_pixmapsdir}/exo-1
158
159 %files -n xfce-preferred-applications
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/*
162 %dir %{_libdir}/xfce4/exo-1
163 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
164 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
166 %dir %{_datadir}/xfce4/helpers
167 %{_datadir}/xfce4/helpers/*.desktop
168 %{_desktopdir}/*.desktop
169 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
170 %{_iconsdir}/hicolor/*/apps/applications-internet.png
171 %{_iconsdir}/hicolor/*/apps/applications-other.png
172 %{_mandir}/man1/*.1*
173
174 %if %{with apidocs}
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/exo-1
178 %endif
179
180 %files devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libexo-1.so
183 %{_includedir}/exo-1
184 %{_pkgconfigdir}/exo-1.pc
185
186 %if %{with static_libs}
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libexo-1.a
190 %endif
This page took 0.060784 seconds and 2 git commands to generate.