]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
cfe50564bb13aaf062dfef88fcc4a4fd717563d1
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5 #
6 %define         xfce_version    4.10.0
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.8.0
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://archive.xfce.org/xfce/4.10/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  189bd19210e1d7d8601be1cdf27bf259
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.27.0
23 BuildRequires:  gtk+2-devel >= 2:2.14.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-pygtk-devel >= 2:2.10.3
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.601
35 BuildRequires:  xfce4-dev-tools >= 4.10.0
36 Requires:       glib2 >= 1:2.27.0
37 Requires:       xfce4-dirs >= 4.6
38 Provides:       libexo
39 Obsoletes:      libexo
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Extension library to Xfce developed by os-cillation.
44
45 %description -l pl.UTF-8
46 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
47
48 %package -n xfce-preferred-applications
49 Summary:        The Xfce Preferred Applications framework
50 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
51 Group:          X11/Applications
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       gtk-update-icon-cache
54 Requires:       hicolor-icon-theme
55
56 %description -n xfce-preferred-applications
57 The Xfce Preferred Applications framework.
58
59 %description -n xfce-preferred-applications -l pl.UTF-8
60 Struktura Preferowanych Aplikacji Xfce.
61
62 %package apidocs
63 Summary:        libexo API documentation
64 Summary(pl.UTF-8):      Dokumentacja API libexo
65 Group:          Documentation
66 Requires:       gtk-doc-common
67 Provides:       libexo-apidocs
68 Obsoletes:      libexo-apidocs
69
70 %description apidocs
71 libexo API documentation.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API libexo.
75
76 %package devel
77 Summary:        Header files for libexo library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gtk+2-devel >= 2:2.14.0
82 Requires:       libxfce4util-devel >= %{xfce_version}
83 Provides:       libexo-devel
84 Obsoletes:      libexo-devel
85
86 %description devel
87 Header files for libexo library.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki libexo.
91
92 %package static
93 Summary:        Static libexo library
94 Summary(pl.UTF-8):      Statyczna biblioteka libexo
95 Group:          X11/Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Provides:       libexo-static
98 Obsoletes:      libexo-static
99
100 %description static
101 Static libexo library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka libexo.
105
106 %package -n python-exo
107 Summary:        Python binding for libexo library
108 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111 %pyrequires_eq  python-libs
112
113 %description -n python-exo
114 Python binding for libexo library.
115
116 %description -n python-exo -l pl.UTF-8
117 Wiązania Pythona do biblioteki libexo.
118
119 %package -n python-exo-devel
120 Summary:        Development files for libexo Python bindings
121 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
122 Group:          Libraries/Python
123 Requires:       python-exo = %{version}-%{release}
124
125 %description -n python-exo-devel
126 Development files for libexo Python bindings.
127
128 %description -n python-exo-devel -l pl.UTF-8
129 Pliki programistyczne wiązań Pythona do libexo.
130
131 %prep
132 %setup -q
133
134 %build
135 %{?with_apidocs:%{__gtkdocize}}
136 %{__intltoolize}
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoheader}
140 %{__automake}
141 %{__autoconf}
142 %configure \
143         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
144         --enable-notifications \
145         --enable-python \
146         --with-html-dir=%{_gtkdocdir} \
147         %{!?with_static_libs:--disable-static} \
148         --disable-silent-rules
149
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/exo-*/*.{a,la}
159 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
160
161 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,tl}
162 # already exists as ur
163 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
164
165 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
166
167 %py_postclean
168
169 %find_lang exo-1
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %post   -n xfce-preferred-applications
178 %update_icon_cache hicolor
179
180 %postun -n xfce-preferred-applications
181 %update_icon_cache hicolor
182
183 %files -f exo-1.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog HACKING NEWS README TODO
186 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
188 %{_pixmapsdir}/exo-1
189
190 %files -n xfce-preferred-applications
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/*
193 %dir %{_libdir}/xfce4/exo-1
194 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
195 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
197 %dir %{_datadir}/doc/exo
198 %dir %{_datadir}/doc/exo/html
199 %{_datadir}/doc/exo/html/exo-preferred-applications.css
200 %{_datadir}/doc/exo/html/C
201 %lang(bn) %{_datadir}/doc/exo/html/bn
202 %lang(ca) %{_datadir}/doc/exo/html/ca
203 %lang(da) %{_datadir}/doc/exo/html/da
204 %lang(de) %{_datadir}/doc/exo/html/de
205 %lang(el) %{_datadir}/doc/exo/html/el
206 %lang(es) %{_datadir}/doc/exo/html/es
207 %lang(fr) %{_datadir}/doc/exo/html/fr
208 %lang(gl) %{_datadir}/doc/exo/html/gl
209 %lang(id) %{_datadir}/doc/exo/html/id
210 %lang(it) %{_datadir}/doc/exo/html/it
211 %lang(ja) %{_datadir}/doc/exo/html/ja
212 %lang(pt) %{_datadir}/doc/exo/html/pt
213 %lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
214 %lang(ru) %{_datadir}/doc/exo/html/ru
215 %lang(sv) %{_datadir}/doc/exo/html/sv
216 %lang(tr) %{_datadir}/doc/exo/html/tr
217 %lang(ug) %{_datadir}/doc/exo/html/ug
218 %lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
219 %dir %{_datadir}/xfce4/helpers
220 %{_datadir}/xfce4/helpers/*.desktop
221 %{_desktopdir}/*.desktop
222 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
223 %{_iconsdir}/hicolor/*/apps/applications-internet.png
224 %{_iconsdir}/hicolor/*/apps/applications-other.png
225 %{_mandir}/man1/*.1*
226
227 %if %{with apidocs}
228 %files apidocs
229 %defattr(644,root,root,755)
230 %{_gtkdocdir}/exo-1
231 %endif
232
233 %files devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libexo-1.so
236 %{_includedir}/exo-1
237 %{_pkgconfigdir}/exo-1.pc
238
239 %if %{with static_libs}
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/libexo-1.a
243 %endif
244
245 %files -n python-exo
246 %defattr(644,root,root,755)
247 %dir %{py_sitedir}/exo-0.6
248 %attr(755,root,root) %{py_sitedir}/exo-0.6/_exo.so
249 %dir %{py_sitedir}/exo-0.6/exo
250 %{py_sitedir}/exo-0.6/exo/*.py[co]
251 %{py_sitescriptdir}/*.py[co]
252
253 %files -n python-exo-devel
254 %defattr(644,root,root,755)
255 %{_datadir}/pygtk/2.0/defs/exo-0.6
This page took 0.063865 seconds and 2 git commands to generate.