]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
c78bc6e48dd4d44f52dfed778fb85386fd7a1268
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         xfce_version    4.6.0
6 #
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.3.100
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
15 # Source0-md5:  ebded97ff55f43cd0fe6b16242992ecf
16 URL:            http://www.os-cillation.com/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel
20 BuildRequires:  gtk+2-devel >= 2:2.10.6
21 BuildRequires:  gtk-doc >= 1.7
22 BuildRequires:  hal-devel >= 0.5.7
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libnotify-devel >= 0.4.0
25 BuildRequires:  libtool
26 BuildRequires:  libxfce4util-devel >= %{xfce_version}
27 BuildRequires:  perl-URI
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-pygtk-devel >= 2:2.10.3
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.311
32 BuildRequires:  xfce4-dev-tools >= 4.6.0
33 Provides:       libexo
34 Obsoletes:      libexo
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Extension library to Xfce developed by os-cillation.
39
40 %description -l pl.UTF-8
41 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
42
43 %package -n xfce-preferred-applications
44 Summary:        The Xfce Preferred Applications framework
45 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
46 Group:          X11/Applications
47 Requires(post,postun):  gtk+2
48 Requires(post,postun):  hicolor-icon-theme
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n xfce-preferred-applications
52 The Xfce Preferred Applications framework.
53
54 %description -n xfce-preferred-applications -l pl.UTF-8
55 Struktura Preferowanych Aplikacji Xfce.
56
57 %package apidocs
58 Summary:        libexo API documentation
59 Summary(pl.UTF-8):      Dokumentacja API libexo
60 Group:          Documentation
61 Requires:       gtk-doc-common
62 Provides:       libexo-apidocs
63 Obsoletes:      libexo-apidocs
64
65 %description apidocs
66 libexo API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API libexo.
70
71 %package devel
72 Summary:        Header files for libexo library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       gtk+2-devel >= 2:2.10.6
77 Requires:       hal-devel >= 0.5.7
78 Requires:       libxfce4util-devel >= %{xfce_version}
79 Provides:       libexo-devel
80 Obsoletes:      libexo-devel
81
82 %description devel
83 Header files for libexo library.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki libexo.
87
88 %package static
89 Summary:        Static libexo library
90 Summary(pl.UTF-8):      Statyczna biblioteka libexo
91 Group:          X11/Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93 Provides:       libexo-static
94 Obsoletes:      libexo-static
95
96 %description static
97 Static libexo library.
98
99 %description static -l pl.UTF-8
100 Statyczna biblioteka libexo.
101
102 %package -n python-exo
103 Summary:        Python binding for libexo library
104 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
105 Group:          Libraries/Python
106 Requires:       %{name} = %{version}-%{release}
107 %pyrequires_eq  python-libs
108
109 %description -n python-exo
110 Python binding for libexo library.
111
112 %description -n python-exo -l pl.UTF-8
113 Wiązania Pythona do biblioteki libexo.
114
115 %package -n python-exo-devel
116 Summary:        Development files for libexo Python bindings
117 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
118 Group:          Libraries/Python
119 Requires:       python-exo = %{version}-%{release}
120
121 %description -n python-exo-devel
122 Development files for libexo Python bindings.
123
124 %description -n python-exo-devel -l pl.UTF-8
125 Pliki programistyczne wiązań Pythona do libexo.
126
127 %prep
128 %setup -q
129
130 %build
131 %{__intltoolize}
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoheader}
135 %{__automake}
136 %{__autoconf}
137 %configure \
138         --enable-hal \
139         --enable-gtk-doc \
140         --enable-notifications \
141         --with-html-dir=%{_gtkdocdir} \
142         %{!?with_static_libs:--disable-static} \
143         --enable-python
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 mv $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
153 mv $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
154
155 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
156
157 %py_postclean
158
159 %find_lang libexo-0.3
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post   -p /sbin/ldconfig
165 %postun -p /sbin/ldconfig
166
167 %post   -n xfce-preferred-applications
168 %update_icon_cache hicolor
169
170 %postun -n xfce-preferred-applications
171 %update_icon_cache hicolor
172
173 %files -f libexo-0.3.lang
174 %defattr(644,root,root,755)
175 %doc AUTHORS ChangeLog HACKING NEWS README TODO
176 %attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
178 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
180 %{_pixmapsdir}/exo-0.3
181
182 %files -n xfce-preferred-applications
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_bindir}/*
185 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
186 %attr(755,root,root) %{_libdir}/exo-helper-0.3
187 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
189 %{_datadir}/xfce4/doc/C/*
190 %lang(es) %{_datadir}/xfce4/doc/es/*
191 %lang(fr) %{_datadir}/xfce4/doc/fr/*
192 %lang(id) %{_datadir}/xfce4/doc/id/*
193 %lang(ja) %{_datadir}/xfce4/doc/ja/*
194 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
195 %lang(tr) %{_datadir}/xfce4/doc/tr/*
196 %dir %{_datadir}/xfce4/helpers
197 %{_datadir}/xfce4/helpers/*.desktop
198 %{_desktopdir}/*.desktop
199 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
200 %{_iconsdir}/hicolor/*/apps/applications-internet.png
201 %{_iconsdir}/hicolor/*/apps/applications-other.png
202 %{_mandir}/man1/*.1*
203
204 %files apidocs
205 %defattr(644,root,root,755)
206 %{_gtkdocdir}/exo
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libexo-0.3.so
211 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
212 %{_libdir}/libexo-0.3.la
213 %{_libdir}/libexo-hal-0.3.la
214 %{_includedir}/exo-0.3
215 %{_pkgconfigdir}/exo-0.3.pc
216 %{_pkgconfigdir}/exo-hal-0.3.pc
217
218 %if %{with static_libs}
219 %files static
220 %defattr(644,root,root,755)
221 %{_libdir}/libexo-0.3.a
222 %{_libdir}/libexo-hal-0.3.a
223 %endif
224
225 %files -n python-exo
226 %defattr(644,root,root,755)
227 %dir %{py_sitedir}/exo-0.3
228 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
229 %dir %{py_sitedir}/exo-0.3/exo
230 %{py_sitedir}/exo-0.3/exo/*.py[co]
231 %{py_sitescriptdir}/*.py[co]
232
233 %files -n python-exo-devel
234 %defattr(644,root,root,755)
235 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.048283 seconds and 2 git commands to generate.