]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- rel.2, removed LDFLAGS
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            beta2
6 %define         xfce_version    4.3.90.2
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
10 Name:           libexo
11 Version:        0.3.1.8
12 Release:        0.%{_pre}.2
13 License:        GPL v2
14 Group:          Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}%{_pre}.tar.bz2
16 # Source0-md5:  b8465faab19e233d5edda12bdd4940b4
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.1
22 BuildRequires:  gtk-doc >= 1.0
23 BuildRequires:  libtool
24 BuildRequires:  libxfce4util-devel >= %{xfce_version}
25 BuildRequires:  pkgconfig
26 BuildRequires:  python-pygtk-devel >= 2:2.9.3
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
30 BuildRequires:  xfce-mcs-manager-devel >= %{xfce_version}
31 BuildRequires:  xorg-lib-libXt-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Extension library to Xfce developed by os-cillation.
36
37 %description -l pl
38 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
39
40 %package -n xfce-preferred-applications
41 Summary:        The Xfce Preferred Applications framework
42 Summary(pl):    Struktura Preferowanych Aplikacji Xfce
43 Group:          Applications
44 Requires(post,postun):  gtk+2 >= 2:2.10.0
45 Requires:       xfce-mcs-plugins >= %{xfce_version}
46
47 %description -n xfce-preferred-applications
48 The Xfce Preferred Applications framework.
49
50 %description -n xfce-preferred-applications -l pl
51 Struktura Preferowanych Aplikacji Xfce.
52
53 %package devel
54 Summary:        Header files for libexo library
55 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libxfce4util-devel >= %{xfce_version}
59
60 %description devel
61 Header files for libexo library.
62
63 %description devel -l pl
64 Pliki nag³ówkowe biblioteki libexo.
65
66 %package static
67 Summary:        Static libexo library
68 Summary(pl):    Statyczna biblioteka libexo
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static libexo library.
74
75 %description static -l pl
76 Statyczna biblioteka libexo.
77
78 %package -n python-exo
79 Summary:        Python binding for libexo library
80 Summary(pl):    Wi±zania Pythona do biblioteki libexo
81 Group:          Libraries/Python
82 Requires:       %{name} = %{version}-%{release}
83 %pyrequires_eq  python-libs
84
85 %description -n python-exo
86 Python binding for libexo library.
87
88 %description -n python-exo -l pl
89 Wi±zania Pythona do biblioteki libexo.
90
91 %package -n python-exo-devel
92 Summary:        Development files for libexo Python bindings
93 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
94 Group:          Libraries/Python
95 Requires:       python-exo = %{version}-%{release}
96
97 %description -n python-exo-devel
98 Development files for libexo Python bindings.
99
100 %description -n python-exo-devel -l pl
101 Pliki programistyczne wi±zañ Pythona do libexo.
102
103 %prep
104 %setup -q -n exo-%{version}%{_pre}
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__automake}
111 %{__autoconf}
112 %configure \
113         --with-html-dir=%{_gtkdocdir} \
114         %{!?with_static_libs:--disable-static} \
115         --enable-xfce-mcs-manager
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 rm -f $RPM_BUILD_ROOT%{_libdir}/xfce4/mcs-plugins/*.{la,a}
125 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
126
127 %py_postclean
128
129 %find_lang %{name}-0.3
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   -n xfce-preferred-applications
138 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
139
140 %postun -n xfce-preferred-applications
141 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
142
143 %files -f %{name}-0.3.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog HACKING NEWS README TODO
146 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
147
148 %files -n xfce-preferred-applications
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/*
151 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
152 %attr(755,root,root) %{_libdir}/exo-helper-0.3
153 %attr(755,root,root) %{_libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
155 %{_datadir}/xfce4/doc/C
156 %lang(ja) %{_datadir}/xfce4/doc/ja
157 %dir %{_datadir}/xfce4/helpers
158 %{_datadir}/xfce4/helpers/*.desktop
159 %{_desktopdir}/*.desktop
160 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
161 %{_iconsdir}/hicolor/*/apps/applications-internet.png
162 %{_iconsdir}/hicolor/*/apps/applications-other.png
163 %{_mandir}/man1/*.1*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/lib*.so
168 %{_libdir}/lib*.la
169 %{_includedir}/exo-0.3
170 %{_pkgconfigdir}/*.pc
171 # not present in beta ?
172 #%{_gtkdocdir}/exo
173
174 %if %{with static_libs}
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/lib*.a
178 %endif
179
180 %files -n python-exo
181 %defattr(644,root,root,755)
182 %dir %{py_sitedir}/exo-0.3
183 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
184 %dir %{py_sitedir}/exo-0.3/exo
185 %{py_sitedir}/exo-0.3/exo/*.py[co]
186 %{py_sitescriptdir}/*.py[co]
187
188 %files -n python-exo-devel
189 %defattr(644,root,root,755)
190 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.043665 seconds and 3 git commands to generate.