]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
a9733d52a27d71ebb2fa05dc27e4a173ba5f24ff
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         xfce_version    4.6.1
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.3.101
12 Release:        3
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  1c0eebb360f53eab70454b70e1bde36e
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-devel
22 BuildRequires:  gtk+2-devel >= 2:2.10.6
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
24 BuildRequires:  gtk-doc-automake
25 BuildRequires:  hal-devel >= 0.5.7
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libnotify-devel >= 0.4.0
28 BuildRequires:  libtool
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-pygtk-devel >= 2:2.10.3
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.311
35 BuildRequires:  xfce4-dev-tools >= 4.6.0
36 Provides:       libexo
37 Obsoletes:      libexo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Extension library to Xfce developed by os-cillation.
42
43 %description -l pl.UTF-8
44 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
45
46 %package -n xfce-preferred-applications
47 Summary:        The Xfce Preferred Applications framework
48 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
49 Group:          X11/Applications
50 Requires(post,postun):  gtk+2
51 Requires(post,postun):  hicolor-icon-theme
52 Requires:       %{name} = %{version}-%{release}
53
54 %description -n xfce-preferred-applications
55 The Xfce Preferred Applications framework.
56
57 %description -n xfce-preferred-applications -l pl.UTF-8
58 Struktura Preferowanych Aplikacji Xfce.
59
60 %package apidocs
61 Summary:        libexo API documentation
62 Summary(pl.UTF-8):      Dokumentacja API libexo
63 Group:          Documentation
64 Requires:       gtk-doc-common
65 Provides:       libexo-apidocs
66 Obsoletes:      libexo-apidocs
67
68 %description apidocs
69 libexo API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API libexo.
73
74 %package devel
75 Summary:        Header files for libexo library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
77 Group:          X11/Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       gtk+2-devel >= 2:2.10.6
80 Requires:       hal-devel >= 0.5.7
81 Requires:       libxfce4util-devel >= %{xfce_version}
82 Provides:       libexo-devel
83 Obsoletes:      libexo-devel
84
85 %description devel
86 Header files for libexo library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki libexo.
90
91 %package static
92 Summary:        Static libexo library
93 Summary(pl.UTF-8):      Statyczna biblioteka libexo
94 Group:          X11/Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Provides:       libexo-static
97 Obsoletes:      libexo-static
98
99 %description static
100 Static libexo library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka libexo.
104
105 %package -n python-exo
106 Summary:        Python binding for libexo library
107 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 %pyrequires_eq  python-libs
111
112 %description -n python-exo
113 Python binding for libexo library.
114
115 %description -n python-exo -l pl.UTF-8
116 Wiązania Pythona do biblioteki libexo.
117
118 %package -n python-exo-devel
119 Summary:        Development files for libexo Python bindings
120 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
121 Group:          Libraries/Python
122 Requires:       python-exo = %{version}-%{release}
123
124 %description -n python-exo-devel
125 Development files for libexo Python bindings.
126
127 %description -n python-exo-devel -l pl.UTF-8
128 Pliki programistyczne wiązań Pythona do libexo.
129
130 %prep
131 %setup -q
132
133 %build
134 %{?with_apidocs:%{__gtkdocize}}
135 %{__intltoolize}
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__automake}
140 %{__autoconf}
141 %configure \
142         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
143         --enable-hal \
144         --enable-notifications \
145         --enable-python \
146         --with-html-dir=%{_gtkdocdir} \
147         %{!?with_static_libs:--disable-static}
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
158
159 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
160
161 %py_postclean
162
163 %find_lang libexo-0.3
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %post   -n xfce-preferred-applications
172 %update_icon_cache hicolor
173
174 %postun -n xfce-preferred-applications
175 %update_icon_cache hicolor
176
177 %files -f libexo-0.3.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog HACKING NEWS README TODO
180 %attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
182 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
184 %{_pixmapsdir}/exo-0.3
185
186 %files -n xfce-preferred-applications
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/*
189 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
190 %attr(755,root,root) %{_libdir}/exo-helper-0.3
191 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
192 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
193 %{_datadir}/xfce4/doc/C/*
194 %lang(da) %{_datadir}/xfce4/doc/da/*
195 %lang(es) %{_datadir}/xfce4/doc/es/*
196 %lang(fr) %{_datadir}/xfce4/doc/fr/*
197 %lang(gl) %{_datadir}/xfce4/doc/gl/*
198 %lang(id) %{_datadir}/xfce4/doc/id/*
199 %lang(it) %{_datadir}/xfce4/doc/it/*
200 %lang(ja) %{_datadir}/xfce4/doc/ja/*
201 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
202 %lang(tr) %{_datadir}/xfce4/doc/tr/*
203 %dir %{_datadir}/xfce4/helpers
204 %{_datadir}/xfce4/helpers/*.desktop
205 %{_desktopdir}/*.desktop
206 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
207 %{_iconsdir}/hicolor/*/apps/applications-internet.png
208 %{_iconsdir}/hicolor/*/apps/applications-other.png
209 %{_mandir}/man1/*.1*
210
211 %if %{with apidocs}
212 %files apidocs
213 %defattr(644,root,root,755)
214 %{_gtkdocdir}/exo
215 %endif
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libexo-0.3.so
220 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
221 %{_libdir}/libexo-0.3.la
222 %{_libdir}/libexo-hal-0.3.la
223 %{_includedir}/exo-0.3
224 %{_pkgconfigdir}/exo-0.3.pc
225 %{_pkgconfigdir}/exo-hal-0.3.pc
226
227 %if %{with static_libs}
228 %files static
229 %defattr(644,root,root,755)
230 %{_libdir}/libexo-0.3.a
231 %{_libdir}/libexo-hal-0.3.a
232 %endif
233
234 %files -n python-exo
235 %defattr(644,root,root,755)
236 %dir %{py_sitedir}/exo-0.3
237 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
238 %dir %{py_sitedir}/exo-0.3/exo
239 %{py_sitedir}/exo-0.3/exo/*.py[co]
240 %{py_sitescriptdir}/*.py[co]
241
242 %files -n python-exo-devel
243 %defattr(644,root,root,755)
244 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.034701 seconds and 2 git commands to generate.