]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
a457bf710bf4b9146aae55eb0a6b732f9e856ad0
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         xfce_version    4.6.1
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.3.101
12 Release:        3
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  1c0eebb360f53eab70454b70e1bde36e
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.6
22 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
23 BuildRequires:  gtk-doc-automake
24 BuildRequires:  hal-devel >= 0.5.7
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libnotify-devel >= 0.4.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4util-devel >= %{xfce_version}
29 BuildRequires:  perl-URI
30 BuildRequires:  pkgconfig
31 BuildRequires:  python-pygtk-devel >= 2:2.10.3
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.311
34 BuildRequires:  xfce4-dev-tools >= 4.6.0
35 Provides:       libexo
36 Obsoletes:      libexo
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Extension library to Xfce developed by os-cillation.
41
42 %description -l pl.UTF-8
43 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
44
45 %package -n xfce-preferred-applications
46 Summary:        The Xfce Preferred Applications framework
47 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
48 Group:          X11/Applications
49 Requires(post,postun):  gtk+2
50 Requires(post,postun):  hicolor-icon-theme
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n xfce-preferred-applications
54 The Xfce Preferred Applications framework.
55
56 %description -n xfce-preferred-applications -l pl.UTF-8
57 Struktura Preferowanych Aplikacji Xfce.
58
59 %package apidocs
60 Summary:        libexo API documentation
61 Summary(pl.UTF-8):      Dokumentacja API libexo
62 Group:          Documentation
63 Requires:       gtk-doc-common
64 Provides:       libexo-apidocs
65 Obsoletes:      libexo-apidocs
66
67 %description apidocs
68 libexo API documentation.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API libexo.
72
73 %package devel
74 Summary:        Header files for libexo library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       gtk+2-devel >= 2:2.10.6
79 Requires:       hal-devel >= 0.5.7
80 Requires:       libxfce4util-devel >= %{xfce_version}
81 Provides:       libexo-devel
82 Obsoletes:      libexo-devel
83
84 %description devel
85 Header files for libexo library.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki libexo.
89
90 %package static
91 Summary:        Static libexo library
92 Summary(pl.UTF-8):      Statyczna biblioteka libexo
93 Group:          X11/Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Provides:       libexo-static
96 Obsoletes:      libexo-static
97
98 %description static
99 Static libexo library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka libexo.
103
104 %package -n python-exo
105 Summary:        Python binding for libexo library
106 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 %pyrequires_eq  python-libs
110
111 %description -n python-exo
112 Python binding for libexo library.
113
114 %description -n python-exo -l pl.UTF-8
115 Wiązania Pythona do biblioteki libexo.
116
117 %package -n python-exo-devel
118 Summary:        Development files for libexo Python bindings
119 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
120 Group:          Libraries/Python
121 Requires:       python-exo = %{version}-%{release}
122
123 %description -n python-exo-devel
124 Development files for libexo Python bindings.
125
126 %description -n python-exo-devel -l pl.UTF-8
127 Pliki programistyczne wiązań Pythona do libexo.
128
129 %prep
130 %setup -q
131
132 %build
133 %{?with_apidocs:%{__gtkdocize}}
134 %{__intltoolize}
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__automake}
139 %{__autoconf}
140 %configure \
141         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
142         --enable-hal \
143         --enable-notifications \
144         --enable-python \
145         --with-html-dir=%{_gtkdocdir} \
146         %{!?with_static_libs:--disable-static}
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
157
158 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
159
160 %py_postclean
161
162 %find_lang libexo-0.3
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %post   -n xfce-preferred-applications
171 %update_icon_cache hicolor
172
173 %postun -n xfce-preferred-applications
174 %update_icon_cache hicolor
175
176 %files -f libexo-0.3.lang
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog HACKING NEWS README TODO
179 %attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
181 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
183 %{_pixmapsdir}/exo-0.3
184
185 %files -n xfce-preferred-applications
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/*
188 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
189 %attr(755,root,root) %{_libdir}/exo-helper-0.3
190 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
191 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
192 %{_datadir}/xfce4/doc/C/*
193 %lang(da) %{_datadir}/xfce4/doc/da/*
194 %lang(es) %{_datadir}/xfce4/doc/es/*
195 %lang(fr) %{_datadir}/xfce4/doc/fr/*
196 %lang(gl) %{_datadir}/xfce4/doc/gl/*
197 %lang(id) %{_datadir}/xfce4/doc/id/*
198 %lang(it) %{_datadir}/xfce4/doc/it/*
199 %lang(ja) %{_datadir}/xfce4/doc/ja/*
200 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
201 %lang(tr) %{_datadir}/xfce4/doc/tr/*
202 %dir %{_datadir}/xfce4/helpers
203 %{_datadir}/xfce4/helpers/*.desktop
204 %{_desktopdir}/*.desktop
205 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
206 %{_iconsdir}/hicolor/*/apps/applications-internet.png
207 %{_iconsdir}/hicolor/*/apps/applications-other.png
208 %{_mandir}/man1/*.1*
209
210 %if %{with apidocs}
211 %files apidocs
212 %defattr(644,root,root,755)
213 %{_gtkdocdir}/exo
214 %endif
215
216 %files devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libexo-0.3.so
219 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
220 %{_libdir}/libexo-0.3.la
221 %{_libdir}/libexo-hal-0.3.la
222 %{_includedir}/exo-0.3
223 %{_pkgconfigdir}/exo-0.3.pc
224 %{_pkgconfigdir}/exo-hal-0.3.pc
225
226 %if %{with static_libs}
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/libexo-0.3.a
230 %{_libdir}/libexo-hal-0.3.a
231 %endif
232
233 %files -n python-exo
234 %defattr(644,root,root,755)
235 %dir %{py_sitedir}/exo-0.3
236 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
237 %dir %{py_sitedir}/exo-0.3/exo
238 %{py_sitedir}/exo-0.3/exo/*.py[co]
239 %{py_sitescriptdir}/*.py[co]
240
241 %files -n python-exo-devel
242 %defattr(644,root,root,755)
243 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.072482 seconds and 2 git commands to generate.