]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
8876cc2a1df58504dcae20ebc8a3a6250c6d1464
[packages/exo.git] / exo.spec
1 # Conditional build:
2 %bcond_without  static_libs     # don't build static library
3 #
4 Summary:        Extension library to Xfce developed by os-cillation
5 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
6 Name:           libexo
7 Version:        0.3.0
8 Release:        1
9 License:        GPL v2
10 Group:          Libraries
11 Source0:        http://download.berlios.de/xfce-goodies/exo-%{version}.tar.bz2
12 # Source0-md5:  ffcd73ec6b34f19c81afdc3f1a97377b
13 URL:            http://www.os-cillation.com/
14 BuildRequires:  gettext-devel
15 BuildRequires:  gtk-doc >= 1.0
16 BuildRequires:  gtk+2-devel >= 2:2.4.0
17 BuildRequires:  libxfcegui4-devel >= 4.2.0
18 BuildRequires:  pkgconfig
19 BuildRequires:  python
20 BuildRequires:  python-pygtk-devel >= 2:2.4.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Extension library to Xfce developed by os-cillation.
25
26 %description -l pl
27 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
28
29 %package devel
30 Summary:        Header files for libexo library
31 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libxfcegui4-devel >= 4.2.0
35
36 %description devel
37 Header files for libexo library.
38
39 %description devel -l pl
40 Pliki nag³ówkowe biblioteki libexo.
41
42 %package static
43 Summary:        Static libexo library
44 Summary(pl):    Statyczna biblioteka libexo
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static libexo library.
50
51 %description static -l pl
52 Statyczna biblioteka libexo.
53
54 %package -n python-exo
55 Summary:        Python binding for libexo library
56 Summary(pl):    Wi±zania Pythona do biblioteki libexo
57 Group:          Libraries/Python
58 Requires:       %{name} = %{version}-%{release}
59 %pyrequires_eq  python-libs
60
61 %description -n python-exo
62 Python binding for libexo library.
63
64 %description -n python-exo -l pl
65 Wi±zania Pythona do biblioteki libexo.
66
67 %package -n python-exo-devel
68 Summary:        Development files for libexo Python bindings
69 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
70 Group:          Libraries/Python
71 Requires:       python-exo = %{version}-%{release}
72
73 %description -n python-exo-devel
74 Development files for libexo Python bindings.
75
76 %description -n python-exo-devel -l pl
77 Pliki programistyczne wi±zañ Pythona do libexo.
78
79 %prep
80 %setup -q -n exo-%{version}
81
82 %build
83 %configure \
84         --with-html-dir=%{_gtkdocdir} \
85         %{!?with_static_libs:--disable-static}
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
95
96 %find_lang %{name}-0.3
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files -f %{name}-0.3.lang
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog HACKING NEWS README TODO
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/lib*.so
112 %{_libdir}/lib*.la
113 %{_includedir}/exo-0.3
114 %{_pkgconfigdir}/*.pc
115 %{_gtkdocdir}/exo
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib*.a
121 %endif
122
123 %files -n python-exo
124 %defattr(644,root,root,755)
125 %dir %{py_sitedir}/exo-0.3
126 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
127 %dir %{py_sitedir}/exo-0.3/exo
128 %{py_sitedir}/exo-0.3/exo/*.py[co]
129 %{py_sitescriptdir}/*.py[co]
130
131 %files -n python-exo-devel
132 %defattr(644,root,root,755)
133 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.037708 seconds and 2 git commands to generate.