]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- up to 0.12.6
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5
6 %define         xfce_version    4.12.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.12.6
11 Release:        0.1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://archive.xfce.org/src/xfce/exo/0.12/%{name}-%{version}.tar.bz2
15 # Source0-md5:  e97267e5d5a41bf5b95e9bfdaa62e47a
16 Patch0:         mate-terminal.patch
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.30.0
23 BuildRequires:  gtk+2-devel >= 2:2.24.0
24 BuildRequires:  gtk+3-devel
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
26 BuildRequires:  gtk-doc-automake
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  libtool
29 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  perl-URI
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.601
34 BuildRequires:  xfce4-dev-tools >= 4.10.0
35 Requires:       glib2 >= 1:2.27.0
36 Requires:       xfce4-dirs >= 4.6
37 Provides:       libexo
38 Obsoletes:      libexo
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Extension library to Xfce developed by os-cillation.
43
44 %description -l pl.UTF-8
45 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
46
47 %package -n xfce-preferred-applications
48 Summary:        The Xfce Preferred Applications framework
49 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
50 Group:          X11/Applications
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       gtk-update-icon-cache
53 Requires:       hicolor-icon-theme
54
55 %description -n xfce-preferred-applications
56 The Xfce Preferred Applications framework.
57
58 %description -n xfce-preferred-applications -l pl.UTF-8
59 Struktura Preferowanych Aplikacji Xfce.
60
61 %package apidocs
62 Summary:        libexo API documentation
63 Summary(pl.UTF-8):      Dokumentacja API libexo
64 Group:          Documentation
65 Requires:       gtk-doc-common
66 Provides:       libexo-apidocs
67 Obsoletes:      libexo-apidocs
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 libexo API documentation.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API libexo.
77
78 %package devel
79 Summary:        Header files for libexo library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
81 Group:          X11/Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       gtk+2-devel >= 2:2.14.0
84 Requires:       gtk+3-devel
85 Requires:       libxfce4util-devel >= %{xfce_version}
86 Provides:       libexo-devel
87 Obsoletes:      libexo-devel
88
89 %description devel
90 Header files for libexo library.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki libexo.
94
95 %package static
96 Summary:        Static libexo library
97 Summary(pl.UTF-8):      Statyczna biblioteka libexo
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Provides:       libexo-static
101 Obsoletes:      libexo-static
102
103 %description static
104 Static libexo library.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka libexo.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
114
115 mkdir -p m4
116
117 %build
118 %{?with_apidocs:%{__gtkdocize}}
119 %{__intltoolize}
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoheader}
123 %{__automake}
124 %{__autoconf}
125 %configure \
126         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
127         --with-html-dir=%{_gtkdocdir} \
128         %{!?with_static_libs:--disable-static} \
129         --disable-silent-rules
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
139
140 # already exists as ur
141 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
142
143 # unknown / unsupported
144 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{hy_AM,ie}
145
146 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
147
148 %find_lang exo-1
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %post   -n xfce-preferred-applications
157 %update_icon_cache hicolor
158
159 %postun -n xfce-preferred-applications
160 %update_icon_cache hicolor
161
162 %files -f exo-1.lang
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog HACKING NEWS README TODO
165 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
167 %attr(755,root,root) %{_libdir}/libexo-2.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libexo-2.so.0
169 %{_pixmapsdir}/exo
170
171 %files -n xfce-preferred-applications
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/exo-desktop-item-edit
174 %attr(755,root,root) %{_bindir}/exo-open
175 %attr(755,root,root) %{_bindir}/exo-preferred-applications
176 %dir %{_libdir}/xfce4/exo
177 %attr(755,root,root) %{_libdir}/xfce4/exo/exo-compose-mail
178 %dir %{_libdir}/xfce4/exo-2
179 %attr(755,root,root) %{_libdir}/xfce4/exo-2/exo-helper-2
180 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
181 %dir %{_datadir}/xfce4/helpers
182 %{_datadir}/xfce4/helpers/*.desktop
183 %{_desktopdir}/*.desktop
184 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
185 %{_mandir}/man1/*.1*
186
187 %if %{with apidocs}
188 %files apidocs
189 %defattr(644,root,root,755)
190 %{_gtkdocdir}/exo-1
191 %endif
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/exo-csource
196 %attr(755,root,root) %{_libdir}/libexo-1.so
197 %attr(755,root,root) %{_libdir}/libexo-2.so
198 %{_includedir}/exo-1
199 %{_includedir}/exo-2
200 %{_pkgconfigdir}/exo-1.pc
201 %{_pkgconfigdir}/exo-2.pc
202
203 %if %{with static_libs}
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libexo-1.a
207 %{_libdir}/libexo-2.a
208 %endif
This page took 0.066348 seconds and 3 git commands to generate.