]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- added bcond_without static_libs
[packages/exo.git] / exo.spec
1 %bcond_without  static_libs     # don't build static library
2 Summary:        Extension library to Xfce developed by os-cillation
3 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
4 Name:           libexo
5 Version:        0.3.0
6 Release:        1
7 License:        GPL v2
8 Group:          Libraries
9 Source0:        http://download.berlios.de/xfce-goodies/exo-%{version}.tar.bz2
10 # Source0-md5:  ffcd73ec6b34f19c81afdc3f1a97377b
11 URL:            http://www.os-cillation.com/
12 BuildRequires:  gettext-devel
13 BuildRequires:  gtk-doc >= 1.0
14 BuildRequires:  gtk+2-devel >= 2:2.4.0
15 BuildRequires:  libxfcegui4-devel >= 4.2.0
16 BuildRequires:  pkgconfig
17 BuildRequires:  python
18 BuildRequires:  python-pygtk-devel >= 2:2.4.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Extension library to Xfce developed by os-cillation.
23
24 %description -l pl
25 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
26
27 %package devel
28 Summary:        Header files for libexo library
29 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libxfcegui4-devel >= 4.2.0
33
34 %description devel
35 Header files for libexo library.
36
37 %description devel -l pl
38 Pliki nag³ówkowe biblioteki libexo.
39
40 %package static
41 Summary:        Static libexo library
42 Summary(pl):    Statyczna biblioteka libexo
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static libexo library.
48
49 %description static -l pl
50 Statyczna biblioteka libexo.
51
52 %package -n python-exo
53 Summary:        Python binding for libexo library
54 Summary(pl):    Wi±zania Pythona do biblioteki libexo
55 Group:          Libraries/Python
56 Requires:       %{name} = %{version}-%{release}
57 %pyrequires_eq  python-libs
58
59 %description -n python-exo
60 Python binding for libexo library.
61
62 %description -n python-exo -l pl
63 Wi±zania Pythona do biblioteki libexo.
64
65 %package -n python-exo-devel
66 Summary:        Development files for libexo Python bindings
67 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
68 Group:          Libraries/Python
69 Requires:       python-exo = %{version}-%{release}
70
71 %description -n python-exo-devel
72 Development files for libexo Python bindings.
73
74 %description -n python-exo-devel -l pl
75 Pliki programistyczne wi±zañ Pythona do libexo.
76
77 %prep
78 %setup -q -n exo-%{version}
79
80 %build
81 %configure \
82         --with-html-dir=%{_gtkdocdir} \
83         %{!?with_static_libs:--disable-static}
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
93
94 %find_lang %{name}-0.3
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files -f %{name}-0.3.lang
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog HACKING NEWS README TODO
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/lib*.so
110 %{_libdir}/lib*.la
111 %{_includedir}/exo-0.3
112 %{_pkgconfigdir}/*.pc
113 %{_gtkdocdir}/exo
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
119 %endif
120
121 %files -n python-exo
122 %defattr(644,root,root,755)
123 %dir %{py_sitedir}/exo-0.3
124 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
125 %dir %{py_sitedir}/exo-0.3/exo
126 %{py_sitedir}/exo-0.3/exo/*.py[co]
127 %{py_sitescriptdir}/*.py[co]
128
129 %files -n python-exo-devel
130 %defattr(644,root,root,755)
131 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.083147 seconds and 3 git commands to generate.