]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- updated URL and dependencies, versioned Obsoletes, package fa locale
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5
6 %define         xfce_version    4.10.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.10.7
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://archive.xfce.org/src/xfce/exo/0.10/%{name}-%{version}.tar.bz2
15 # Source0-md5:  92ca200b8787cdd7494164cbc0ed8200
16 Patch0:         mate-terminal.patch
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.30.0
23 BuildRequires:  gtk+2-devel >= 2:2.24.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.601
33 BuildRequires:  xfce4-dev-tools >= 4.10.0
34 Requires:       glib2 >= 1:2.27.0
35 Requires:       xfce4-dirs >= 4.6
36 Provides:       libexo
37 Obsoletes:      libexo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Extension library to Xfce developed by os-cillation.
42
43 %description -l pl.UTF-8
44 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
45
46 %package -n xfce-preferred-applications
47 Summary:        The Xfce Preferred Applications framework
48 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk-update-icon-cache
52 Requires:       hicolor-icon-theme
53
54 %description -n xfce-preferred-applications
55 The Xfce Preferred Applications framework.
56
57 %description -n xfce-preferred-applications -l pl.UTF-8
58 Struktura Preferowanych Aplikacji Xfce.
59
60 %package apidocs
61 Summary:        libexo API documentation
62 Summary(pl.UTF-8):      Dokumentacja API libexo
63 Group:          Documentation
64 Requires:       gtk-doc-common
65 Provides:       libexo-apidocs
66 Obsoletes:      libexo-apidocs
67 %if "%{_rpmversion}" >= "5"
68 BuildArch:      noarch
69 %endif
70
71 %description apidocs
72 libexo API documentation.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API libexo.
76
77 %package devel
78 Summary:        Header files for libexo library
79 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
80 Group:          X11/Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       gtk+2-devel >= 2:2.14.0
83 Requires:       libxfce4util-devel >= %{xfce_version}
84 Provides:       libexo-devel
85 Obsoletes:      libexo-devel
86
87 %description devel
88 Header files for libexo library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki libexo.
92
93 %package static
94 Summary:        Static libexo library
95 Summary(pl.UTF-8):      Statyczna biblioteka libexo
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Provides:       libexo-static
99 Obsoletes:      libexo-static
100
101 %description static
102 Static libexo library.
103
104 %description static -l pl.UTF-8
105 Statyczna biblioteka libexo.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
112
113 mkdir -p m4
114
115 %build
116 %{?with_apidocs:%{__gtkdocize}}
117 %{__intltoolize}
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoheader}
121 %{__automake}
122 %{__autoconf}
123 %configure \
124         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
125         --with-html-dir=%{_gtkdocdir} \
126         %{!?with_static_libs:--disable-static} \
127         --disable-silent-rules
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
137
138 # already exists as ur
139 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
140
141 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
142
143 %find_lang exo-1
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %post   -n xfce-preferred-applications
152 %update_icon_cache hicolor
153
154 %postun -n xfce-preferred-applications
155 %update_icon_cache hicolor
156
157 %files -f exo-1.lang
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog HACKING NEWS README TODO
160 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
162 %{_pixmapsdir}/exo-1
163
164 %files -n xfce-preferred-applications
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/exo-desktop-item-edit
167 %attr(755,root,root) %{_bindir}/exo-open
168 %attr(755,root,root) %{_bindir}/exo-preferred-applications
169 %dir %{_libdir}/xfce4/exo-1
170 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
171 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
173 %dir %{_datadir}/xfce4/helpers
174 %{_datadir}/xfce4/helpers/*.desktop
175 %{_desktopdir}/*.desktop
176 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
177 %{_iconsdir}/hicolor/*/categories/applications-internet.png
178 %{_iconsdir}/hicolor/*/categories/applications-other.png
179 %{_mandir}/man1/*.1*
180
181 %if %{with apidocs}
182 %files apidocs
183 %defattr(644,root,root,755)
184 %{_gtkdocdir}/exo-1
185 %endif
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/exo-csource
190 %attr(755,root,root) %{_libdir}/libexo-1.so
191 %{_includedir}/exo-1
192 %{_pkgconfigdir}/exo-1.pc
193
194 %if %{with static_libs}
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libexo-1.a
198 %endif
This page took 0.062604 seconds and 3 git commands to generate.