]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- updated to 0.3.100
[packages/exo.git] / exo.spec
1 # TODO:
2 # - rename to exo.spec (like tar name)
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static library
6 #
7 %define         xfce_version    4.6.0
8 #
9 Summary:        Extension library to Xfce developed by os-cillation
10 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
11 Name:           libexo
12 Version:        0.3.100
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Libraries
16 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}.tar.bz2
17 # Source0-md5:  ebded97ff55f43cd0fe6b16242992ecf
18 URL:            http://www.os-cillation.com/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel
22 BuildRequires:  gtk+2-devel >= 2:2.10.6
23 BuildRequires:  gtk-doc >= 1.7
24 BuildRequires:  hal-devel >= 0.5.7
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libnotify-devel >= 0.4.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4util-devel >= %{xfce_version}
29 BuildRequires:  perl-URI
30 BuildRequires:  pkgconfig
31 BuildRequires:  python-pygtk-devel >= 2:2.10.3
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.311
34 BuildRequires:  xfce4-dev-tools >= 4.6.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Extension library to Xfce developed by os-cillation.
39
40 %description -l pl.UTF-8
41 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
42
43 %package -n xfce-preferred-applications
44 Summary:        The Xfce Preferred Applications framework
45 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
46 Group:          X11/Applications
47 Requires(post,postun):  gtk+2
48 Requires(post,postun):  hicolor-icon-theme
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n xfce-preferred-applications
52 The Xfce Preferred Applications framework.
53
54 %description -n xfce-preferred-applications -l pl.UTF-8
55 Struktura Preferowanych Aplikacji Xfce.
56
57 %package apidocs
58 Summary:        libexo API documentation
59 Summary(pl.UTF-8):      Dokumentacja API libexo
60 Group:          Documentation
61 Requires:       gtk-doc-common
62
63 %description apidocs
64 libexo API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API libexo.
68
69 %package devel
70 Summary:        Header files for libexo library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
72 Group:          X11/Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       gtk+2-devel >= 2:2.10.6
75 Requires:       hal-devel >= 0.5.7
76 Requires:       libxfce4util-devel >= %{xfce_version}
77
78 %description devel
79 Header files for libexo library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki libexo.
83
84 %package static
85 Summary:        Static libexo library
86 Summary(pl.UTF-8):      Statyczna biblioteka libexo
87 Group:          X11/Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static libexo library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka libexo.
95
96 %package -n python-exo
97 Summary:        Python binding for libexo library
98 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
99 Group:          Libraries/Python
100 Requires:       %{name} = %{version}-%{release}
101 %pyrequires_eq  python-libs
102
103 %description -n python-exo
104 Python binding for libexo library.
105
106 %description -n python-exo -l pl.UTF-8
107 Wiązania Pythona do biblioteki libexo.
108
109 %package -n python-exo-devel
110 Summary:        Development files for libexo Python bindings
111 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
112 Group:          Libraries/Python
113 Requires:       python-exo = %{version}-%{release}
114
115 %description -n python-exo-devel
116 Development files for libexo Python bindings.
117
118 %description -n python-exo-devel -l pl.UTF-8
119 Pliki programistyczne wiązań Pythona do libexo.
120
121 %prep
122 %setup -q -n exo-%{version}
123
124 %build
125 %{__intltoolize}
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoheader}
129 %{__automake}
130 %{__autoconf}
131 %configure \
132         --enable-hal \
133         --enable-gtk-doc \
134         --enable-notifications \
135         --with-html-dir=%{_gtkdocdir} \
136         %{!?with_static_libs:--disable-static} \
137         --enable-python
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 mv $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
147 mv $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
148
149 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
150
151 %py_postclean
152
153 %find_lang %{name}-0.3
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %post   -n xfce-preferred-applications
162 %update_icon_cache hicolor
163
164 %postun -n xfce-preferred-applications
165 %update_icon_cache hicolor
166
167 %files -f %{name}-0.3.lang
168 %defattr(644,root,root,755)
169 %doc AUTHORS ChangeLog HACKING NEWS README TODO
170 %attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
172 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
174 %{_pixmapsdir}/exo-0.3
175
176 %files -n xfce-preferred-applications
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/*
179 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
180 %attr(755,root,root) %{_libdir}/exo-helper-0.3
181 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
183 %{_datadir}/xfce4/doc/C/*
184 %lang(es) %{_datadir}/xfce4/doc/es/*
185 %lang(fr) %{_datadir}/xfce4/doc/fr/*
186 %lang(id) %{_datadir}/xfce4/doc/id/*
187 %lang(ja) %{_datadir}/xfce4/doc/ja/*
188 %lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
189 %lang(tr) %{_datadir}/xfce4/doc/tr/*
190 %dir %{_datadir}/xfce4/helpers
191 %{_datadir}/xfce4/helpers/*.desktop
192 %{_desktopdir}/*.desktop
193 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
194 %{_iconsdir}/hicolor/*/apps/applications-internet.png
195 %{_iconsdir}/hicolor/*/apps/applications-other.png
196 %{_mandir}/man1/*.1*
197
198 %files apidocs
199 %defattr(644,root,root,755)
200 %{_gtkdocdir}/exo
201
202 %files devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libexo-0.3.so
205 %attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
206 %{_libdir}/libexo-0.3.la
207 %{_libdir}/libexo-hal-0.3.la
208 %{_includedir}/exo-0.3
209 %{_pkgconfigdir}/exo-0.3.pc
210 %{_pkgconfigdir}/exo-hal-0.3.pc
211
212 %if %{with static_libs}
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libexo-0.3.a
216 %{_libdir}/libexo-hal-0.3.a
217 %endif
218
219 %files -n python-exo
220 %defattr(644,root,root,755)
221 %dir %{py_sitedir}/exo-0.3
222 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
223 %dir %{py_sitedir}/exo-0.3/exo
224 %{py_sitedir}/exo-0.3/exo/*.py[co]
225 %{py_sitescriptdir}/*.py[co]
226
227 %files -n python-exo-devel
228 %defattr(644,root,root,755)
229 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.062977 seconds and 3 git commands to generate.