]> git.pld-linux.org Git - packages/exo.git/blame_incremental - exo.spec
- merged from DEVEL
[packages/exo.git] / exo.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # disable gtk-doc
4%bcond_without static_libs # don't build static library
5#
6%define xfce_version 4.8.0
7#
8Summary: Extension library to Xfce developed by os-cillation
9Summary(pl.UTF-8): Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10Name: exo
11Version: 0.6.0
12Release: 1
13License: GPL v2
14Group: X11/Libraries
15Source0: http://archive.xfce.org/xfce/4.8/src/%{name}-%{version}.tar.bz2
16# Source0-md5: ac9deafdf9de426d8a03855ac549f424
17URL: http://www.os-cillation.com/
18BuildRequires: autoconf >= 2.50
19BuildRequires: automake
20BuildRequires: docbook-dtd412-xml
21BuildRequires: gettext-devel
22BuildRequires: glib2-devel >= 1:2.27.0
23BuildRequires: gtk+2-devel >= 2:2.14.0
24%{?with_apidocs:BuildRequires: gtk-doc >= 1.9}
25BuildRequires: gtk-doc-automake
26BuildRequires: intltool >= 0.35.0
27BuildRequires: libtool
28BuildRequires: libxfce4util-devel >= %{xfce_version}
29BuildRequires: perl-URI
30BuildRequires: pkgconfig
31BuildRequires: python-pygtk-devel >= 2:2.10.3
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.601
34BuildRequires: xfce4-dev-tools >= 4.8.0
35Requires: glib2 >= 1:2.27.0
36Requires: xfce4-dirs >= 4.6
37Provides: libexo
38Obsoletes: libexo
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Extension library to Xfce developed by os-cillation.
43
44%description -l pl.UTF-8
45Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
46
47%package -n xfce-preferred-applications
48Summary: The Xfce Preferred Applications framework
49Summary(pl.UTF-8): Struktura Preferowanych Aplikacji Xfce
50Group: X11/Applications
51Requires: %{name} = %{version}-%{release}
52Requires: gtk-update-icon-cache
53Requires: hicolor-icon-theme
54
55%description -n xfce-preferred-applications
56The Xfce Preferred Applications framework.
57
58%description -n xfce-preferred-applications -l pl.UTF-8
59Struktura Preferowanych Aplikacji Xfce.
60
61%package apidocs
62Summary: libexo API documentation
63Summary(pl.UTF-8): Dokumentacja API libexo
64Group: Documentation
65Requires: gtk-doc-common
66Provides: libexo-apidocs
67Obsoletes: libexo-apidocs
68
69%description apidocs
70libexo API documentation.
71
72%description apidocs -l pl.UTF-8
73Dokumentacja API libexo.
74
75%package devel
76Summary: Header files for libexo library
77Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libexo
78Group: X11/Development/Libraries
79Requires: %{name} = %{version}-%{release}
80Requires: gtk+2-devel >= 2:2.14.0
81Requires: libxfce4util-devel >= %{xfce_version}
82Provides: libexo-devel
83Obsoletes: libexo-devel
84
85%description devel
86Header files for libexo library.
87
88%description devel -l pl.UTF-8
89Pliki nagłówkowe biblioteki libexo.
90
91%package static
92Summary: Static libexo library
93Summary(pl.UTF-8): Statyczna biblioteka libexo
94Group: X11/Development/Libraries
95Requires: %{name}-devel = %{version}-%{release}
96Provides: libexo-static
97Obsoletes: libexo-static
98
99%description static
100Static libexo library.
101
102%description static -l pl.UTF-8
103Statyczna biblioteka libexo.
104
105%package -n python-exo
106Summary: Python binding for libexo library
107Summary(pl.UTF-8): Wiązania Pythona do biblioteki libexo
108Group: Libraries/Python
109Requires: %{name} = %{version}-%{release}
110%pyrequires_eq python-libs
111
112%description -n python-exo
113Python binding for libexo library.
114
115%description -n python-exo -l pl.UTF-8
116Wiązania Pythona do biblioteki libexo.
117
118%package -n python-exo-devel
119Summary: Development files for libexo Python bindings
120Summary(pl.UTF-8): Pliki programistyczne wiązań Pythona do libexo
121Group: Libraries/Python
122Requires: python-exo = %{version}-%{release}
123
124%description -n python-exo-devel
125Development files for libexo Python bindings.
126
127%description -n python-exo-devel -l pl.UTF-8
128Pliki programistyczne wiązań Pythona do libexo.
129
130%prep
131%setup -q
132
133%build
134%{?with_apidocs:%{__gtkdocize}}
135%{__intltoolize}
136%{__libtoolize}
137%{__aclocal}
138%{__autoheader}
139%{__automake}
140%{__autoconf}
141%configure \
142 --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
143 --enable-notifications \
144 --enable-python \
145 --with-html-dir=%{_gtkdocdir} \
146 %{!?with_static_libs:--disable-static} \
147 --disable-silent-rules
148
149%{__make}
150
151%install
152rm -rf $RPM_BUILD_ROOT
153
154%{__make} install \
155 DESTDIR=$RPM_BUILD_ROOT
156
157%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/exo-*/*.{a,la}
158%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
159
160%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,ur_PK}
161
162%{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
163
164rm -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
165
166%py_postclean
167
168%find_lang exo-1
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post -p /sbin/ldconfig
174%postun -p /sbin/ldconfig
175
176%post -n xfce-preferred-applications
177%update_icon_cache hicolor
178
179%postun -n xfce-preferred-applications
180%update_icon_cache hicolor
181
182%files -f exo-1.lang
183%defattr(644,root,root,755)
184%doc AUTHORS ChangeLog HACKING NEWS README TODO
185%attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
186%attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
187%{_pixmapsdir}/exo-1
188
189%files -n xfce-preferred-applications
190%defattr(644,root,root,755)
191%attr(755,root,root) %{_bindir}/*
192%dir %{_libdir}/xfce4/exo-1
193%attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
194%attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
195%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
196%dir %{_datadir}/doc/exo
197%dir %{_datadir}/doc/exo/html
198%{_datadir}/doc/exo/html/exo-preferred-applications.css
199%{_datadir}/doc/exo/html/C
200%lang(bn) %{_datadir}/doc/exo/html/bn
201%lang(ca) %{_datadir}/doc/exo/html/ca
202%lang(da) %{_datadir}/doc/exo/html/da
203%lang(de) %{_datadir}/doc/exo/html/de
204%lang(el) %{_datadir}/doc/exo/html/el
205%lang(es) %{_datadir}/doc/exo/html/es
206%lang(fr) %{_datadir}/doc/exo/html/fr
207%lang(gl) %{_datadir}/doc/exo/html/gl
208%lang(id) %{_datadir}/doc/exo/html/id
209%lang(it) %{_datadir}/doc/exo/html/it
210%lang(ja) %{_datadir}/doc/exo/html/ja
211%lang(pt) %{_datadir}/doc/exo/html/pt
212%lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
213%lang(ru) %{_datadir}/doc/exo/html/ru
214%lang(sv) %{_datadir}/doc/exo/html/sv
215%lang(tr) %{_datadir}/doc/exo/html/tr
216%lang(ug) %{_datadir}/doc/exo/html/ug
217%lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
218%dir %{_datadir}/xfce4/helpers
219%{_datadir}/xfce4/helpers/*.desktop
220%{_desktopdir}/*.desktop
221%{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
222%{_iconsdir}/hicolor/*/apps/applications-internet.png
223%{_iconsdir}/hicolor/*/apps/applications-other.png
224%{_mandir}/man1/*.1*
225
226%if %{with apidocs}
227%files apidocs
228%defattr(644,root,root,755)
229%{_gtkdocdir}/exo-1
230%endif
231
232%files devel
233%defattr(644,root,root,755)
234%attr(755,root,root) %{_libdir}/libexo-1.so
235%{_includedir}/exo-1
236%{_pkgconfigdir}/exo-1.pc
237
238%if %{with static_libs}
239%files static
240%defattr(644,root,root,755)
241%{_libdir}/libexo-1.a
242%endif
243
244%files -n python-exo
245%defattr(644,root,root,755)
246%dir %{py_sitedir}/exo-0.6
247%attr(755,root,root) %{py_sitedir}/exo-0.6/_exo.so
248%dir %{py_sitedir}/exo-0.6/exo
249%{py_sitedir}/exo-0.6/exo/*.py[co]
250%{py_sitescriptdir}/*.py[co]
251
252%files -n python-exo-devel
253%defattr(644,root,root,755)
254%{_datadir}/pygtk/2.0/defs/exo-0.6
This page took 0.068623 seconds and 4 git commands to generate.