]> git.pld-linux.org Git - packages/exo.git/blame - exo.spec
- obsolete
[packages/exo.git] / exo.spec
CommitLineData
1c0714b9
PG
1# TODO:
2# - rename to exo.spec (like tar name)
22fe3d17 3#
3edba695 4# Conditional build:
3eb704f5 5%bcond_without static_libs # don't build static library
3edba695 6#
849ed81e 7%define xfce_version 4.6.0
1f492905 8#
c4ca9554 9Summary: Extension library to Xfce developed by os-cillation
3800417d 10Summary(pl.UTF-8): Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
c4ca9554 11Name: libexo
849ed81e
MB
12Version: 0.3.100
13Release: 1
c4ca9554 14License: GPL v2
849ed81e 15Group: X11/Libraries
0ab17a4e 16Source0: http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}.tar.bz2
849ed81e 17# Source0-md5: ebded97ff55f43cd0fe6b16242992ecf
c4ca9554 18URL: http://www.os-cillation.com/
1f492905 19BuildRequires: autoconf >= 2.50
20BuildRequires: automake
8607d679 21BuildRequires: gettext-devel
aa64eb26 22BuildRequires: gtk+2-devel >= 2:2.10.6
0ab17a4e 23BuildRequires: gtk-doc >= 1.7
849ed81e 24BuildRequires: hal-devel >= 0.5.7
737f4d4f 25BuildRequires: intltool >= 0.35.0
0ab17a4e 26BuildRequires: libnotify-devel >= 0.4.0
849ed81e 27BuildRequires: libtool
1f492905 28BuildRequires: libxfce4util-devel >= %{xfce_version}
d31d715c 29BuildRequires: perl-URI
8b122451 30BuildRequires: pkgconfig
aa64eb26 31BuildRequires: python-pygtk-devel >= 2:2.10.3
1f492905 32BuildRequires: rpm-pythonprov
0ab17a4e 33BuildRequires: rpmbuild(macros) >= 1.311
849ed81e 34BuildRequires: xfce4-dev-tools >= 4.6.0
c4ca9554
AG
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Extension library to Xfce developed by os-cillation.
39
8d7f3270
JR
40%description -l pl.UTF-8
41Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
c4ca9554 42
1f492905 43%package -n xfce-preferred-applications
44Summary: The Xfce Preferred Applications framework
3800417d 45Summary(pl.UTF-8): Struktura Preferowanych Aplikacji Xfce
849ed81e 46Group: X11/Applications
0ab17a4e 47Requires(post,postun): gtk+2
737f4d4f 48Requires(post,postun): hicolor-icon-theme
849ed81e 49Requires: %{name} = %{version}-%{release}
1f492905 50
51%description -n xfce-preferred-applications
52The Xfce Preferred Applications framework.
53
8d7f3270 54%description -n xfce-preferred-applications -l pl.UTF-8
1f492905 55Struktura Preferowanych Aplikacji Xfce.
56
0ab17a4e
MB
57%package apidocs
58Summary: libexo API documentation
3800417d 59Summary(pl.UTF-8): Dokumentacja API libexo
0ab17a4e
MB
60Group: Documentation
61Requires: gtk-doc-common
62
63%description apidocs
64libexo API documentation.
65
8d7f3270 66%description apidocs -l pl.UTF-8
0ab17a4e
MB
67Dokumentacja API libexo.
68
c4ca9554
AG
69%package devel
70Summary: Header files for libexo library
3800417d 71Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libexo
849ed81e 72Group: X11/Development/Libraries
c4ca9554 73Requires: %{name} = %{version}-%{release}
849ed81e
MB
74Requires: gtk+2-devel >= 2:2.10.6
75Requires: hal-devel >= 0.5.7
1f492905 76Requires: libxfce4util-devel >= %{xfce_version}
c4ca9554
AG
77
78%description devel
79Header files for libexo library.
80
8d7f3270
JR
81%description devel -l pl.UTF-8
82Pliki nagłówkowe biblioteki libexo.
c4ca9554
AG
83
84%package static
85Summary: Static libexo library
3800417d 86Summary(pl.UTF-8): Statyczna biblioteka libexo
849ed81e 87Group: X11/Development/Libraries
c4ca9554
AG
88Requires: %{name}-devel = %{version}-%{release}
89
90%description static
91Static libexo library.
92
8d7f3270 93%description static -l pl.UTF-8
c4ca9554
AG
94Statyczna biblioteka libexo.
95
8b122451
JB
96%package -n python-exo
97Summary: Python binding for libexo library
3800417d 98Summary(pl.UTF-8): Wiązania Pythona do biblioteki libexo
8b122451
JB
99Group: Libraries/Python
100Requires: %{name} = %{version}-%{release}
101%pyrequires_eq python-libs
102
103%description -n python-exo
104Python binding for libexo library.
105
8d7f3270
JR
106%description -n python-exo -l pl.UTF-8
107Wiązania Pythona do biblioteki libexo.
8b122451
JB
108
109%package -n python-exo-devel
110Summary: Development files for libexo Python bindings
3800417d 111Summary(pl.UTF-8): Pliki programistyczne wiązań Pythona do libexo
8b122451
JB
112Group: Libraries/Python
113Requires: python-exo = %{version}-%{release}
114
115%description -n python-exo-devel
116Development files for libexo Python bindings.
117
8d7f3270
JR
118%description -n python-exo-devel -l pl.UTF-8
119Pliki programistyczne wiązań Pythona do libexo.
8b122451 120
c4ca9554 121%prep
0ab17a4e 122%setup -q -n exo-%{version}
c4ca9554
AG
123
124%build
737f4d4f 125%{__intltoolize}
1f492905 126%{__libtoolize}
127%{__aclocal}
128%{__autoheader}
129%{__automake}
130%{__autoconf}
c4ca9554 131%configure \
0ab17a4e
MB
132 --enable-hal \
133 --enable-gtk-doc \
134 --enable-notifications \
3eb704f5 135 --with-html-dir=%{_gtkdocdir} \
1f492905 136 %{!?with_static_libs:--disable-static} \
849ed81e 137 --enable-python
c4ca9554
AG
138%{__make}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143%{__make} install \
144 DESTDIR=$RPM_BUILD_ROOT
145
849ed81e
MB
146mv $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
147mv $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
148
8b122451
JB
149rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
150
22fe3d17
MB
151%py_postclean
152
8b122451 153%find_lang %{name}-0.3
2bc3c417 154
c4ca9554
AG
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post -p /sbin/ldconfig
159%postun -p /sbin/ldconfig
160
1f492905 161%post -n xfce-preferred-applications
737f4d4f 162%update_icon_cache hicolor
1f492905 163
164%postun -n xfce-preferred-applications
737f4d4f 165%update_icon_cache hicolor
1f492905 166
8b122451 167%files -f %{name}-0.3.lang
c4ca9554
AG
168%defattr(644,root,root,755)
169%doc AUTHORS ChangeLog HACKING NEWS README TODO
849ed81e
MB
170%attr(755,root,root) %{_libdir}/libexo-0.3.so.*.*.*
171%attr(755,root,root) %ghost %{_libdir}/libexo-0.3.so.0
172%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so.*.*.*
173%attr(755,root,root) %ghost %{_libdir}/libexo-hal-0.3.so.0
174%{_pixmapsdir}/exo-0.3
c4ca9554 175
1f492905 176%files -n xfce-preferred-applications
177%defattr(644,root,root,755)
178%attr(755,root,root) %{_bindir}/*
179%attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
180%attr(755,root,root) %{_libdir}/exo-helper-0.3
0ab17a4e 181%attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
1f492905 182%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
849ed81e
MB
183%{_datadir}/xfce4/doc/C/*
184%lang(es) %{_datadir}/xfce4/doc/es/*
185%lang(fr) %{_datadir}/xfce4/doc/fr/*
186%lang(id) %{_datadir}/xfce4/doc/id/*
187%lang(ja) %{_datadir}/xfce4/doc/ja/*
188%lang(pt_BR) %{_datadir}/xfce4/doc/pt_BR/*
189%lang(tr) %{_datadir}/xfce4/doc/tr/*
1f492905 190%dir %{_datadir}/xfce4/helpers
191%{_datadir}/xfce4/helpers/*.desktop
192%{_desktopdir}/*.desktop
193%{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
194%{_iconsdir}/hicolor/*/apps/applications-internet.png
195%{_iconsdir}/hicolor/*/apps/applications-other.png
196%{_mandir}/man1/*.1*
197
0ab17a4e
MB
198%files apidocs
199%defattr(644,root,root,755)
200%{_gtkdocdir}/exo
201
c4ca9554
AG
202%files devel
203%defattr(644,root,root,755)
849ed81e
MB
204%attr(755,root,root) %{_libdir}/libexo-0.3.so
205%attr(755,root,root) %{_libdir}/libexo-hal-0.3.so
206%{_libdir}/libexo-0.3.la
207%{_libdir}/libexo-hal-0.3.la
6dac1ab9 208%{_includedir}/exo-0.3
849ed81e
MB
209%{_pkgconfigdir}/exo-0.3.pc
210%{_pkgconfigdir}/exo-hal-0.3.pc
c4ca9554 211
3eb704f5 212%if %{with static_libs}
c4ca9554
AG
213%files static
214%defattr(644,root,root,755)
849ed81e
MB
215%{_libdir}/libexo-0.3.a
216%{_libdir}/libexo-hal-0.3.a
3eb704f5 217%endif
8b122451
JB
218
219%files -n python-exo
220%defattr(644,root,root,755)
221%dir %{py_sitedir}/exo-0.3
222%attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
223%dir %{py_sitedir}/exo-0.3/exo
224%{py_sitedir}/exo-0.3/exo/*.py[co]
225%{py_sitescriptdir}/*.py[co]
226
227%files -n python-exo-devel
228%defattr(644,root,root,755)
229%{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.055181 seconds and 4 git commands to generate.