]> git.pld-linux.org Git - packages/eximstate.git/blame - eximstate.spec
- tabs in preamble
[packages/eximstate.git] / eximstate.spec
CommitLineData
4045fdf9 1# TODO: what non-existing directory in /home/services/httpd/html is used for???
4d538166 2Summary: Monitoring exim installations
c27d21da 3Summary(pl.UTF-8): Monitorowanie instalacji exima
bdbabb7d 4Name: eximstate
5ab63431 5Version: 1.1
454a9d80 6Release: 3
bf24485c 7License: GPL
8Group: Applications/Mail
5a407d11 9Source0: http://www.olliecook.net/projects/eximstate/releases/%{name}-%{version}.tar.gz
77860a37 10# Source0-md5: e59355c849577dc5354e2614a5246aba
bdbabb7d
AM
11Source1: %{name}.init
12Source2: %{name}.sysconfig
13Source3: %{name}d.init
14Source4: %{name}d.sysconfig
15Patch0: %{name}-debug.patch
bf24485c 16URL: http://www.olliecook.net/projects/eximstate/
bdbabb7d 17BuildRequires: ncurses-devel
454a9d80 18BuildRequires: rpmbuild(macros) >= 1.268
1a290dae 19BuildRequires: rrdtool-devel >= 1.2.10
02b7497b 20Requires(post,preun): /sbin/chkconfig
bdbabb7d
AM
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _sysconfdir /etc/eximstate
24%define _localstatedir %{_var}/spool/%{name}
25
26%description
27eximstate is a server/client project for monitoring a number of Exim
28installations. The clients are installed on each of the mailservers
29running exim and the server runs on the monitoring server. Each client
30reads the queue on the mail server and sends the total number of
31messages, the number of frozen message, and the number of bounce
32messages to the server. The server stores this data and uses RRDtool
33to make a graphical representations of the data.
34
fa4a4908 35%description -l pl.UTF-8
8176275e 36eximstate to klient/serwer do monitorowania instalacji Exima. Klienty
fa4a4908
JR
37zainstalowane są na każdym serwerze poczty pracującym pod kontrolą
38Exima natomiast serwer eximstate na serwerze monitorującym. Każdy
39klient czyta kolejkę na serwerze pocztowym oraz przesyła informacje o
40całkowitej liczbie wiadomości, liczbie wiadomości zamrożonych oraz
41odbitych. Serwer eximstate zapisuje te dane oraz używa RRDtoola w celu
8176275e 42stworzenia graficznej reprezentacji danych.
bdbabb7d
AM
43
44%package client
af401bd6 45Summary: eximstate client
c27d21da 46Summary(pl.UTF-8): Klient eximstate
af401bd6 47Group: Networking
02b7497b 48Requires(post,preun): /sbin/chkconfig
af401bd6 49Requires: exim >= 3.0.0
861fc3db 50Requires: rc-scripts
bdbabb7d
AM
51
52%description client
53eximstate is a server/client project for monitoring a number of Exim
8176275e 54installations. This package contains client.
bdbabb7d 55
fa4a4908 56%description client -l pl.UTF-8
8176275e 57eximstate to klient/serwer do monitorowania instalacji Exima. Ten
58pakiet zawiera klienta.
bdbabb7d
AM
59
60%prep
61%setup -q
62%patch0 -p1
63
64%build
65%configure \
861fc3db 66 CPPFLAGS="-I/usr/include/ncurses" \
bdbabb7d
AM
67 --with-rrdtool=%{_prefix}
68%{__make}
69
70%install
71rm -rf $RPM_BUILD_ROOT
bf24485c 72install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},%{_localstatedir}}
bdbabb7d
AM
73
74%{__make} install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77cp $RPM_BUILD_ROOT%{_sbindir}/graphrrd.sh .
5ab63431 78sed -e 's#%{_prefix}/local/apache/htdocs/#/home/services/httpd/html/%{name}/#g' graphrrd.sh \
bdbabb7d
AM
79 > $RPM_BUILD_ROOT%{_sbindir}/graphrrd.sh
80
81install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
82install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
83install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}d
84install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}d
85
02b7497b
JB
86%clean
87rm -rf $RPM_BUILD_ROOT
88
bdbabb7d
AM
89%post
90/sbin/chkconfig --add %{name}d
454a9d80
ER
91if [ "$1" = 1 ]; then
92 echo "Run \"%{_sbindir}/makenewrrd.sh <host>\" for each your monitored host."
bdbabb7d 93fi
454a9d80 94%service %{name}d restart "%{name}d daemon"
bdbabb7d
AM
95
96%preun
454a9d80
ER
97if [ "$1" = "0" ]; then
98 %service %{name}d stop
99 /sbin/chkconfig --del %{name}d
bdbabb7d 100fi
bdbabb7d
AM
101
102%post client
103/sbin/chkconfig --add %{name}
454a9d80 104%service %{name} restart "%{name} daemon"
bdbabb7d
AM
105
106%preun client
454a9d80 107if [ "$1" = "0" ]; then
454a9d80
ER
108 %service %{name} stop
109 /sbin/chkconfig --del %{name}
bdbabb7d 110fi
bdbabb7d 111
bdbabb7d
AM
112%files
113%defattr(644,root,root,755)
114%doc AUTHORS ChangeLog NEWS README
115%attr(755,root,root) %{_bindir}/exitop
116%attr(755,root,root) %{_sbindir}/eximstated
117%attr(755,root,root) %{_sbindir}/*.sh
118
119%dir %{_sysconfdir}
120%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}d.conf
121%attr(755,root,root) %{_var}/spool/%{name}
122
123%attr(754,root,root) /etc/rc.d/init.d/%{name}d
124%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}d
125
126%files client
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_bindir}/eximstate
129%dir %{_sysconfdir}
130%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
131
132%attr(754,root,root) /etc/rc.d/init.d/%{name}
133%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
This page took 0.110326 seconds and 4 git commands to generate.