]> git.pld-linux.org Git - packages/eximq.git/blob - eximq.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/eximq.git] / eximq.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Supervising process for Exim's queue runners
3 Name:           eximq
4 # look into eximq.pl
5 Version:        0.4
6 # date of eximq file edit
7 Release:        0.20041227.1
8 License:        GPL
9 Group:          Applications/Mail
10 # see homepage
11 Source0:        %{name}.pl
12 Source1:        %{name}.args
13 Source2:        %{name}.init
14 Source3:        %{name}.tmpfiles
15 URL:            http://eximconf.alioth.debian.org/
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 Requires:       exim >= 2:4.00
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22
23 %prep
24 %setup -q -T -c
25
26 %build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,mail},%{_sbindir},/var/run/eximq} \
31         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
32
33 install %{SOURCE0} $RPM_BUILD_ROOT%{_sbindir}
34 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/eximq.args
35 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
36 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 /sbin/chkconfig --add %{name}
43 %service %{name} restart "%{name} daemon"
44
45 %preun
46 if [ "$1" = "0" ]; then
47         %service %{name} stop
48         /sbin/chkconfig --del %{name}
49 fi
50
51 %files
52 %defattr(644,root,root,755)
53 %attr(755,root,root) %{_sbindir}/eximq.pl
54 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/%{name}.args
55 %attr(754,root,root) /etc/rc.d/init.d/%{name}
56 /usr/lib/tmpfiles.d/%{name}.conf
57 %attr(755,exim,root) /var/run/eximq
This page took 0.057877 seconds and 3 git commands to generate.