]> git.pld-linux.org Git - packages/exim.git/commitdiff
- rel 4; allow different location for exim.conf auto/th/exim-4.92-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 16 Apr 2019 11:51:42 +0000 (13:51 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 16 Apr 2019 11:51:42 +0000 (13:51 +0200)
exim.init
exim.spec

index b7dd9ae07342f5a65097ce1e3d31e442924f79ca..d684c122e2099b4e007f7d28992c395f2df95a9d 100755 (executable)
--- a/exim.init
+++ b/exim.init
@@ -17,6 +17,8 @@
 
 QUEUE=1h
 
+EXIM_CONFIG=/etc/mail/exim.conf
+
 # Source exim configureation.
 if [ -f /etc/sysconfig/exim ]; then
        . /etc/sysconfig/exim
@@ -37,7 +39,7 @@ checkconfig() {
 
        RETVAL=0
        if [ $details = 1 ]; then
-               for CONFIG in /etc/mail/exim.conf $EXIM_EXTRA_CONFIGS; do
+               for CONFIG in "$EXIM_CONFIG" $EXIM_EXTRA_CONFIGS; do
                        run_cmd "Checking exim configuration ($CONFIG)" exim -bV -C $CONFIG
                        ret=$?
                        if [ $ret != 0 ]; then
@@ -45,8 +47,8 @@ checkconfig() {
                        fi
                done
        else
-               for CONFIG in /etc/mail/exim.conf $EXIM_EXTRA_CONFIGS; do
-                       exim -bV -C $CONFIG > /dev/null 2>&1
+               for CONFIG in "$EXIM_CONFIG" $EXIM_EXTRA_CONFIGS; do
+                       exim -bV -C "$CONFIG" > /dev/null 2>&1
                        ret=$?
                        if [ $ret != 0 ]; then
                                show "Checking %s configuration (%s)" "exim" "$CONFIG"; fail
@@ -71,7 +73,8 @@ start() {
        daemon /usr/bin/exim \
                -oP /var/spool/exim/exim-daemon.pid \
                $( is_yes "$ALLOW_TCP_CONNECTIONS" && echo -bd ) \
-               $( [ -n "$QUEUE" ] && echo -q$QUEUE )
+               $( [ -n "$QUEUE" ] && echo -q$QUEUE ) \
+               -C "$EXIM_CONFIG"
        for CONFIG in $EXIM_EXTRA_CONFIGS; do
                        msg_starting "Exim ($CONFIG)"
                        daemon exim \
index cdba6b68c1b0fc6048e5f3564d5955faa0772104..15d5bc4e4888ac8d9db3b964d4e34074e6ac5c1d 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -25,7 +25,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.92
-Release:       3
+Release:       4
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
This page took 0.423098 seconds and 4 git commands to generate.