]> git.pld-linux.org Git - packages/exim.git/commitdiff
- up to 4.94; enable EXPERIMENTAL_QUEUE_RAMP auto/th/exim-4.94-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 4 Jun 2020 07:01:21 +0000 (09:01 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 4 Jun 2020 07:01:21 +0000 (09:01 +0200)
branch.sh
exim-spam-timeout.patch
exim.spec
localscan_dlopen_exim_4.20_or_better.patch
zstd.patch [deleted file]

index ed248348c7926d59fbdca49275ad8e1b4a64225a..3442ca1755ca4618e4ec4901d31703426aaf8060 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://git.exim.org/exim.git
 package=exim
-tag=exim-4.93
-branch=exim-4.93+fixes
+tag=exim-4.94
+branch=exim-4.94+fixes
 out=$package-git.patch
 repo=$package.git
 
index 8ef66bd69aa008b81876908d1cca95bfcdd9bf92..67eb22a9ae06c8707e9f4308d5e146f5a4ae13c4 100644 (file)
@@ -4,8 +4,8 @@
      for (;;)
        {
        /*XXX could potentially use TFO early-data here */
--      if (  (spamd_cctx.sock = ip_streamsocket(sd->hostspec, &errstr, 5)) >= 0
-+      if (  (spamd_cctx.sock = ip_streamsocket(sd->hostspec, &errstr, 15)) >= 0
+-      if (  (spamd_cctx.sock = ip_streamsocket(sd->hostspec, &errstr, 5, NULL)) >= 0
++      if (  (spamd_cctx.sock = ip_streamsocket(sd->hostspec, &errstr, 15, NULL)) >= 0
           || sd->retry <= 0
         )
        break;
index e33e89aca61e7271d91c80babc6f60651ec285e8..7076b9acffed91f972b44558b9d4065b7e326575 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -23,15 +23,15 @@ Summary:    University of Cambridge Mail Transfer Agent
 Summary(pl.UTF-8):     Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
-Version:       4.93
-Release:       21
+Version:       4.94
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
 Source0:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-%{version}.tar.bz2
-# Source0-md5: d8a9342b2c0f2275717ba1f9fafbc3aa
+# Source0-md5: 5773e8a0379bd621d57bc66c36ffff17
 Source1:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-html-%{version}.tar.bz2
-# Source1-md5: 1985746cb7fbe8141c9f4b7fc6adece3
+# Source1-md5: e840b2f90c08bdaa8c7a356c5cab79dd
 Source2:       %{name}.init
 Source3:       %{name}.cron.db
 Source4:       %{name}4.conf
@@ -50,7 +50,7 @@ Source15:     %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
 Patch100:      %{name}-git.patch
-# Patch100-md5:        d4accdf0befbdde28ddec7dad4365f27
+# Patch100-md5:        551720b919d7bc3b21be4c51972444d8
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
@@ -58,7 +58,6 @@ Patch3:               exim-defs.patch
 Patch4:                %{name}4-Makefile-Default.patch
 # http://marc.merlins.org/linux/exim/files/sa-exim-cvs/localscan_dlopen_exim_4.20_or_better.patch
 Patch5:                localscan_dlopen_%{name}_4.20_or_better.patch
-Patch6:                zstd.patch
 
 Patch8:                %{name}-spam-timeout.patch
 
@@ -183,7 +182,6 @@ Pliki nagłówkowe dla Exima.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p2
 
 %patch8 -p1
 
@@ -204,6 +202,7 @@ EXPERIMENTAL_DCC=yes
 EXPERIMENTAL_PRDR=yes
 EXPERIMENTAL_DSN_INFO=yes
 EXPERIMENTAL_QUEUEFILE=yes
+EXPERIMENTAL_QUEUE_RAMP=yes
 SUPPORT_DANE=yes
 SUPPORT_I18N=yes
 SUPPORT_I18N_2008=yes
index cef1b2a5618b1a856958f3ba534c9bcdb368f626..10339dd94c3a825b9b1b212c560755d617f2bc0b 100644 (file)
@@ -279,14 +279,14 @@ Last-Update: 2019-10-20
 --- a/src/readconf.c
 +++ b/src/readconf.c
 @@ -203,6 +203,9 @@ static optionlist optionlist_config[] =
-   { "local_from_prefix",        opt_stringptr,   &local_from_prefix },
-   { "local_from_suffix",        opt_stringptr,   &local_from_suffix },
-   { "local_interfaces",         opt_stringptr,   &local_interfaces },
+   { "local_from_prefix",        opt_stringptr,   {&local_from_prefix} },
+   { "local_from_suffix",        opt_stringptr,   {&local_from_suffix} },
+   { "local_interfaces",         opt_stringptr,   {&local_interfaces} },
 +#ifdef DLOPEN_LOCAL_SCAN
-+  { "local_scan_path",          opt_stringptr,   &local_scan_path },
++  { "local_scan_path",          opt_stringptr,   {&local_scan_path} },
 +#endif
  #ifdef HAVE_LOCAL_SCAN
-   { "local_scan_timeout",       opt_time,        &local_scan_timeout },
+   { "local_scan_timeout",       opt_time,        {&local_scan_timeout} },
  #endif
 --- a/src/string.c
 +++ b/src/string.c
diff --git a/zstd.patch b/zstd.patch
deleted file mode 100644 (file)
index 3902498..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-commit 4f252517dc0e8eda6c1eb1031ac0bcd29b6a7a93
-Author: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Date:   Thu Jan 23 08:51:01 2020 +0100
-
-    Add support for zstd compressed .zst files (Bug 2515)
-
-diff --git a/src/src/exigrep.src b/src/src/exigrep.src
-index afd3538b6..835766fb4 100644
---- a/src/src/exigrep.src
-+++ b/src/src/exigrep.src
-@@ -159,7 +159,8 @@ my $compressors = {
-   gz   => { cmd => 'zcat',  args => '' },
-   bz2  => { cmd => 'bzcat', args => '' },
-   xz   => { cmd => 'xzcat', args => '' },
--  lzma => { cmd => 'lzma',  args => '-dc' }
-+  lzma => { cmd => 'lzma',  args => '-dc' },
-+  zst  => { cmd => 'zstdcat', args => '' },
- };
- my $csearch = 0;
-@@ -313,8 +314,8 @@ given host, for example.
- If no file names are given on the command line, the standard input is read.
--For known file extensions indicating compression (F<.gz>, F<.bz2>, F<.xz>, and F<.lzma>)
--a suitable de-compressor is used, if available.
-+For known file extensions indicating compression (F<.gz>, F<.bz2>, F<.xz>,
-+F<.lzma>, and F<.zst>) a suitable de-compressor is used, if available.
- The output is sent through a pager if a terminal is connected to STDOUT. As
- pager are considered: C<$ENV{PAGER}>, C<less>, C<more>.
This page took 0.259263 seconds and 4 git commands to generate.